core/linux-am33x update

This commit is contained in:
Kevin Mihelich 2016-10-24 18:11:04 +00:00
parent 4f66020aca
commit 7e3fa67b7f
2 changed files with 5 additions and 60 deletions

View file

@ -1,7 +1,7 @@
From 053ab81f7eb38d92a51b43c809301487f8d1d624 Mon Sep 17 00:00:00 2001
From 81d5fffe14ccafa00b9ea82e4278f759651039ff Mon Sep 17 00:00:00 2001
From: Mateusz Salamon <m.salamon@grinn-global.com>
Date: Fri, 20 May 2016 14:31:51 +0200
Subject: [PATCH 1/2] add lcd cape for chiliboard
Subject: [PATCH] add lcd cape for chiliboard
---
arch/arm/boot/dts/Makefile | 1 +
@ -10,10 +10,10 @@ Subject: [PATCH 1/2] add lcd cape for chiliboard
create mode 100644 arch/arm/boot/dts/am335x-chiliboard-lcd.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 1b6564a..877d6bb 100644
index 63c8f7d..d24887d 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -539,6 +539,7 @@ dtb-$(CONFIG_SOC_AM33XX) += \
@@ -567,6 +567,7 @@ dtb-$(CONFIG_SOC_AM33XX) += \
am335x-boneblack-emmc-overlay.dtb \
am335x-bonegreen.dtb \
am335x-chiliboard.dtb \
@ -171,5 +171,5 @@ index 0000000..bee7d42
+ };
+};
--
2.9.3
2.10.0

View file

@ -1,55 +0,0 @@
From ecfbe769de9664836468529eddcbd28b83776411 Mon Sep 17 00:00:00 2001
From: Franklin S Cooper Jr <fcooper@ti.com>
Date: Tue, 3 May 2016 10:56:47 -0500
Subject: [PATCH 2/2] clk: ti: am335x/am4372: Add tbclk to pwm node
Add tblck to the pwm nodes. This insures that the ehrpwm driver has access
to the time-based clk.
Do not remove similar entries for ehrpwm node. Later patches will switch
from using ehrpwm node name to pwm. But to maintain ABI compatibility we
shouldn't remove the old entries.
Signed-off-by: Franklin S Cooper Jr <fcooper@ti.com>
Acked-by: Stephen Boyd <sboyd@codeaurora.org>
Acked-by: Tero Kristo <t-kristo@ti.com>
Signed-off-by: Tony Lindgren <tony@atomide.com>
---
drivers/clk/ti/clk-33xx.c | 3 +++
drivers/clk/ti/clk-43xx.c | 6 ++++++
2 files changed, 9 insertions(+)
diff --git a/drivers/clk/ti/clk-33xx.c b/drivers/clk/ti/clk-33xx.c
index ef2ec64..0e47d95 100644
--- a/drivers/clk/ti/clk-33xx.c
+++ b/drivers/clk/ti/clk-33xx.c
@@ -108,6 +108,9 @@ static struct ti_dt_clk am33xx_clks[] = {
DT_CLK("48300200.ehrpwm", "tbclk", "ehrpwm0_tbclk"),
DT_CLK("48302200.ehrpwm", "tbclk", "ehrpwm1_tbclk"),
DT_CLK("48304200.ehrpwm", "tbclk", "ehrpwm2_tbclk"),
+ DT_CLK("48300200.pwm", "tbclk", "ehrpwm0_tbclk"),
+ DT_CLK("48302200.pwm", "tbclk", "ehrpwm1_tbclk"),
+ DT_CLK("48304200.pwm", "tbclk", "ehrpwm2_tbclk"),
{ .node_name = NULL },
};
diff --git a/drivers/clk/ti/clk-43xx.c b/drivers/clk/ti/clk-43xx.c
index 097fc90..7255aa8 100644
--- a/drivers/clk/ti/clk-43xx.c
+++ b/drivers/clk/ti/clk-43xx.c
@@ -115,6 +115,12 @@ static struct ti_dt_clk am43xx_clks[] = {
DT_CLK("48306200.ehrpwm", "tbclk", "ehrpwm3_tbclk"),
DT_CLK("48308200.ehrpwm", "tbclk", "ehrpwm4_tbclk"),
DT_CLK("4830a200.ehrpwm", "tbclk", "ehrpwm5_tbclk"),
+ DT_CLK("48300200.pwm", "tbclk", "ehrpwm0_tbclk"),
+ DT_CLK("48302200.pwm", "tbclk", "ehrpwm1_tbclk"),
+ DT_CLK("48304200.pwm", "tbclk", "ehrpwm2_tbclk"),
+ DT_CLK("48306200.pwm", "tbclk", "ehrpwm3_tbclk"),
+ DT_CLK("48308200.pwm", "tbclk", "ehrpwm4_tbclk"),
+ DT_CLK("4830a200.pwm", "tbclk", "ehrpwm5_tbclk"),
{ .node_name = NULL },
};
--
2.9.3