mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
community/linux-tools: fix
This commit is contained in:
parent
22f607ed37
commit
7e427f89c6
2 changed files with 41 additions and 0 deletions
|
@ -0,0 +1,39 @@
|
|||
From afe2e788d1da5d246b1453444d2d9d7dba767cb9 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 14 Jul 2019 21:34:17 -0600
|
||||
Subject: [PATCH] perf: fix debug printf for 32-bit
|
||||
|
||||
---
|
||||
tools/perf/util/session.c | 2 +-
|
||||
tools/perf/util/zstd.c | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tools/perf/util/session.c b/tools/perf/util/session.c
|
||||
index 54cf163347f7..aceb703e676d 100644
|
||||
--- a/tools/perf/util/session.c
|
||||
+++ b/tools/perf/util/session.c
|
||||
@@ -76,7 +76,7 @@ static int perf_session__process_compressed_event(struct perf_session *session,
|
||||
session->decomp_last = decomp;
|
||||
}
|
||||
|
||||
- pr_debug("decomp (B): %ld to %ld\n", src_size, decomp_size);
|
||||
+ pr_debug("decomp (B): %ld to %ld\n", (long)src_size, (long)decomp_size);
|
||||
|
||||
return 0;
|
||||
}
|
||||
diff --git a/tools/perf/util/zstd.c b/tools/perf/util/zstd.c
|
||||
index 23bdb9884576..f4382ed3c432 100644
|
||||
--- a/tools/perf/util/zstd.c
|
||||
+++ b/tools/perf/util/zstd.c
|
||||
@@ -100,7 +100,7 @@ size_t zstd_decompress_stream(struct zstd_data *data, void *src, size_t src_size
|
||||
ret = ZSTD_decompressStream(data->dstream, &output, &input);
|
||||
if (ZSTD_isError(ret)) {
|
||||
pr_err("failed to decompress (B): %ld -> %ld : %s\n",
|
||||
- src_size, output.size, ZSTD_getErrorName(ret));
|
||||
+ (long)src_size, (long)output.size, ZSTD_getErrorName(ret));
|
||||
break;
|
||||
}
|
||||
output.dst = dst + output.pos;
|
||||
--
|
||||
2.21.0
|
||||
|
|
@ -42,12 +42,14 @@ makedepends+=('ncurses')
|
|||
groups=("$pkgbase")
|
||||
source=("https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${pkgver}.tar.xz"
|
||||
"https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-$pkgver.1.xz"
|
||||
'0001-perf-fix-debug-printf-for-32-bit.patch'
|
||||
'cpupower.default'
|
||||
'cpupower.systemd'
|
||||
'cpupower.service'
|
||||
'usbipd.service')
|
||||
md5sums=('ddf994de00d7b18395886dd9b30b9262'
|
||||
'a45be902d46625f7b554f17bab3686f0'
|
||||
'79157a49024739b249e8f16e5b31eb31'
|
||||
'56883c159381ba89e50ab8ea65efec77'
|
||||
'34f5ecc19770a1abbcd0fd65bfd1f065'
|
||||
'86c4e419e4ba80835c330d49ba3f56ad'
|
||||
|
|
Loading…
Reference in a new issue