extra/libreoffice-fresh to 6.1.2-2

This commit is contained in:
Kevin Mihelich 2018-10-30 00:14:51 +00:00
parent d36a31971e
commit 7eb3eb0b16
2 changed files with 51 additions and 1 deletions

View file

@ -20,7 +20,7 @@ pkgbase=libreoffice-fresh
pkgname=('libreoffice-fresh-sdk' 'libreoffice-fresh')
_LOver=6.1.2.1
pkgver=6.1.2
pkgrel=1
pkgrel=2
arch=('x86_64')
license=('LGPL3')
url="http://www.libreoffice.org/"
@ -63,6 +63,7 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
${_additional_source_url2}/odfvalidator-1.2.0-incubating-SNAPSHOT-jar-with-dependencies+ODFTOOLKIT-460+ODFTOOLKIT-475.jar # for test suite
${_additional_source_url2}/185d60944ea767075d27247c3162b3bc-unowinreg.dll
make-pyuno-work-with-system-wide-module-install.diff
poppler-0.70.patch
libreoffice-fresh.sh libreoffice-fresh.csh)
noextract=(#boost_1_66_0.tar.bz2
35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
@ -102,6 +103,7 @@ sha256sums=('650c57b60f880db28e49e584f42018da9e714865dfa94fbb8391de15b58a3f91'
'702413413a5d8076c17fe79c0808dfba145a7260020f6c8627ea529a0cf83769'
'eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6'
'c463654a73ecfbc242ff109726fb4faecdbfb3d91affafe919b24bea65afb563'
'4cac21ffdb711803c0d5372c6b0ba04f1310afa7907081fdd01c11e68c1785bf'
'28c97effbe55e43a1370ab141c676cec9daba9e3dc408bec78136dfefc892a8b'
'7af3113c804e4d58c7de3b5ed10f515fc46e349a580ba56eebfc6e891acbef89')
@ -129,6 +131,9 @@ prepare() {
# fix not upstreamable pyuno paths - FS#54250
patch -Np1 -i ${srcdir}/make-pyuno-work-with-system-wide-module-install.diff
# fix build with poppler 0.70
patch -Np1 -i ../poppler-0.70.patch
#use the CFLAGS but remove the LibO overridden ones
for i in $CFLAGS; do
case "$i" in

View file

@ -0,0 +1,45 @@
From 557ee0a0f4e40b934c72515f41f3a605803ddb1d Mon Sep 17 00:00:00 2001
From: Evangelos Foutras <evangelos@foutrelis.com>
Date: Wed, 24 Oct 2018 17:48:53 +0300
Subject: [PATCH] fix build with poppler 0.70
---
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx | 4 ++++
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx | 4 ++++
2 files changed, 8 insertions(+)
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
index 575a90acb..99219f7e6 100644
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
@@ -578,7 +578,11 @@ void PDFOutDev::restoreState(GfxState*)
printf( "restoreState\n" );
}
+#if POPPLER_CHECK_VERSION(0, 70, 0)
+void PDFOutDev::setDefaultCTM(const double *pMat)
+#else
void PDFOutDev::setDefaultCTM(double *pMat)
+#endif
{
assert(pMat);
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
index da021a2a0..27440f2bb 100644
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
@@ -166,7 +166,11 @@ namespace pdfi
//----- initialization and control
// Set default transform matrix.
+#if POPPLER_CHECK_VERSION(0, 70, 0)
+ virtual void setDefaultCTM(const double *ctm) override;
+#else
virtual void setDefaultCTM(double *ctm) override;
+#endif
// Start a page.
virtual void startPage(int pageNum, GfxState *state
--
2.19.1