mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
added community/busybox
This commit is contained in:
parent
7e4996d731
commit
7ecdf5f8fe
4 changed files with 1145 additions and 0 deletions
41
community/busybox/PKGBUILD
Normal file
41
community/busybox/PKGBUILD
Normal file
|
@ -0,0 +1,41 @@
|
|||
# $Id$
|
||||
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
|
||||
# Contributor: Jens Pranaitis <jens@jenux.homelinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - don't build with musl-gcc
|
||||
|
||||
pkgname=busybox
|
||||
pkgver=1.23.1
|
||||
pkgrel=3.1
|
||||
pkgdesc="Utilities for rescue and embedded systems"
|
||||
arch=("i686" "x86_64")
|
||||
url="http://www.busybox.net"
|
||||
license=('GPL')
|
||||
makedepends=("make" "gcc" "sed" "ncurses")
|
||||
install=busybox.install
|
||||
source=("$url/downloads/$pkgname-$pkgver.tar.bz2"
|
||||
"config"
|
||||
ifplugd.patch)
|
||||
md5sums=('5c94d6301a964cd91619bd4d74605245'
|
||||
'71c99d75dda156dab162dece3bd424a5'
|
||||
'187adc8319e45be12d79e8db2c514d74')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
patch -p1 <$srcdir/ifplugd.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
cp $srcdir/config .config
|
||||
sed '1,1i#include <sys/resource.h>' -i include/libbb.h
|
||||
# if you want to run menuconfig uncomment the following line:
|
||||
# make menuconfig ; return 1
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
install -Dm755 busybox $pkgdir/usr/bin/busybox
|
||||
}
|
16
community/busybox/busybox.install
Normal file
16
community/busybox/busybox.install
Normal file
|
@ -0,0 +1,16 @@
|
|||
_tmp_dir=tmp/busybox.upgrade
|
||||
|
||||
post_install() {
|
||||
echo "You may want to do setuid on /usr/bin/busybox"
|
||||
echo " chmod 4555 /usr/bin/busybox"
|
||||
}
|
||||
|
||||
pre_upgrade() {
|
||||
mkdir ${_tmp_dir} || exit 1
|
||||
busybox stat -c %a usr/bin/busybox >${_tmp_dir}/busybox.upgrade.script
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
[ -f ${_tmp_dir}/busybox.upgrade.script ] && busybox chmod `busybox cat ${_tmp_dir}/busybox.upgrade.script` usr/bin/busybox
|
||||
busybox rm -rf ${_tmp_dir}
|
||||
}
|
1058
community/busybox/config
Normal file
1058
community/busybox/config
Normal file
File diff suppressed because it is too large
Load diff
30
community/busybox/ifplugd.patch
Normal file
30
community/busybox/ifplugd.patch
Normal file
|
@ -0,0 +1,30 @@
|
|||
networking/ifplugd.c | 9 +++++----
|
||||
1 file changed, 5 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/networking/ifplugd.c b/networking/ifplugd.c
|
||||
index b578f4c..8fad69a 100644
|
||||
--- a/networking/ifplugd.c
|
||||
+++ b/networking/ifplugd.c
|
||||
@@ -34,16 +34,17 @@
|
||||
#include "libbb.h"
|
||||
|
||||
#include "fix_u32.h"
|
||||
-#include <linux/if.h>
|
||||
-#include <linux/mii.h>
|
||||
-#include <linux/ethtool.h>
|
||||
#ifdef HAVE_NET_ETHERNET_H
|
||||
# include <net/ethernet.h>
|
||||
#endif
|
||||
+#include <syslog.h>
|
||||
+
|
||||
+#include <linux/if.h>
|
||||
+#include <linux/mii.h>
|
||||
+#include <linux/ethtool.h>
|
||||
#include <linux/netlink.h>
|
||||
#include <linux/rtnetlink.h>
|
||||
#include <linux/sockios.h>
|
||||
-#include <syslog.h>
|
||||
|
||||
#define __user
|
||||
#include <linux/wireless.h>
|
||||
|
Loading…
Reference in a new issue