mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/mesa-demos to 8.1.0-2
This commit is contained in:
parent
1bcd69e599
commit
7f1d9436eb
2 changed files with 106 additions and 4 deletions
|
@ -1,4 +1,4 @@
|
|||
# $Id: PKGBUILD 151280 2012-02-25 12:34:36Z pierre $
|
||||
# $Id$
|
||||
# Maintainer: Jan de Groot <jgc@archlinux.org>
|
||||
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
|
||||
|
||||
|
@ -7,7 +7,7 @@
|
|||
|
||||
pkgname='mesa-demos'
|
||||
pkgver=8.1.0
|
||||
pkgrel=1.1
|
||||
pkgrel=2
|
||||
arch=('i686' 'x86_64')
|
||||
pkgdesc="Mesa demos and tools"
|
||||
url="http://mesa3d.sourceforge.net"
|
||||
|
@ -15,9 +15,17 @@ license=('custom')
|
|||
depends=('libgl' 'glew')
|
||||
makedepends=('mesa')
|
||||
source=("ftp://ftp.freedesktop.org/pub/mesa/demos/${pkgver}/mesa-demos-${pkgver}.tar.bz2"
|
||||
'LICENSE')
|
||||
'LICENSE'
|
||||
drawtex-resolve-glDrawTexfOES-extension-function.patch)
|
||||
sha256sums=('9703fa0646b32a1e68d2abf5628f936f77bf97c69ffcaac90de380820a87a828'
|
||||
'7fdc119cf53c8ca65396ea73f6d10af641ba41ea1dd2bd44a824726e01c8b3f2')
|
||||
'7fdc119cf53c8ca65396ea73f6d10af641ba41ea1dd2bd44a824726e01c8b3f2'
|
||||
'963b3e45b2eccafea50fdab4f2fac17bd308f4c15522c00d4787b50ebb25423a')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/mesa-demos-${pkgver}"
|
||||
# merged upstream
|
||||
patch -Np1 -i ../drawtex-resolve-glDrawTexfOES-extension-function.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/mesa-demos-${pkgver}"
|
||||
|
|
|
@ -0,0 +1,94 @@
|
|||
From 9c326a34e088971a3c11b2e5289cd1a8e4d439df Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Tapani=20P=C3=A4lli?= <tapani.palli@intel.com>
|
||||
Date: Wed, 30 Apr 2014 14:05:11 +0300
|
||||
Subject: [PATCH] drawtex: resolve glDrawTexfOES extension function
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=78101
|
||||
Signed-off-by: Tapani Pälli <tapani.palli@intel.com>
|
||||
Reviewed-by: Brian Paul <brianp@vmware.com>
|
||||
Reviewed-by: Ian Romanick <ian.d.romanick@intel.com>
|
||||
---
|
||||
src/egl/opengles1/drawtex.c | 10 +++++++++-
|
||||
1 file changed, 9 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/egl/opengles1/drawtex.c b/src/egl/opengles1/drawtex.c
|
||||
index 524f931..1ba8ac7 100644
|
||||
--- a/src/egl/opengles1/drawtex.c
|
||||
+++ b/src/egl/opengles1/drawtex.c
|
||||
@@ -25,13 +25,14 @@ static GLfloat width = 200, height = 200;
|
||||
static GLboolean animate = GL_FALSE;
|
||||
static int win;
|
||||
|
||||
+static PFNGLDRAWTEXFOESPROC glDrawTexfOES_func = NULL;
|
||||
|
||||
static void
|
||||
draw(void)
|
||||
{
|
||||
glClear(GL_COLOR_BUFFER_BIT);
|
||||
|
||||
- glDrawTexfOES(view_posx, view_posy, 0.0, width, height);
|
||||
+ glDrawTexfOES_func(view_posx, view_posy, 0.0, width, height);
|
||||
}
|
||||
|
||||
|
||||
@@ -128,6 +129,13 @@ init(void)
|
||||
exit(1);
|
||||
}
|
||||
|
||||
+ glDrawTexfOES_func = eglGetProcAddress("glDrawTexfOES");
|
||||
+
|
||||
+ if (!glDrawTexfOES_func) {
|
||||
+ fprintf(stderr, "Sorry, failed to resolve glDrawTexfOES function\n");
|
||||
+ exit(1);
|
||||
+ }
|
||||
+
|
||||
glClearColor(0.4, 0.4, 0.4, 0.0);
|
||||
|
||||
make_smile_texture();
|
||||
--
|
||||
1.9.2
|
||||
|
||||
From 6ad8820c457845300806a2f9469599460ca96af9 Mon Sep 17 00:00:00 2001
|
||||
From: Stefan Dirsch <sndirsch@suse.de>
|
||||
Date: Thu, 8 May 2014 11:48:44 +0200
|
||||
Subject: [PATCH] drawtex: fixed compiler warnings related to use of
|
||||
eglGetProcAddress
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Add proper <EGL/egl.h> include and cast in order to fix compiler
|
||||
warnings related to the use of eglGetProcAddress.
|
||||
|
||||
Reviewed-By: Tapani Pälli <tapani.palli@intel.com>
|
||||
---
|
||||
src/egl/opengles1/drawtex.c | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/egl/opengles1/drawtex.c b/src/egl/opengles1/drawtex.c
|
||||
index 1ba8ac7..dc1de13 100644
|
||||
--- a/src/egl/opengles1/drawtex.c
|
||||
+++ b/src/egl/opengles1/drawtex.c
|
||||
@@ -16,6 +16,7 @@
|
||||
#include <string.h>
|
||||
#include <GLES/gl.h>
|
||||
#include <GLES/glext.h>
|
||||
+#include <EGL/egl.h>
|
||||
|
||||
#include "eglut.h"
|
||||
|
||||
@@ -129,7 +130,7 @@ init(void)
|
||||
exit(1);
|
||||
}
|
||||
|
||||
- glDrawTexfOES_func = eglGetProcAddress("glDrawTexfOES");
|
||||
+ glDrawTexfOES_func = (PFNGLDRAWTEXFOESPROC) eglGetProcAddress("glDrawTexfOES");
|
||||
|
||||
if (!glDrawTexfOES_func) {
|
||||
fprintf(stderr, "Sorry, failed to resolve glDrawTexfOES function\n");
|
||||
--
|
||||
1.9.2
|
||||
|
Loading…
Reference in a new issue