core/linux-raspberrypi to 5.10.63-3

This commit is contained in:
graysky 2021-09-11 13:49:59 -04:00
parent 86341db4ff
commit 7f24423a69
2 changed files with 32 additions and 1 deletions

View file

@ -0,0 +1,27 @@
From 46cce667db4dd477556d30137515c839f4efb0b1 Mon Sep 17 00:00:00 2001
From: graysky <graysky@archlinux.us>
Date: Sat, 11 Sep 2021 13:29:39 -0400
Subject: [PATCH] Revert "drm/vc4: hdmi: Remove the DDC probing for status
detection"
This reverts commit 17a554471341cabeb583feb02f04eb785d7d9bf8.
---
drivers/gpu/drm/vc4/vc4_hdmi.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/gpu/drm/vc4/vc4_hdmi.c b/drivers/gpu/drm/vc4/vc4_hdmi.c
index cc1a05df6195..9e86970d5afc 100644
--- a/drivers/gpu/drm/vc4/vc4_hdmi.c
+++ b/drivers/gpu/drm/vc4/vc4_hdmi.c
@@ -185,6 +185,8 @@ vc4_hdmi_connector_detect(struct drm_connector *connector, bool force)
if (gpio_get_value_cansleep(vc4_hdmi->hpd_gpio) ^
vc4_hdmi->hpd_active_low)
connected = true;
+ } else if (drm_probe_ddc(vc4_hdmi->ddc)) {
+ connected = true;
} else if (HDMI_READ(HDMI_HOTPLUG) & VC4_HDMI_HOTPLUG_CONNECTED) {
connected = true;
}
--
2.33.0

View file

@ -11,7 +11,7 @@ _srcname=linux-${_commit}
_kernelname=${pkgbase#linux}
_desc="Raspberry Pi 4"
pkgver=5.10.63
pkgrel=2
pkgrel=3
arch=('armv6h' 'armv7h')
url="http://www.kernel.org/"
license=('GPL2')
@ -22,6 +22,7 @@ source=("https://github.com/raspberrypi/linux/archive/${_commit}.tar.gz"
'linux.preset'
'config.txt'
'config'
'0001-Revert-drm-vc4-hdmi-Remove-the-DDC-probing-for-statu.patch'
'60-linux.hook'
'90-linux.hook')
md5sums=('f20a487737797330687518e9c9573a3f'
@ -29,6 +30,7 @@ md5sums=('f20a487737797330687518e9c9573a3f'
'86d4a35722b5410e3b29fc92dae15d4b'
'9669d916a5929a2eedbd64477f83d99e'
'4e77a3c2e7dbf645f60fcc9217587dc6'
'051ba07146602eab77484b99e3b3294b'
'ce6c81ad1ad1f8b333fd6077d47abdaf'
'69e1db90d78f691dc446fe2ab94727eb')
@ -42,6 +44,8 @@ prepare() {
# don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh
patch -Np1 -i ../0001-Revert-drm-vc4-hdmi-Remove-the-DDC-probing-for-statu.patch
}
build() {