community/openimageio to 1.7.10-1

This commit is contained in:
Kevin Mihelich 2017-01-16 02:32:48 +00:00
parent c1c8533891
commit 7f3fd25360
4 changed files with 4 additions and 79 deletions

View file

@ -6,8 +6,8 @@
# - removed intel-tbb from deps, set -DUSE_TBB=0
pkgname=openimageio
pkgver=1.6.14
pkgrel=5
pkgver=1.7.10
pkgrel=1
pkgdesc="A library for reading and writing images, including classes, utilities, and applications"
arch=(i686 x86_64)
url="http://www.openimageio.org/"
@ -27,8 +27,8 @@ build() {
# Python is currently broken :(
cmake .. \
-DUSE_PYTHON=OFF \
-DUSE_PYTHON3=OFF \
-DUSE_PYTHON=ON \
-DUSE_PYTHON3=ON \
-DUSE_OPENSSL=ON \
-DCMAKE_INSTALL_PREFIX=/usr \
-DPYLIB_INSTALL_DIR=lib/python2.7/site-packages \

View file

@ -1,22 +0,0 @@
From 4e3371d2e37512c5fa8b1f297ad9af52417fec9e Mon Sep 17 00:00:00 2001
From: Larry Gritz <lg@larrygritz.com>
Date: Wed, 11 Feb 2015 15:27:40 -0800
Subject: [PATCH] Fix compiler warning about unused variable
---
src/ptex.imageio/ptex/PtexHalf.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/ptex.imageio/ptex/PtexHalf.cpp b/src/ptex.imageio/ptex/PtexHalf.cpp
index a880971..3c17369 100644
--- a/src/ptex.imageio/ptex/PtexHalf.cpp
+++ b/src/ptex.imageio/ptex/PtexHalf.cpp
@@ -80,7 +80,7 @@ static bool PtexHalfInit()
return 1;
}
-static bool PtexHalfInitialized = PtexHalfInit();
+bool PtexHalfInitialized = PtexHalfInit();
/** Handle exceptional cases for half-to-float conversion */

View file

@ -1,18 +0,0 @@
diff --git a/src/include/OpenImageIO/fmath.h b/src/include/OpenImageIO/fmath.h
index 8db8442..751cd07 100644
--- a/src/include/OpenImageIO/fmath.h
+++ b/src/include/OpenImageIO/fmath.h
@@ -1298,9 +1298,9 @@ OIIO_NAMESPACE_EXIT
#ifndef _MSC_VER
// Some systems have isnan, isinf and isfinite in the std namespace.
- using std::isnan;
- using std::isinf;
- using std::isfinite;
+ using ::isnan;
+ using ::isinf;
+ using OIIO::isfinite;
#endif
#if (defined(__FreeBSD__) && (__FreeBSD_version < 803000))

View file

@ -1,35 +0,0 @@
From a2ccfad7c4962a5203ea2cf755fd102b4c67f997 Mon Sep 17 00:00:00 2001
From: Larry Gritz <lg@larrygritz.com>
Date: Fri, 26 Jun 2015 11:46:23 -0700
Subject: [PATCH] ustring fixes for new gcc (5.1+) std::string ABI
This makes it work (and adds a test).
We still need to return and do something more clever for that case.
I'll need to install gcc 5.1 first to see how the internals work.
But in the mean time, at least this will unbreak things for people
already on gcc 5.1.
Fixes #1174
---
src/libutil/ustring.cpp | 7 ++++++-
src/libutil/ustring_test.cpp | 2 ++
2 files changed, 8 insertions(+), 1 deletion(-)
diff --git a/src/libutil/ustring.cpp b/src/libutil/ustring.cpp
index 1d12533..4b4a8c2 100644
--- a/src/libutil/ustring.cpp
+++ b/src/libutil/ustring.cpp
@@ -318,7 +318,12 @@ ustring::TableRep::TableRep (string_view strref, size_t hash)
// the std::string to make it point to our chars! In such a case, the
// destructor will be careful not to allow a deallocation.
-#if defined(__GNUC__) && !defined(_LIBCPP_VERSION)
+#if defined(__GNUC__) && !defined(_LIBCPP_VERSION) && defined(_GLIBCXX_USE_CXX11_ABI) && _GLIBCXX_USE_CXX11_ABI
+ // NEW gcc ABI
+ // FIXME -- do something smart with this.
+
+#elif defined(__GNUC__) && !defined(_LIBCPP_VERSION)
+ // OLD gcc ABI
// It turns out that the first field of a gcc std::string is a pointer
// to the characters within the basic_string::_Rep. We merely redirect
// that pointer, though for std::string to function properly, the chars