alarm/xf86-video-armsoc-odroid to 240.78c3cda-4

This commit is contained in:
Kevin Mihelich 2018-06-28 00:22:51 +00:00
parent 2280b12078
commit 7fc1e5f234
4 changed files with 49 additions and 10 deletions

View file

@ -1,7 +1,7 @@
From 4e6cfc02a458f873015b7f73e93a39d3ae2ef366 Mon Sep 17 00:00:00 2001 From 4163e125900d2d24f546f8c9416f6fef1f9e95d1 Mon Sep 17 00:00:00 2001
From: Adam Jackson <ajax@redhat.com> From: Adam Jackson <ajax@redhat.com>
Date: Tue, 19 Jul 2016 10:21:03 -0400 Date: Tue, 19 Jul 2016 10:21:03 -0400
Subject: [PATCH 1/2] Adapt Block/WakeupHandler signature for ABI 23 Subject: [PATCH 1/3] Adapt Block/WakeupHandler signature for ABI 23
Signed-off-by: Adam Jackson <ajax@redhat.com> Signed-off-by: Adam Jackson <ajax@redhat.com>
--- ---
@ -29,5 +29,5 @@ index fefbc59..78d3c91 100644
#define CLOSE_SCREEN_ARGS_DECL ScreenPtr pScreen #define CLOSE_SCREEN_ARGS_DECL ScreenPtr pScreen
#define CLOSE_SCREEN_ARGS pScreen #define CLOSE_SCREEN_ARGS pScreen
-- --
2.11.0 2.17.1

View file

@ -1,7 +1,7 @@
From e63caa8a48715adfac9242ec4c42d36d18e4fdf2 Mon Sep 17 00:00:00 2001 From b24ee793b6c4eb2ae5c5ddb770cb9043f5d22a9d Mon Sep 17 00:00:00 2001
From: Keith Packard <keithp@keithp.com> From: Keith Packard <keithp@keithp.com>
Date: Tue, 19 Jul 2016 08:51:12 -0700 Date: Tue, 19 Jul 2016 08:51:12 -0700
Subject: [PATCH 2/2] Use NotifyFd for drm fd Subject: [PATCH 2/3] Use NotifyFd for drm fd
NotifyFd is available after API 22, and must be used after API 23. NotifyFd is available after API 22, and must be used after API 23.
@ -97,5 +97,5 @@ index 1b47632..b64bf71 100644
drmmode_uevent_fini(pScrn); drmmode_uevent_fini(pScrn);
} }
-- --
2.11.0 2.17.1

View file

@ -0,0 +1,36 @@
From f83caedccd856db42de89d265b96b912fa02fd69 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 14 Jun 2018 11:59:02 -0600
Subject: [PATCH 3/3] Initialize XRandR before EnterVT
---
src/armsoc_driver.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/armsoc_driver.c b/src/armsoc_driver.c
index 7e70f34..5ffb64a 100644
--- a/src/armsoc_driver.c
+++ b/src/armsoc_driver.c
@@ -1105,6 +1105,9 @@ ARMSOCScreenInit(SCREEN_INIT_ARGS_DECL)
*/
pScrn->vtSema = TRUE;
+ /* Do some XRandR initialization. Return value is not useful */
+ (void)xf86CrtcScreenInit(pScreen);
+
/* Take over the virtual terminal from the console, set the
* desired mode, etc.:
*/
@@ -1113,9 +1116,6 @@ ARMSOCScreenInit(SCREEN_INIT_ARGS_DECL)
goto fail6;
}
- /* Do some XRandR initialization. Return value is not useful */
- (void)xf86CrtcScreenInit(pScreen);
-
if (!miCreateDefColormap(pScreen)) {
ERROR_MSG("Cannot create colormap!");
goto fail7;
--
2.17.1

View file

@ -5,7 +5,7 @@ buildarch=4
pkgname=xf86-video-armsoc-odroid pkgname=xf86-video-armsoc-odroid
pkgver=240.78c3cda pkgver=240.78c3cda
pkgrel=3 pkgrel=4
pkgdesc='X.org graphics driver for ARM graphics - Exynos ODROID' pkgdesc='X.org graphics driver for ARM graphics - Exynos ODROID'
arch=('armv7h') arch=('armv7h')
url="https://github.com/mdrjr/xf86-video-armsoc/tree/r4p0" url="https://github.com/mdrjr/xf86-video-armsoc/tree/r4p0"
@ -15,10 +15,12 @@ conflicts=('xorg-server<1.20' 'X-ABI-VIDEODRV_VERSION<24' 'X-ABI-VIDEODRV_VERSIO
provides=(xf86-video-armsoc) provides=(xf86-video-armsoc)
source=("$pkgname::git+https://github.com/mdrjr/xf86-video-armsoc.git#branch=r4p0" source=("$pkgname::git+https://github.com/mdrjr/xf86-video-armsoc.git#branch=r4p0"
'0001-Adapt-Block-WakeupHandler-signature-for-ABI-23.patch' '0001-Adapt-Block-WakeupHandler-signature-for-ABI-23.patch'
'0002-Use-NotifyFd-for-drm-fd.patch') '0002-Use-NotifyFd-for-drm-fd.patch'
'0003-Initialize-XRandR-before-EnterVT.patch')
md5sums=('SKIP' md5sums=('SKIP'
'9d06b5add32485a340c771bb87f3c81c' '2cf86d77a14940d24e6aacfb22cd3432'
'742f19941f6ef38a344c26c5785b8b79') 'abaa79ea09ebf88151e8c74b75f48ac4'
'17d36d2a9c29b9ae467f67dba64ce524')
pkgver() { pkgver() {
cd $pkgname cd $pkgname
@ -29,6 +31,7 @@ prepare() {
cd $pkgname cd $pkgname
git apply ../0001-Adapt-Block-WakeupHandler-signature-for-ABI-23.patch git apply ../0001-Adapt-Block-WakeupHandler-signature-for-ABI-23.patch
git apply ../0002-Use-NotifyFd-for-drm-fd.patch git apply ../0002-Use-NotifyFd-for-drm-fd.patch
git apply ../0003-Initialize-XRandR-before-EnterVT.patch
} }
build() { build() {