mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/rust to 1.55.0-1
This commit is contained in:
parent
9a5d96948a
commit
7fee206fd3
3 changed files with 9 additions and 9 deletions
|
@ -8,7 +8,7 @@ Subject: [PATCH] bootstrap: Change libexec dir
|
|||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
|
||||
index 16d148db618..856d57faf44 100644
|
||||
index c37763243c0..889bcb7c081 100644
|
||||
--- a/src/bootstrap/dist.rs
|
||||
+++ b/src/bootstrap/dist.rs
|
||||
@@ -992,7 +992,7 @@ fn run(self, builder: &Builder<'_>) -> GeneratedTarball {
|
||||
|
|
|
@ -24,10 +24,10 @@ targets, as things break when this is done:
|
|||
4 files changed, 12 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
|
||||
index 2b547f8be92..09e1152dde4 100644
|
||||
index 2d7f5f9b321..8213c10964c 100644
|
||||
--- a/compiler/rustc_session/src/config.rs
|
||||
+++ b/compiler/rustc_session/src/config.rs
|
||||
@@ -1538,7 +1538,7 @@ pub fn parse_target_triple(
|
||||
@@ -1534,7 +1534,7 @@ pub fn parse_target_triple(
|
||||
early_error(error_format, &format!("target file {:?} does not exist", path))
|
||||
})
|
||||
}
|
||||
|
@ -50,10 +50,10 @@ index 165505ee731..00a7f5c2f8c 100644
|
|||
data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
|
||||
f64:32:64-f80:32-n8:16:32-S128"
|
||||
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
|
||||
index 0f2aaeb533a..ce27142ec86 100644
|
||||
index 0185132ee36..b825fcb7260 100644
|
||||
--- a/compiler/rustc_target/src/spec/mod.rs
|
||||
+++ b/compiler/rustc_target/src/spec/mod.rs
|
||||
@@ -2164,6 +2164,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
||||
@@ -2280,6 +2280,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
||||
Ok(TargetTriple::TargetPath(canonicalized_path))
|
||||
}
|
||||
|
||||
|
|
|
@ -16,7 +16,7 @@ highmem=1
|
|||
|
||||
pkgname=('rust' 'rust-docs')
|
||||
epoch=1
|
||||
pkgver=1.54.0
|
||||
pkgver=1.55.0
|
||||
pkgrel=1
|
||||
|
||||
_llvm_ver=12.0.1
|
||||
|
@ -39,13 +39,13 @@ source=(
|
|||
0001-cargo-Change-libexec-dir.patch
|
||||
0002-compiler-Change-LLVM-targets.patch
|
||||
)
|
||||
sha256sums=('ac8511633e9b5a65ad030a1a2e5bdaa841fdfe3132f2baaa52cc04e71c6c6976'
|
||||
sha256sums=('b2379ac710f5f876ee3c3e03122fe33098d6765d371cac6c31b1b6fc8e43821e'
|
||||
'SKIP'
|
||||
'b4c8d5f2a802332987c1c0a95b5afb35b1a66a96fe44add4e4ed4792c4cba0a4'
|
||||
'SKIP'
|
||||
'644238f652f2099befb30f30eff77a5269a63cb4db1615933032ab3f6cbc31ba'
|
||||
'1259fd166de6289fb24e4ae09ebf1d18e10fc2777a8d6f90d9475c5d3aa6807b'
|
||||
'1833c3b5f8262b598115d13f08e2dcba792536768a2371869870e26244971112'
|
||||
'851172a5a3c35e209d455232d0572f51b6d34d3bc5f1a0416c01f426fdf60e92')
|
||||
'2d91730203d0e58b90365e4e5041d2bdffd500f1f9e6457c7d6256d0e65f1ad9')
|
||||
validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE' # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
||||
'474E22316ABF4785A88C6E8EA2C794A986419D8A' # Tom Stellard <tstellar@redhat.com>
|
||||
'B6C8F98282B944E3B0D5C2530FC3042E345AD05D') # Hans Wennborg <hans@chromium.org>
|
||||
|
|
Loading…
Reference in a new issue