mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/qt6-webengine to 6.2.1-1
This commit is contained in:
parent
0a5fe73892
commit
80139d7396
3 changed files with 3 additions and 131 deletions
|
@ -12,9 +12,9 @@ buildarch=12
|
|||
highmem=1
|
||||
|
||||
pkgname=qt6-webengine
|
||||
_qtver=6.2.0
|
||||
_qtver=6.2.1
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=2
|
||||
pkgrel=1
|
||||
arch=(x86_64)
|
||||
url='https://www.qt.io'
|
||||
license=(GPL3 LGPL3 FDL custom)
|
||||
|
@ -26,15 +26,11 @@ optdepends=('pipewire: WebRTC desktop sharing under Wayland')
|
|||
groups=(qt6)
|
||||
_pkgfn="${pkgname/6-/}-everywhere-src-$_qtver"
|
||||
source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz
|
||||
chromium-harfbuzz-3.0.0.patch
|
||||
skia-harfbuzz-3.0.0.patch
|
||||
0001-ARM-toolchain-fixes.patch
|
||||
0002-Fix-ARM-skia-ICE.patch
|
||||
0003-Run-blink-bindings-generation-single-threaded.patch
|
||||
0004-Fix-sandbox-Aw-snap-for-sycalls-403-and-407.patch)
|
||||
sha256sums=('c6e530a61bea2e7fbb50308a2b4e7fdb4f7c7b61a28797973270acffc020809d'
|
||||
'7ce947944a139e66774dfc7249bf7c3069f07f83a0f1b2c1a1b14287a7e15928'
|
||||
'c9ed1dbadaf4be6097e25bc5577b91751799befc2d0376b143e1bd10def5754e'
|
||||
sha256sums=('1f933cffb8671c1e71b6b2a4924cb6b3f9878388ae6298ac8d31a76c1ecffbb7'
|
||||
'2f9388902350b706d85181e8a5864efe577b665afefb7328ad213a6c71b09d27'
|
||||
'd7bfd8ed1db238c540935ff31539a54e4e807eb8c3013ed98f7dcc7367d35784'
|
||||
'a24170d4576adebbfb8ee19dccd892f4038b9848765036b2ff78dbf590fc8138'
|
||||
|
@ -43,10 +39,6 @@ sha256sums=('c6e530a61bea2e7fbb50308a2b4e7fdb4f7c7b61a28797973270acffc020809d'
|
|||
prepare() {
|
||||
cd $_pkgfn
|
||||
|
||||
# Fix build with harfbuzz 3.0.0
|
||||
patch -p1 -d src/3rdparty/chromium -i "$srcdir"/chromium-harfbuzz-3.0.0.patch
|
||||
patch -p1 -d src/3rdparty/chromium/third_party/skia -i "$srcdir"/skia-harfbuzz-3.0.0.patch
|
||||
|
||||
if [[ $CARCH == "armv7h" ]]; then
|
||||
export MAKEFLAGS="-j4"
|
||||
export ALARM_NINJA_JOBS="2"
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
# https://github.com/chromium/chromium/commit/b289f6f3fcbc
|
||||
|
||||
diff --git a/components/paint_preview/common/subset_font.cc b/components/paint_preview/common/subset_font.cc
|
||||
index 8ff0540d9a..20a7d37474 100644
|
||||
--- a/components/paint_preview/common/subset_font.cc
|
||||
+++ b/components/paint_preview/common/subset_font.cc
|
||||
@@ -72,9 +72,11 @@ sk_sp<SkData> SubsetFont(SkTypeface* typeface, const GlyphUsage& usage) {
|
||||
hb_set_t* glyphs =
|
||||
hb_subset_input_glyph_set(input.get()); // Owned by |input|.
|
||||
usage.ForEach(base::BindRepeating(&AddGlyphs, base::Unretained(glyphs)));
|
||||
- hb_subset_input_set_retain_gids(input.get(), true);
|
||||
+ hb_subset_input_set_flags(input.get(), HB_SUBSET_FLAGS_RETAIN_GIDS);
|
||||
|
||||
- HbScoped<hb_face_t> subset_face(hb_subset(face.get(), input.get()));
|
||||
+ HbScoped<hb_face_t> subset_face(hb_subset_or_fail(face.get(), input.get()));
|
||||
+ if (!subset_face)
|
||||
+ return nullptr;
|
||||
HbScoped<hb_blob_t> subset_blob(hb_face_reference_blob(subset_face.get()));
|
||||
if (!subset_blob)
|
||||
return nullptr;
|
|
@ -1,100 +0,0 @@
|
|||
# Minimal diff for harfbuzz 3.0.0 support; based on:
|
||||
# https://github.com/google/skia/commit/66684b17b382
|
||||
# https://github.com/google/skia/commit/51d83abcd24a
|
||||
|
||||
diff --git a/gn/skia.gni b/gn/skia.gni
|
||||
index d98fdc19ee..199335d5c4 100644
|
||||
--- a/gn/skia.gni
|
||||
+++ b/gn/skia.gni
|
||||
@@ -34,8 +34,6 @@ declare_args() {
|
||||
skia_include_multiframe_procs = false
|
||||
skia_lex = false
|
||||
skia_libgifcodec_path = "third_party/externals/libgifcodec"
|
||||
- skia_pdf_subset_harfbuzz =
|
||||
- false # TODO: set skia_pdf_subset_harfbuzz to skia_use_harfbuzz.
|
||||
skia_qt_path = getenv("QT_PATH")
|
||||
skia_skqp_global_error_tolerance = 0
|
||||
skia_tools_require_resources = false
|
||||
@@ -99,6 +97,10 @@ declare_args() {
|
||||
skia_use_libfuzzer_defaults = true
|
||||
}
|
||||
|
||||
+declare_args() {
|
||||
+ skia_pdf_subset_harfbuzz = skia_use_harfbuzz
|
||||
+}
|
||||
+
|
||||
declare_args() {
|
||||
skia_compile_sksl_tests = skia_compile_processors
|
||||
skia_enable_fontmgr_android = skia_use_expat && skia_use_freetype
|
||||
diff --git a/src/pdf/SkPDFSubsetFont.cpp b/src/pdf/SkPDFSubsetFont.cpp
|
||||
index 81c37eef3a..2340a7937b 100644
|
||||
--- a/src/pdf/SkPDFSubsetFont.cpp
|
||||
+++ b/src/pdf/SkPDFSubsetFont.cpp
|
||||
@@ -49,6 +49,37 @@ static sk_sp<SkData> to_data(HBBlob blob) {
|
||||
blob.release());
|
||||
}
|
||||
|
||||
+template<typename...> using void_t = void;
|
||||
+template<typename T, typename = void>
|
||||
+struct SkPDFHarfBuzzSubset {
|
||||
+ // This is the HarfBuzz 3.0 interface.
|
||||
+ // hb_subset_flags_t does not exist in 2.0. It isn't dependent on T, so inline the value of
|
||||
+ // HB_SUBSET_FLAGS_RETAIN_GIDS until 2.0 is no longer supported.
|
||||
+ static HBFace Make(T input, hb_face_t* face) {
|
||||
+ // TODO: When possible, check if a font is 'tricky' with FT_IS_TRICKY.
|
||||
+ // If it isn't known if a font is 'tricky', retain the hints.
|
||||
+ hb_subset_input_set_flags(input, 2/*HB_SUBSET_FLAGS_RETAIN_GIDS*/);
|
||||
+ return HBFace(hb_subset_or_fail(face, input));
|
||||
+ }
|
||||
+};
|
||||
+template<typename T>
|
||||
+struct SkPDFHarfBuzzSubset<T, void_t<
|
||||
+ decltype(hb_subset_input_set_retain_gids(std::declval<T>(), std::declval<bool>())),
|
||||
+ decltype(hb_subset_input_set_drop_hints(std::declval<T>(), std::declval<bool>())),
|
||||
+ decltype(hb_subset(std::declval<hb_face_t*>(), std::declval<T>()))
|
||||
+ >>
|
||||
+{
|
||||
+ // This is the HarfBuzz 2.0 (non-public) interface, used if it exists.
|
||||
+ // This code should be removed as soon as all users are migrated to the newer API.
|
||||
+ static HBFace Make(T input, hb_face_t* face) {
|
||||
+ hb_subset_input_set_retain_gids(input, true);
|
||||
+ // TODO: When possible, check if a font is 'tricky' with FT_IS_TRICKY.
|
||||
+ // If it isn't known if a font is 'tricky', retain the hints.
|
||||
+ hb_subset_input_set_drop_hints(input, false);
|
||||
+ return HBFace(hb_subset(face, input));
|
||||
+ }
|
||||
+};
|
||||
+
|
||||
static sk_sp<SkData> subset_harfbuzz(sk_sp<SkData> fontData,
|
||||
const SkPDFGlyphUse& glyphUsage,
|
||||
int ttcIndex) {
|
||||
@@ -71,11 +102,10 @@ static sk_sp<SkData> subset_harfbuzz(sk_sp<SkData> fontData,
|
||||
hb_set_t* glyphs = hb_subset_input_glyph_set(input.get());
|
||||
glyphUsage.getSetValues([&glyphs](unsigned gid) { hb_set_add(glyphs, gid);});
|
||||
|
||||
- hb_subset_input_set_retain_gids(input.get(), true);
|
||||
- // TODO: When possible, check if a font is 'tricky' with FT_IS_TRICKY.
|
||||
- // If it isn't known if a font is 'tricky', retain the hints.
|
||||
- hb_subset_input_set_drop_hints(input.get(), false);
|
||||
- HBFace subset(hb_subset(face.get(), input.get()));
|
||||
+ HBFace subset = SkPDFHarfBuzzSubset<hb_subset_input_t*>::Make(input.get(), face.get());
|
||||
+ if (!subset) {
|
||||
+ return nullptr;
|
||||
+ }
|
||||
HBBlob result(hb_face_reference_blob(subset.get()));
|
||||
return to_data(std::move(result));
|
||||
}
|
||||
diff --git a/third_party/harfbuzz/BUILD.gn b/third_party/harfbuzz/BUILD.gn
|
||||
index 173830de62..4156607ef9 100644
|
||||
--- a/third_party/harfbuzz/BUILD.gn
|
||||
+++ b/third_party/harfbuzz/BUILD.gn
|
||||
@@ -14,6 +14,9 @@ if (skia_use_system_harfbuzz) {
|
||||
"harfbuzz",
|
||||
"harfbuzz-icu",
|
||||
]
|
||||
+ if (skia_pdf_subset_harfbuzz) {
|
||||
+ libs += [ "harfbuzz-subset" ]
|
||||
+ }
|
||||
}
|
||||
} else {
|
||||
third_party("harfbuzz") {
|
Loading…
Reference in a new issue