mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/python to 3.7.0-3
This commit is contained in:
parent
a72edc23b6
commit
802cc218f9
2 changed files with 101 additions and 9 deletions
|
@ -11,9 +11,9 @@
|
|||
# - don't configure with --enable-optimizations - PGO kills builds
|
||||
|
||||
pkgname=python
|
||||
pkgver=3.6.6
|
||||
pkgrel=1
|
||||
_pybasever=3.6
|
||||
pkgver=3.7.0
|
||||
pkgrel=3
|
||||
_pybasever=${pkgver%.*}
|
||||
pkgdesc="Next generation of the python high-level scripting language"
|
||||
arch=('x86_64')
|
||||
license=('custom')
|
||||
|
@ -29,25 +29,29 @@ optdepends=('python-setuptools'
|
|||
provides=('python3')
|
||||
replaces=('python3')
|
||||
source=("https://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tar.xz"{,.asc}
|
||||
bpo34056-always-return-bytes-from-_HackedGetData.get_data.patch
|
||||
dont-make-libpython-readonly.patch)
|
||||
sha512sums=('c71f87c5906e770322a14cacad228655659f782207db826320449d12bf86091c3662f317e1773158dec52f8b052eaedfb4c03b561cc2a6cfcd381597fd2d2b04'
|
||||
sha512sums=('8bb11233fb67ee9ab8ed1b72f8fdc62f66e26a6beaaeb92448bce681cf065269833b1658d3ed2459127f25ba43adb0eab73cf27c59834a2a803fb529b4216739'
|
||||
'SKIP'
|
||||
'0ec544fa95ba30be03e866d02848f9fa4921304055368609136ac39626df9835bad75506f6d81ef9fdc0ebcc29a9749f84b5b5f4dd75958c9699ade522d51b68'
|
||||
'2ef96708d5b13ae2a3d2cc62c87b4780e60ecfce914e190564492def3a11d5e56977659f41c7f9d12266e58050c766bce4e2b5d50b708eb792794fa8357920c4')
|
||||
validpgpkeys=('0D96DF4D4110E5C43FBFB17F2D347EA6AA65421D') # Ned Deily (Python release signing key) <nad@python.org>
|
||||
|
||||
prepare() {
|
||||
cd Python-${pkgver}
|
||||
|
||||
# https://bugs.python.org/issue34056
|
||||
patch -Np1 -i ../bpo34056-always-return-bytes-from-_HackedGetData.get_data.patch
|
||||
|
||||
# FS#45809
|
||||
patch -p1 -i ../dont-make-libpython-readonly.patch
|
||||
|
||||
# FS#23997
|
||||
sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python|" Lib/cgi.py
|
||||
|
||||
# Ensure that we are using the system copy of various libraries (expat, zlib, libffi, and libmpdec),
|
||||
# Ensure that we are using the system copy of various libraries (expat, libffi, and libmpdec),
|
||||
# rather than copies shipped in the tarball
|
||||
rm -r Modules/expat
|
||||
rm -r Modules/zlib
|
||||
rm -r Modules/_ctypes/{darwin,libffi}*
|
||||
rm -r Modules/_decimal/libmpdec
|
||||
}
|
||||
|
@ -77,8 +81,12 @@ build() {
|
|||
}
|
||||
|
||||
check() {
|
||||
# test_gdb is expected to fail with LTO~
|
||||
# test_idle, test_tk, test_ttk_guionly segfaults on 3.6.5
|
||||
# test_gdb is expected to fail with LTO
|
||||
# test_idle, test_tk, test_ttk_guionly segfaults since 3.6.5
|
||||
|
||||
# https://bugs.python.org/issue34022
|
||||
# test_cmd_line_script, test_compileall, test_importlib,
|
||||
# test_multiprocessing_main_handling, test_py_compile, test_runpy
|
||||
|
||||
cd Python-${pkgver}
|
||||
|
||||
|
@ -88,7 +96,8 @@ check() {
|
|||
|
||||
LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
|
||||
LC_CTYPE=en_US.UTF-8 xvfb-run -s "-screen 0 1280x720x24 -ac +extension GLX" -a -n "$servernum" \
|
||||
"${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_gdb -x test_idle -x test_tk -x test_ttk_guionly
|
||||
"${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_gdb -x test_idle -x test_tk -x test_ttk_guionly \
|
||||
-x test_cmd_line_script -x test_compileall -x test_importlib -x test_multiprocessing_main_handling -x test_py_compile -x test_runpy
|
||||
}
|
||||
|
||||
package() {
|
||||
|
|
|
@ -0,0 +1,83 @@
|
|||
From 7bd6f0e5500f778e940374237b94651f60ae1990 Mon Sep 17 00:00:00 2001
|
||||
From: "Miss Islington (bot)"
|
||||
<31488909+miss-islington@users.noreply.github.com>
|
||||
Date: Fri, 6 Jul 2018 21:00:45 -0700
|
||||
Subject: [PATCH] closes bpo-34056: Always return bytes from
|
||||
_HackedGetData.get_data(). (GH-8130)
|
||||
|
||||
* Always return bytes from _HackedGetData.get_data().
|
||||
|
||||
Ensure the imp.load_source shim always returns bytes by reopening the file in
|
||||
binary mode if needed. Hash-based pycs have to receive the source code in bytes.
|
||||
|
||||
It's tempting to change imp.get_suffixes() to always return 'rb' as a mode, but
|
||||
that breaks some stdlib tests and likely 3rdparty code, too.
|
||||
(cherry picked from commit b0274f2cddd36b49fe5080efbe160277ef546471)
|
||||
|
||||
Co-authored-by: Benjamin Peterson <benjamin@python.org>
|
||||
---
|
||||
Lib/imp.py | 13 ++++++-------
|
||||
Lib/test/test_imp.py | 15 +++++++++++++++
|
||||
2 files changed, 21 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/Lib/imp.py b/Lib/imp.py
|
||||
index 866464b245b2..31f8c766381a 100644
|
||||
--- a/Lib/imp.py
|
||||
+++ b/Lib/imp.py
|
||||
@@ -142,17 +142,16 @@ def __init__(self, fullname, path, file=None):
|
||||
def get_data(self, path):
|
||||
"""Gross hack to contort loader to deal w/ load_*()'s bad API."""
|
||||
if self.file and path == self.path:
|
||||
+ # The contract of get_data() requires us to return bytes. Reopen the
|
||||
+ # file in binary mode if needed.
|
||||
if not self.file.closed:
|
||||
file = self.file
|
||||
- else:
|
||||
- self.file = file = open(self.path, 'r')
|
||||
+ if 'b' not in file.mode:
|
||||
+ file.close()
|
||||
+ if self.file.closed:
|
||||
+ self.file = file = open(self.path, 'rb')
|
||||
|
||||
with file:
|
||||
- # Technically should be returning bytes, but
|
||||
- # SourceLoader.get_code() just passed what is returned to
|
||||
- # compile() which can handle str. And converting to bytes would
|
||||
- # require figuring out the encoding to decode to and
|
||||
- # tokenize.detect_encoding() only accepts bytes.
|
||||
return file.read()
|
||||
else:
|
||||
return super().get_data(path)
|
||||
diff --git a/Lib/test/test_imp.py b/Lib/test/test_imp.py
|
||||
index a115e60d4e4f..bb0144b12d41 100644
|
||||
--- a/Lib/test/test_imp.py
|
||||
+++ b/Lib/test/test_imp.py
|
||||
@@ -2,6 +2,7 @@
|
||||
import importlib.util
|
||||
import os
|
||||
import os.path
|
||||
+import py_compile
|
||||
import sys
|
||||
from test import support
|
||||
from test.support import script_helper
|
||||
@@ -350,6 +351,20 @@ def test_pyc_invalidation_mode_from_cmdline(self):
|
||||
res = script_helper.assert_python_ok(*args)
|
||||
self.assertEqual(res.out.strip().decode('utf-8'), expected)
|
||||
|
||||
+ def test_find_and_load_checked_pyc(self):
|
||||
+ # issue 34056
|
||||
+ with support.temp_cwd():
|
||||
+ with open('mymod.py', 'wb') as fp:
|
||||
+ fp.write(b'x = 42\n')
|
||||
+ py_compile.compile(
|
||||
+ 'mymod.py',
|
||||
+ doraise=True,
|
||||
+ invalidation_mode=py_compile.PycInvalidationMode.CHECKED_HASH,
|
||||
+ )
|
||||
+ file, path, description = imp.find_module('mymod', path=['.'])
|
||||
+ mod = imp.load_module('mymod', file, path, description)
|
||||
+ self.assertEqual(mod.x, 42)
|
||||
+
|
||||
|
||||
class ReloadTests(unittest.TestCase):
|
||||
|
Loading…
Reference in a new issue