mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/python to 3.6.3-1
This commit is contained in:
parent
3ed61133e0
commit
8043024a3f
2 changed files with 4 additions and 59 deletions
|
@ -10,7 +10,7 @@
|
|||
# - configure with --without-lto
|
||||
|
||||
pkgname=python
|
||||
pkgver=3.6.2
|
||||
pkgver=3.6.3
|
||||
pkgrel=1
|
||||
_pybasever=3.6
|
||||
pkgdesc="Next generation of the python high-level scripting language"
|
||||
|
@ -28,20 +28,15 @@ optdepends=('python-setuptools'
|
|||
provides=('python3')
|
||||
replaces=('python3')
|
||||
source=("https://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tar.xz"{,.asc}
|
||||
openssl-110f.patch
|
||||
dont-make-libpython-readonly.patch)
|
||||
sha512sums=('a8270a09a9e9b39f69ece6cdade2fa964665d2107b5acbad4453f1b921107b329c697c137185928fb4a576fc0f2ae2a98dbf26a8b7ea17219e990ddbc216db8b'
|
||||
sha512sums=('32f24a3adcb7880003c7ecdc5e53e838e774adda76b308961d8215e28db630b2fa2828097817924c76afa4212b2df3362eb64d4e10f37c0147f512ec5aa8662b'
|
||||
'SKIP'
|
||||
'b32c2a0f17b3d19720187b68606024886c6b8008b7c61feaf4fe7b26b4547fddc71a2f191f87557d5fe613d06a8bc79ce5f724681a3090559fc34a032ccbf61a'
|
||||
'2ef96708d5b13ae2a3d2cc62c87b4780e60ecfce914e190564492def3a11d5e56977659f41c7f9d12266e58050c766bce4e2b5d50b708eb792794fa8357920c4')
|
||||
validpgpkeys=('0D96DF4D4110E5C43FBFB17F2D347EA6AA65421D') # Ned Deily (Python release signing key) <nad@python.org>
|
||||
|
||||
prepare() {
|
||||
cd Python-${pkgver}
|
||||
|
||||
# https://bugs.python.org/issue30714
|
||||
patch -p1 -i ../openssl-110f.patch
|
||||
|
||||
# FS#45809
|
||||
patch -p1 -i ../dont-make-libpython-readonly.patch
|
||||
|
||||
|
@ -83,6 +78,7 @@ build() {
|
|||
|
||||
check() {
|
||||
# test_gdb is expected to fail with LTO
|
||||
# test_subprocess hangs on 3.6.3
|
||||
|
||||
cd Python-${pkgver}
|
||||
|
||||
|
@ -92,7 +88,7 @@ check() {
|
|||
|
||||
LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
|
||||
LC_CTYPE=en_US.UTF-8 xvfb-run -a -n "$servernum" \
|
||||
"${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_gdb
|
||||
"${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_gdb -x test_subprocess
|
||||
}
|
||||
|
||||
package() {
|
||||
|
|
|
@ -1,51 +0,0 @@
|
|||
From 0e396a20c3137244b1774bd14a0cb03921ff326d Mon Sep 17 00:00:00 2001
|
||||
From: Christian Heimes <christian@python.org>
|
||||
Date: Tue, 20 Jun 2017 18:28:38 +0200
|
||||
Subject: [PATCH] bpo-30714: ALPN changes for OpenSSL 1.1.0f
|
||||
|
||||
OpenSSL 1.1.0 to 1.1.0e aborted the handshake when server and client
|
||||
could not agree on a protocol using ALPN. OpenSSL 1.1.0f changed that.
|
||||
The most recent version now behaves like OpenSSL 1.0.2 again. The ALPN
|
||||
callback can pretend to not been set.
|
||||
|
||||
See https://github.com/openssl/openssl/pull/3158 for more details
|
||||
|
||||
Signed-off-by: Christian Heimes <christian@python.org>
|
||||
---
|
||||
Doc/library/ssl.rst | 5 +++--
|
||||
Lib/test/test_ssl.py | 5 +++--
|
||||
Misc/NEWS | 3 +++
|
||||
3 files changed, 9 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/Doc/library/ssl.rst b/Doc/library/ssl.rst
|
||||
index 729a239a1ba..b51b9c6e396 100644
|
||||
--- a/Doc/library/ssl.rst
|
||||
+++ b/Doc/library/ssl.rst
|
||||
@@ -1447,8 +1447,9 @@ to speed up repeated connections from the same clients.
|
||||
This method will raise :exc:`NotImplementedError` if :data:`HAS_ALPN` is
|
||||
False.
|
||||
|
||||
- OpenSSL 1.1.0+ will abort the handshake and raise :exc:`SSLError` when
|
||||
- both sides support ALPN but cannot agree on a protocol.
|
||||
+ OpenSSL 1.1.0 to 1.1.0e will abort the handshake and raise :exc:`SSLError`
|
||||
+ when both sides support ALPN but cannot agree on a protocol. 1.1.0f+
|
||||
+ behaves like 1.0.2.
|
||||
|
||||
.. versionadded:: 3.5
|
||||
|
||||
diff --git a/Lib/test/test_ssl.py b/Lib/test/test_ssl.py
|
||||
index fdaf1c52046..3215031206c 100644
|
||||
--- a/Lib/test/test_ssl.py
|
||||
+++ b/Lib/test/test_ssl.py
|
||||
@@ -3267,8 +3267,9 @@ def test_alpn_protocols(self):
|
||||
except ssl.SSLError as e:
|
||||
stats = e
|
||||
|
||||
- if expected is None and IS_OPENSSL_1_1:
|
||||
- # OpenSSL 1.1.0 raises handshake error
|
||||
+ if (expected is None and IS_OPENSSL_1_1
|
||||
+ and ssl.OPENSSL_VERSION_INFO < (1, 1, 0, 6)):
|
||||
+ # OpenSSL 1.1.0 to 1.1.0e raises handshake error
|
||||
self.assertIsInstance(stats, ssl.SSLError)
|
||||
else:
|
||||
msg = "failed trying %s (s) and %s (c).\n" \
|
Loading…
Reference in a new issue