core/linux-rpi: add support for xbox controller

Closes #2016
This commit is contained in:
graysky 2023-11-22 07:03:35 -05:00
parent 410327f461
commit 804af01a9d
2 changed files with 34 additions and 0 deletions

View file

@ -0,0 +1,29 @@
From 1999a6b12a3b5c8953fc9ec74863ebc75a1b851d Mon Sep 17 00:00:00 2001
From: Vicki Pfau <vi@endrift.com>
Date: Thu, 23 Mar 2023 18:32:43 -0700
Subject: [PATCH] Input: xpad - add VID for Turtle Beach controllers
This adds support for the Turtle Beach REACT-R and Recon Xbox controllers
Signed-off-by: Vicki Pfau <vi@endrift.com>
Link: https://lore.kernel.org/r/20230225012147.276489-4-vi@endrift.com
Signed-off-by: Dmitry Torokhov <dmitry.torokhov@gmail.com>
---
drivers/input/joystick/xpad.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/input/joystick/xpad.c b/drivers/input/joystick/xpad.c
index a1f23da7d72c2..49ae963e5f9df 100644
--- a/drivers/input/joystick/xpad.c
+++ b/drivers/input/joystick/xpad.c
@@ -474,6 +474,7 @@ static const struct usb_device_id xpad_table[] = {
XPAD_XBOX360_VENDOR(0x0f0d), /* Hori Controllers */
XPAD_XBOXONE_VENDOR(0x0f0d), /* Hori Controllers */
XPAD_XBOX360_VENDOR(0x1038), /* SteelSeries Controllers */
+ XPAD_XBOXONE_VENDOR(0x10f5), /* Turtle Beach Controllers */
XPAD_XBOX360_VENDOR(0x11c9), /* Nacon GC100XF */
XPAD_XBOX360_VENDOR(0x1209), /* Ardwiino Controllers */
XPAD_XBOX360_VENDOR(0x12ab), /* X-Box 360 dance pads */
--
2.43.0

View file

@ -26,6 +26,7 @@ source_aarch64=('config8' 'config8.txt')
source=("linux-$pkgver-${_commit:0:10}.tar.gz::https://github.com/raspberrypi/linux/archive/${_commit}.tar.gz"
cmdline.txt
0001-Make-proc-cpuinfo-consistent-on-arm64-and-arm.patch
0002-Input-xpad-add-VID-for-Turtle-Beach-controllers.patch
linux.preset
60-linux.hook
90-linux.hook
@ -34,6 +35,7 @@ source=("linux-$pkgver-${_commit:0:10}.tar.gz::https://github.com/raspberrypi/li
md5sums=('d5079b8dbb91823eb4723ca728841345'
'3bab7426d8c8818dda8353da3892a41f'
'f66a7ea3feb708d398ef57e4da4815e9'
'f89e0666bf9f0799a074379f29e6004d'
'86d4a35722b5410e3b29fc92dae15d4b'
'0a5f16bfec6ad982a2f6782724cca8ba'
'441ec084c47cddc53e592fb0cbce4edf'
@ -56,6 +58,9 @@ prepare() {
# consistent behavior of lscpu on arm/arm64
patch -p1 -i ../0001-Make-proc-cpuinfo-consistent-on-arm64-and-arm.patch
# xbox controller support
patch -p1 -i ../0002-Input-xpad-add-VID-for-Turtle-Beach-controllers.patch
echo "Setting version..."
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname