extra/calligra to 4.0.1-1

This commit is contained in:
Kevin Mihelich 2024-09-03 10:45:36 +00:00
parent e0c8284f76
commit 80b90f3d14
4 changed files with 10 additions and 49 deletions

View file

@ -1,7 +1,7 @@
pkgbase = calligra
pkgdesc = A set of applications for productivity and creative usage
pkgver = 4.0.0
pkgrel = 2
pkgver = 4.0.1
pkgrel = 1
url = https://www.calligra-suite.org/
arch = x86_64
license = GPL-2.0-only
@ -63,14 +63,10 @@ pkgbase = calligra
optdepends = poppler: PDF to SVG filter
optdepends = pstoedit: EPS to SVG filter
optdepends = qt6-webengine: Braindump web shape
source = https://download.kde.org/stable/calligra/calligra-4.0.0.tar.xz
source = https://download.kde.org/stable/calligra/calligra-4.0.0.tar.xz.sig
source = dependencies.patch
source = docs.patch
source = https://download.kde.org/stable/calligra/calligra-4.0.1.tar.xz
source = https://download.kde.org/stable/calligra/calligra-4.0.1.tar.xz.sig
validpgpkeys = 39FFA93CAE9C6AFC212AD00202325448204E452A
sha256sums = e97cb1dc0720074d37d8ec11662f2628384595311c3dac6b29477d6634144119
sha256sums = d401f5e73f4f1bdc0b3548ea1a50b0ac1778c1ede30a6a335944ed7fbd88d95f
sha256sums = SKIP
sha256sums = b14146c4e9574aed8d0266d6cb943b82c69fe252409b7e9d96c2e585333ecd03
sha256sums = e6c504adbe884be190c3016f75ec3897c7364d7ca82a695614b34a2a56288d90
pkgname = calligra

View file

@ -8,8 +8,8 @@
pkgname=calligra
pkgdesc='A set of applications for productivity and creative usage'
pkgver=4.0.0
pkgrel=2
pkgver=4.0.1
pkgrel=1
arch=(x86_64)
url='https://www.calligra-suite.org/'
license=(GPL-2.0-only)
@ -70,20 +70,11 @@ optdepends=('libetonyek: Apple Keynote import filter'
'poppler: PDF to SVG filter'
'pstoedit: EPS to SVG filter'
'qt6-webengine: Braindump web shape')
source=(https://download.kde.org/stable/$pkgname/$pkgname-$pkgver.tar.xz{,.sig}
dependencies.patch
docs.patch)
sha256sums=('e97cb1dc0720074d37d8ec11662f2628384595311c3dac6b29477d6634144119'
'SKIP'
'b14146c4e9574aed8d0266d6cb943b82c69fe252409b7e9d96c2e585333ecd03'
'e6c504adbe884be190c3016f75ec3897c7364d7ca82a695614b34a2a56288d90')
source=(https://download.kde.org/stable/$pkgname/$pkgname-$pkgver.tar.xz{,.sig})
sha256sums=('d401f5e73f4f1bdc0b3548ea1a50b0ac1778c1ede30a6a335944ed7fbd88d95f'
'SKIP')
validpgpkeys=(39FFA93CAE9C6AFC212AD00202325448204E452A) # Carl Schwan <carl@carlschwan.eu>
prepare() {
patch -d $pkgname-$pkgver -p1 < dependencies.patch
patch -d $pkgname-$pkgver -p1 < docs.patch
}
build() {
cmake -B build -S $pkgname-$pkgver \
-DRELEASE_BUILD=ON \

View file

@ -1,12 +0,0 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fb56ef6584d..8aafdbff288 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -153,7 +153,6 @@ find_package(KF6 ${REQUIRED_KF6_VERSION} REQUIRED
KIO
Notifications
NotifyConfig
- Parts
Sonnet
TextWidgets
WidgetsAddons

View file

@ -1,14 +0,0 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 66f657dc720..06c8816530d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1016,8 +1016,7 @@ endif(BUILD_TESTING)
ki18n_install(po)
if(KF6DocTools_FOUND)
- #kdoctools_install(po)
- # Disable for now, since it is failing
+ kdoctools_install(po)
endif()
file(GLOB_RECURSE ALL_CLANG_FORMAT_SOURCE_FILES *.cpp *.h)