extra/chromium: patch for skia

This commit is contained in:
Kevin Mihelich 2013-08-21 23:56:35 +00:00
parent bf6778c174
commit 812474fdc9
2 changed files with 18 additions and 2 deletions

View file

@ -14,6 +14,7 @@
# - use system ffmpeg, added ffmpeg to depends
# - patch to fix webrtc code for non-android ARM
# - patch to fix using system ffmpeg
# - patch (hack) to fix skia
#
# moonman <moonman [dot] ca [at] gmail [dot] com>
# -added armv6 support
@ -46,14 +47,16 @@ source=(https://gsdview.appspot.com/chromium-browser-official/$pkgname-$pkgver.t
chromium.sh
chromium-28.0.1500.71-avoid-std-string-copying-in-GetFileNameInWhitelist.patch
arm-webrtc-fix.patch
chromium-system-ffmpeg-r7.patch)
chromium-system-ffmpeg-r7.patch
skia.patch)
sha256sums=('ae77204a5417ad7bf1ade257ba49f3ca64c83ed5741cb811a31f9f675d498576'
'09bfac44104f4ccda4c228053f689c947b3e97da9a4ab6fa34ce061ee83d0322'
'478340d5760a9bd6c549e19b1b5d1c5b4933ebf5f8cfb2b3e2d70d07443fe232'
'4999fded897af692f4974f0a3e3bbb215193519918a1fa9b31ed51e74a2dccb9'
'7c2e448c30677999f524f9513c2f998f3cb15bc6084692cad9c3f310aa813530'
'222ec0db5d40b02e4ebbde8a1f1c5de3f0579e51836be87be138c44f8487d0ce'
'4093f87f16f8dc4dd846a88d5b6faf91bed2542308c6a11fef93400c94dbf192')
'4093f87f16f8dc4dd846a88d5b6faf91bed2542308c6a11fef93400c94dbf192'
'8a68654df274de9fd93d0d16dc18ba556cac7b08e69b4abc33538ec265822321')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
@ -73,6 +76,9 @@ prepare() {
# Fix using system ffmpeg
patch -Np1 -i "$srcdir/chromium-system-ffmpeg-r7.patch"
# Temp fix for skia
patch -Np0 -i "$srcdir/skia.patch"
# Fix deadlock related to the GPU sandbox when tcmalloc isn't used
# https://code.google.com/p/chromium/issues/detail?id=255063
# https://bugs.gentoo.org/show_bug.cgi?id=471198#c23

10
extra/chromium/skia.patch Normal file
View file

@ -0,0 +1,10 @@
--- skia/skia.gyp.orig 2013-08-21 15:19:34.068777150 -0600
+++ skia/skia.gyp 2013-08-21 15:20:16.163601088 -0600
@@ -753,6 +753,7 @@
'../third_party/skia/src/opts/SkBlitRow_opts_arm.cpp',
'../third_party/skia/src/opts/SkBlitRow_opts_arm.h',
'../third_party/skia/src/opts/opts_check_arm.cpp',
+ '../third_party/skia/src/opts/memset.arm.S',
],
}],
[ 'target_arch == "mipsel"',{