mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
community/linux-tools to 4.9-1
This commit is contained in:
parent
f986462708
commit
813498d470
2 changed files with 7 additions and 40 deletions
|
@ -1,31 +0,0 @@
|
||||||
diff --git a/tools/power/cpupower/utils/cpufreq-set.c b/tools/power/cpupower/utils/cpufreq-set.c
|
|
||||||
index b4bf769..f2d1bbd 100644
|
|
||||||
--- a/tools/power/cpupower/utils/cpufreq-set.c
|
|
||||||
+++ b/tools/power/cpupower/utils/cpufreq-set.c
|
|
||||||
@@ -296,9 +296,10 @@ int cmd_freq_set(int argc, char **argv)
|
|
||||||
struct cpufreq_affected_cpus *cpus;
|
|
||||||
|
|
||||||
if (!bitmask_isbitset(cpus_chosen, cpu) ||
|
|
||||||
- cpupower_is_cpu_online(cpu))
|
|
||||||
+ cpupower_is_cpu_online(cpu) != 1)
|
|
||||||
continue;
|
|
||||||
|
|
||||||
+
|
|
||||||
cpus = cpufreq_get_related_cpus(cpu);
|
|
||||||
if (!cpus)
|
|
||||||
break;
|
|
||||||
@@ -316,11 +317,10 @@ int cmd_freq_set(int argc, char **argv)
|
|
||||||
cpu <= bitmask_last(cpus_chosen); cpu++) {
|
|
||||||
|
|
||||||
if (!bitmask_isbitset(cpus_chosen, cpu) ||
|
|
||||||
- cpupower_is_cpu_online(cpu))
|
|
||||||
- continue;
|
|
||||||
-
|
|
||||||
- if (cpupower_is_cpu_online(cpu) != 1)
|
|
||||||
+ cpupower_is_cpu_online(cpu) != 1) {
|
|
||||||
+ printf(_("Ignoring cpu: %d\n"), cpu);
|
|
||||||
continue;
|
|
||||||
+ }
|
|
||||||
|
|
||||||
printf(_("Setting cpu: %d\n"), cpu);
|
|
||||||
ret = do_one_cpu(cpu, &new_pol, freq, policychange);
|
|
|
@ -16,11 +16,11 @@ pkgname=(
|
||||||
'tmon'
|
'tmon'
|
||||||
'usbip'
|
'usbip'
|
||||||
)
|
)
|
||||||
pkgver=4.8
|
pkgver=4.9
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
license=('GPL2')
|
license=('GPL2')
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
url='http://www.kernel.org'
|
url='https://www.kernel.org'
|
||||||
options=('!strip')
|
options=('!strip')
|
||||||
makedepends=('git')
|
makedepends=('git')
|
||||||
# split packages need all package dependencies set manually in makedepends
|
# split packages need all package dependencies set manually in makedepends
|
||||||
|
@ -40,14 +40,12 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-${pkgver}.tar.xz"
|
||||||
'cpupower.default'
|
'cpupower.default'
|
||||||
'cpupower.systemd'
|
'cpupower.systemd'
|
||||||
'cpupower.service'
|
'cpupower.service'
|
||||||
'usbipd.service'
|
'usbipd.service')
|
||||||
'01-cpupower-governor-fix.patch')
|
md5sums=('0a68ef3615c64bd5ee54a3320e46667d'
|
||||||
md5sums=('c1af0afbd3df35c1ccdc7a5118cd2d07'
|
|
||||||
'56883c159381ba89e50ab8ea65efec77'
|
'56883c159381ba89e50ab8ea65efec77'
|
||||||
'34f5ecc19770a1abbcd0fd65bfd1f065'
|
'34f5ecc19770a1abbcd0fd65bfd1f065'
|
||||||
'86c4e419e4ba80835c330d49ba3f56ad'
|
'86c4e419e4ba80835c330d49ba3f56ad'
|
||||||
'bb35634f480325a78b943f7e10165e86'
|
'bb35634f480325a78b943f7e10165e86')
|
||||||
'33c871519adfd4e5575643c4579d019b')
|
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd linux-$pkgver
|
cd linux-$pkgver
|
||||||
|
@ -57,8 +55,8 @@ prepare() {
|
||||||
local filename
|
local filename
|
||||||
for filename in "${source[@]}"; do
|
for filename in "${source[@]}"; do
|
||||||
if [[ "$filename" =~ \.patch$ ]]; then
|
if [[ "$filename" =~ \.patch$ ]]; then
|
||||||
msg2 "Applying patch $filename"
|
msg2 "Applying patch ${filename##*/}"
|
||||||
patch -p1 -N -i "$srcdir/$filename"
|
patch -p1 -N -i "$srcdir/${filename##*/}"
|
||||||
fi
|
fi
|
||||||
done
|
done
|
||||||
}
|
}
|
||||||
|
|
Loading…
Reference in a new issue