mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
community/xbmc to 13.1-3
This commit is contained in:
parent
b6e73123c3
commit
815c156322
2 changed files with 30 additions and 3 deletions
|
@ -18,7 +18,7 @@ _prefix=/usr
|
|||
pkgname=xbmc
|
||||
pkgver=13.1
|
||||
_codename=Gotham
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
pkgdesc="A software media player and entertainment hub for digital media"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://xbmc.org"
|
||||
|
@ -51,16 +51,19 @@ install="${pkgname}.install"
|
|||
source=("xbmc-$pkgver-$_codename.tar.gz::https://github.com/xbmc/xbmc/archive/$pkgver-$_codename.tar.gz"
|
||||
'xbmc.service'
|
||||
'enable-external-ffmpeg.patch'
|
||||
'0001-make-sure-applications-xbmc.desktop-does-nt-have-exe.patch')
|
||||
'0001-make-sure-applications-xbmc.desktop-does-nt-have-exe.patch'
|
||||
'libnfs-header-changes.patch')
|
||||
sha256sums=('344b604eae2ddb47c032dd7964d01f27e6fcd7a8873c84c0841d5da75961a678'
|
||||
'f83097388e6c9b301cac78de95cf1797d4aaa11e4021734c28d643320e76d919'
|
||||
'0239e33e87292c7340ed2092f2b5f1e82f5e283b1f763fb125b3aee78f50c355'
|
||||
'5f5fe2932050265ad71c82b5d23efe5eaf7b2b3a152bdc6da66675cfb655fabe')
|
||||
'5f5fe2932050265ad71c82b5d23efe5eaf7b2b3a152bdc6da66675cfb655fabe'
|
||||
'cec996873f7c45fd01c04b5598152f4a13509eed9b38f395dd1fe0d5c8a4c1ff')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/xbmc-$pkgver-$_codename"
|
||||
patch -p1 -i "$srcdir/enable-external-ffmpeg.patch"
|
||||
patch -p1 -i "$srcdir/0001-make-sure-applications-xbmc.desktop-does-nt-have-exe.patch"
|
||||
patch -p1 -i "$srcdir/libnfs-header-changes.patch"
|
||||
|
||||
find -type f -name *.py -exec sed 's|^#!.*python$|#!/usr/bin/python2|' -i "{}" +
|
||||
sed 's|^#!.*python$|#!/usr/bin/python2|' -i tools/depends/native/rpl-native/rpl
|
||||
|
|
24
community/xbmc/libnfs-header-changes.patch
Normal file
24
community/xbmc/libnfs-header-changes.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
diff --git a/xbmc/filesystem/NFSDirectory.cpp b/xbmc/filesystem/NFSDirectory.cpp
|
||||
index 85084a5..8efa7bf 100644
|
||||
--- a/xbmc/filesystem/NFSDirectory.cpp
|
||||
+++ b/xbmc/filesystem/NFSDirectory.cpp
|
||||
@@ -37,6 +37,7 @@
|
||||
using namespace XFILE;
|
||||
using namespace std;
|
||||
#include <limits.h>
|
||||
+#include <nfsc/libnfs-zdr.h>
|
||||
#include <nfsc/libnfs-raw-mount.h>
|
||||
#include <nfsc/libnfs-raw-nfs.h>
|
||||
|
||||
diff --git a/xbmc/filesystem/NFSFile.cpp b/xbmc/filesystem/NFSFile.cpp
|
||||
index 479f3fe..2aeea32 100644
|
||||
--- a/xbmc/filesystem/NFSFile.cpp
|
||||
+++ b/xbmc/filesystem/NFSFile.cpp
|
||||
@@ -32,6 +32,7 @@
|
||||
#include "network/DNSNameCache.h"
|
||||
#include "threads/SystemClock.h"
|
||||
|
||||
+#include <nfsc/libnfs-zdr.h>
|
||||
#include <nfsc/libnfs-raw-mount.h>
|
||||
|
||||
#ifdef TARGET_WINDOWS
|
Loading…
Reference in a new issue