mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/cantor to 18.08.0-4
This commit is contained in:
parent
05457a0e6e
commit
816ae0fb57
2 changed files with 18 additions and 3 deletions
|
@ -8,7 +8,7 @@
|
|||
|
||||
pkgname=cantor
|
||||
pkgver=18.08.0
|
||||
pkgrel=3
|
||||
pkgrel=4
|
||||
pkgdesc="KDE Frontend to Mathematical Software"
|
||||
url="https://kde.org/applications/education/cantor/"
|
||||
arch=(x86_64)
|
||||
|
@ -24,11 +24,12 @@ optdepends=('maxima: Maxima backend'
|
|||
'python2: Python 2 backend'
|
||||
'sagemath: SageMath backend')
|
||||
source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig}
|
||||
cantor-julia.patch::"https://cgit.kde.org/cantor.git/patch/?id=90b001d1" cantor-julia-0.7.patch)
|
||||
cantor-julia.patch::"https://cgit.kde.org/cantor.git/patch/?id=90b001d1" cantor-julia-0.7.patch sage-8.3.patch)
|
||||
sha256sums=('be6167ec88504091e9fa9914e0bd1fbb13637fb2b2b228c9274225db6dc85823'
|
||||
'SKIP'
|
||||
'366e1a734a968c4a933e91342308e4d18108c1bc023572848747ca6a2ec656f7'
|
||||
'cf031eb1891a97f964c9147a4ff4d7e69f3821eee8fb5dab0693c6483dacd4ee')
|
||||
'cf031eb1891a97f964c9147a4ff4d7e69f3821eee8fb5dab0693c6483dacd4ee'
|
||||
'78c90097749e53433641b3acfd637b2aaa12f04c03a304b71c2cc5a5672cb4de')
|
||||
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
|
||||
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <cfeck@kde.org>
|
||||
|
||||
|
@ -38,6 +39,7 @@ prepare() {
|
|||
cd $pkgname-$pkgver
|
||||
patch -p1 -i ../cantor-julia.patch # Fix julia backend build
|
||||
patch -p1 -i ../cantor-julia-0.7.patch # support julia>=0.7
|
||||
patch -p1 -i ../sage-8.3.patch # fix sagemath backend with 8.3
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
13
extra/cantor/sage-8.3.patch
Normal file
13
extra/cantor/sage-8.3.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/src/backends/sage/sagesession.cpp b/src/backends/sage/sagesession.cpp
|
||||
index c2973a8a..f23914ad 100644
|
||||
--- a/src/backends/sage/sagesession.cpp
|
||||
+++ b/src/backends/sage/sagesession.cpp
|
||||
@@ -118,7 +118,7 @@ void SageSession::login()
|
||||
m_process=new KPtyProcess(this);
|
||||
updateSageVersion();
|
||||
const QString& sageExecFile = SageSettings::self()->path().toLocalFile();
|
||||
- if (m_sageVersion >= SageSession::VersionInfo(8, 3))
|
||||
+ if (m_sageVersion >= SageSession::VersionInfo(8, 4))
|
||||
m_process->setProgram(sageExecFile, QStringList() << QLatin1String("--simple-prompt"));
|
||||
else
|
||||
{
|
Loading…
Reference in a new issue