mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/kwin fixes
This commit is contained in:
parent
7faa4a1283
commit
816d992b02
3 changed files with 16 additions and 15 deletions
|
@ -25,17 +25,18 @@ conflicts=('kdebase-workspace')
|
|||
source=("http://download.kde.org/stable/plasma/${_dir}/${pkgname}-${pkgver}.tar.xz"
|
||||
"rpi_fix_build.patch"
|
||||
"kwin_remove_eglonxbackend.patch")
|
||||
md5sums=('47b6ce31b45450fa702098c9f3f5ac95'
|
||||
'3e11a42013f03d55b4b730463bdd6fe0'
|
||||
'28a1e8bd701a8fd1421e6ec238b4c522')
|
||||
md5sums=('863205ef27b7a11897fdeb24a75399ed'
|
||||
'65af20bd49436056c93932ad7f80f7dd'
|
||||
'176fedf90b0056de0934ea926095de89')
|
||||
|
||||
prepare() {
|
||||
mkdir build
|
||||
|
||||
# Raspberry Pi
|
||||
if [ "$CARCH" == 'armv6h' ]; then
|
||||
patch -p1 -i "${srcdir}/rpi_fix_build.patch"
|
||||
patch -p1 -i "${srcdir}/kwin_remove_eglonxbackend.patch"
|
||||
cd ${pkgname}-${pkgver}
|
||||
patch -p1 -i ../rpi_fix_build.patch
|
||||
patch -p1 -i ../kwin_remove_eglonxbackend.patch
|
||||
fi
|
||||
}
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
diff -urN a/CMakeLists.txt b/CMakeLists.txt
|
||||
--- a/CMakeLists.txt 2015-01-26 03:44:19.000000000 -0700
|
||||
+++ b/CMakeLists.txt 2015-01-27 06:00:42.290677955 -0700
|
||||
@@ -392,10 +392,6 @@
|
||||
--- a/CMakeLists.txt 2015-02-21 13:23:27.000000000 -0700
|
||||
+++ b/CMakeLists.txt 2015-03-01 16:00:41.823988772 -0700
|
||||
@@ -393,10 +393,6 @@
|
||||
)
|
||||
endif()
|
||||
|
||||
|
@ -13,8 +13,8 @@ diff -urN a/CMakeLists.txt b/CMakeLists.txt
|
|||
set(kwin_KDEINIT_SRCS
|
||||
${kwin_KDEINIT_SRCS}
|
||||
diff -urN a/scene_opengl.cpp b/scene_opengl.cpp
|
||||
--- a/scene_opengl.cpp 2015-01-26 03:27:31.000000000 -0700
|
||||
+++ b/scene_opengl.cpp 2015-01-27 06:00:42.295677953 -0700
|
||||
--- a/scene_opengl.cpp 2015-02-21 13:21:17.000000000 -0700
|
||||
+++ b/scene_opengl.cpp 2015-03-01 16:00:41.838988770 -0700
|
||||
@@ -28,7 +28,6 @@
|
||||
*********************************************************************/
|
||||
#include "scene_opengl.h"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
diff -urN a/libkwineffects/kwinglplatform.cpp b/libkwineffects/kwinglplatform.cpp
|
||||
--- a/libkwineffects/kwinglplatform.cpp 2015-01-26 03:27:31.000000000 -0700
|
||||
+++ b/libkwineffects/kwinglplatform.cpp 2015-01-27 05:56:33.605773992 -0700
|
||||
--- a/libkwineffects/kwinglplatform.cpp 2015-02-21 13:21:17.000000000 -0700
|
||||
+++ b/libkwineffects/kwinglplatform.cpp 2015-03-01 16:01:13.843985675 -0700
|
||||
@@ -25,6 +25,8 @@
|
||||
#include <QStringList>
|
||||
#include <QDebug>
|
||||
|
@ -11,9 +11,9 @@ diff -urN a/libkwineffects/kwinglplatform.cpp b/libkwineffects/kwinglplatform.cp
|
|||
|
||||
#include <iostream>
|
||||
diff -urN a/libkwineffects/kwingltexture.cpp b/libkwineffects/kwingltexture.cpp
|
||||
--- a/libkwineffects/kwingltexture.cpp 2015-01-26 03:27:31.000000000 -0700
|
||||
+++ b/libkwineffects/kwingltexture.cpp 2015-01-27 05:56:33.605773992 -0700
|
||||
@@ -315,7 +315,7 @@
|
||||
--- a/libkwineffects/kwingltexture.cpp 2015-02-21 13:21:17.000000000 -0700
|
||||
+++ b/libkwineffects/kwingltexture.cpp 2015-03-01 16:01:13.843985675 -0700
|
||||
@@ -320,7 +320,7 @@
|
||||
bool GLTexture::isNull() const
|
||||
{
|
||||
Q_D(const GLTexture);
|
||||
|
|
Loading…
Reference in a new issue