mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
alarm/uboot-cubox-i to 2013.10-5
This commit is contained in:
parent
5214c98043
commit
818177ad3c
4 changed files with 61 additions and 82 deletions
|
@ -1,18 +1,18 @@
|
|||
# U-Boot: UDOO
|
||||
# Maintainer: Dave Higham <pepedog@archlinuxarm.org>
|
||||
# Maintainer: Oleg Rakhmanov <oleg@archlinuxarm.org>
|
||||
|
||||
buildarch=4
|
||||
|
||||
pkgbase=uboot-cubox-i
|
||||
pkgname=('uboot-cubox-i')
|
||||
pkgver=2013.10
|
||||
pkgrel=4
|
||||
pkgrel=5
|
||||
arch=('armv7h')
|
||||
url="http://git.denx.de/u-boot.git/"
|
||||
license=('GPL')
|
||||
makedepends=('git')
|
||||
option=('!strip')
|
||||
_commit=e509dd30e97bf2cbce21502e4462d9d7c1d85daa
|
||||
_commit=408544d61f230060f18ffe2e06565deadbcf3451
|
||||
source=("uboot-${_commit}.tar.gz::https://github.com/SolidRun/u-boot-imx6/archive/${_commit}.tar.gz"
|
||||
'kernel-add-support-for-gcc-5.patch'
|
||||
'arm_board_use_weak.patch'
|
||||
|
@ -21,8 +21,8 @@ source=("uboot-${_commit}.tar.gz::https://github.com/SolidRun/u-boot-imx6/archiv
|
|||
'u-boot-002-gcc5-use_gcc_inline_version_instead_c99.patch'
|
||||
'no-unalligned-access.patch'
|
||||
'common-main.c-make-show_boot_progress-__weak.patch'
|
||||
'check_dtbs_subdir_fix.patch')
|
||||
md5sums=('3417d53a913949fd80c052fc8662c2a4'
|
||||
'arch-linux-arm-modifications.patch')
|
||||
md5sums=('8dc15f4cf0b244a8d9598a2ce93056a4'
|
||||
'721a46867e189d8dedc6b6f86a536a34'
|
||||
'b8cd082b76224d157d55404d0bc87831'
|
||||
'cf823fe2da67b8db5b9de9352a815f91'
|
||||
|
@ -30,7 +30,7 @@ md5sums=('3417d53a913949fd80c052fc8662c2a4'
|
|||
'8ed91e4257bfb7e0971fa988342537a3'
|
||||
'629d34349b5652e2d4274ad89e1c4481'
|
||||
'8087672256020417438b12ec4946e1cf'
|
||||
'e1487acbad44446e74a8825b4c88142c')
|
||||
'5352b85da1ee65eb4565d375d72b253c')
|
||||
prepare() {
|
||||
cd u-boot-imx6-${_commit}
|
||||
|
||||
|
@ -41,7 +41,7 @@ prepare() {
|
|||
patch -Np1 -i ../u-boot-002-gcc5-use_gcc_inline_version_instead_c99.patch
|
||||
patch -Np1 -i ../no-unalligned-access.patch
|
||||
patch -Np1 -i ../common-main.c-make-show_boot_progress-__weak.patch
|
||||
patch -Np1 -i ../check_dtbs_subdir_fix.patch
|
||||
patch -Np1 -i ../arch-linux-arm-modifications.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
54
alarm/uboot-cubox-i/arch-linux-arm-modifications.patch
Normal file
54
alarm/uboot-cubox-i/arch-linux-arm-modifications.patch
Normal file
|
@ -0,0 +1,54 @@
|
|||
diff -ruN a/include/configs/mx6_cubox-i.h b/include/configs/mx6_cubox-i.h
|
||||
--- a/include/configs/mx6_cubox-i.h 2015-10-13 11:56:13.000000000 +0000
|
||||
+++ b/include/configs/mx6_cubox-i.h 2015-11-05 18:35:27.766174690 +0000
|
||||
@@ -97,6 +97,7 @@
|
||||
#define CONFIG_FS_EXT4
|
||||
#define CONFIG_FS_FAT
|
||||
#define CONFIG_CMD_FS_GENERIC
|
||||
+#define CONFIG_SUPPORT_RAW_INITRD
|
||||
|
||||
/* Ethernet Configuration */
|
||||
#define CONFIG_FEC_MXC
|
||||
@@ -176,11 +177,14 @@
|
||||
"bootfile=auto\0" \
|
||||
"bootenv=uEnv.txt\0" \
|
||||
"boot_prefixes=/ /boot/\0" \
|
||||
+ "fdtfile_prefix=dtbs/\0" \
|
||||
"console=ttymxc0\0" \
|
||||
"splashpos=m,m\0" \
|
||||
"fdt_high=0xffffffff\0" \
|
||||
"initrd_high=0xffffffff\0" \
|
||||
"fdt_addr=0x18000000\0" \
|
||||
+ "ramdisk_file=initramfs-linux.img\0" \
|
||||
+ "ramdisk_addr=0x15100000\0" \
|
||||
"boot_fdt=try\0" \
|
||||
"ip_dyn=yes\0" \
|
||||
"mmcdev=" __stringify(CONFIG_SYS_MMC_ENV_DEV) "\0" \
|
||||
@@ -220,7 +224,9 @@
|
||||
"fi;\0" \
|
||||
"loadbootenv=load mmc ${mmcdev}:${mmcpart} ${loadaddr} ${file_prefix}${bootenv};\0" \
|
||||
"loadfdt=if test ${boottype} = mmc; then " \
|
||||
- "load mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${file_prefix}${fdt_file}; " \
|
||||
+ "if load mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${file_prefix}${fdt_file}; then; else " \
|
||||
+ "load mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${file_prefix}${fdtfile_prefix}${fdt_file}; " \
|
||||
+ "fi; " \
|
||||
"else " \
|
||||
"${get_cmd} ${fdt_addr} ${fdt_file}; " \
|
||||
"fi;\0 " \
|
||||
@@ -228,13 +234,14 @@
|
||||
"load mmc ${mmcdev}:${mmcpart} ${ramdisk_addr} ${file_prefix}${ramdisk_file}; " \
|
||||
"else " \
|
||||
"${get_cmd} ${ramdisk_addr} ${ramdisk_file}; " \
|
||||
- "fi;\0 " \
|
||||
+ "fi; " \
|
||||
+ "setenv ramdisk_size :${filesize}; \0" \
|
||||
"loadbootfile=load mmc ${mmcdev}:${mmcpart} ${loadaddr} ${file_prefix}${bootfile};\0" \
|
||||
"importbootenv=echo Importing environment from mmc${mmcdev} ...; " \
|
||||
"env import -t ${loadaddr} ${filesize};\0" \
|
||||
"autoboot=echo Booting ${boot_file}; " \
|
||||
"if test ${boot_file} = zImage; then " \
|
||||
- "bootz ${loadaddr} ${ramdisk_addr} ${fdt_addr}; " \
|
||||
+ "bootz ${loadaddr} ${ramdisk_addr}${ramdisk_size} ${fdt_addr}; " \
|
||||
"else " \
|
||||
"bootm ${loadaddr} ${ramdisk_addr} ${fdt_addr}; " \
|
||||
"fi;\0 " \
|
|
@ -1,22 +0,0 @@
|
|||
diff -ruN a/include/configs/mx6_cubox-i.h b/include/configs/mx6_cubox-i.h
|
||||
--- a/include/configs/mx6_cubox-i.h 2015-06-30 15:34:48.000000000 +0000
|
||||
+++ b/include/configs/mx6_cubox-i.h 2015-08-28 05:48:43.225896471 +0000
|
||||
@@ -176,6 +176,7 @@
|
||||
"bootfile=auto\0" \
|
||||
"bootenv=uEnv.txt\0" \
|
||||
"boot_prefixes=/ /boot/\0" \
|
||||
+ "fdtfile_prefix=dtbs/\0" \
|
||||
"console=ttymxc0\0" \
|
||||
"splashpos=m,m\0" \
|
||||
"fdt_high=0xffffffff\0" \
|
||||
@@ -220,7 +221,9 @@
|
||||
"fi;\0" \
|
||||
"loadbootenv=load mmc ${mmcdev}:${mmcpart} ${loadaddr} ${file_prefix}${bootenv};\0" \
|
||||
"loadfdt=if test ${boottype} = mmc; then " \
|
||||
- "load mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${file_prefix}${fdt_file}; " \
|
||||
+ "if load mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${file_prefix}${fdt_file}; then; else " \
|
||||
+ "load mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${file_prefix}${fdtfile_prefix}${fdt_file}; " \
|
||||
+ "fi; " \
|
||||
"else " \
|
||||
"${get_cmd} ${fdt_addr} ${fdt_file}; " \
|
||||
"fi;\0 " \
|
|
@ -1,53 +0,0 @@
|
|||
This is much like a regular shell's -e operator, except that it takes
|
||||
multiple arguments to specify the device type and device/partition ID
|
||||
in addition to the usual filename:
|
||||
|
||||
if test -e mmc 0:1 /boot/boot.scr; then echo yes; else echo no; fi
|
||||
|
||||
Signed-off-by: Stephen Warren <swarren at nvidia.com>
|
||||
---
|
||||
v3: New patch.
|
||||
---
|
||||
common/cmd_test.c | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/common/cmd_test.c b/common/cmd_test.c
|
||||
index 4c2f967c6dc0..c93fe7823100 100644
|
||||
--- a/common/cmd_test.c
|
||||
+++ b/common/cmd_test.c
|
||||
@@ -16,6 +16,7 @@
|
||||
|
||||
#include <common.h>
|
||||
#include <command.h>
|
||||
+#include <fs.h>
|
||||
|
||||
#define OP_INVALID 0
|
||||
#define OP_NOT 1
|
||||
@@ -33,6 +34,7 @@
|
||||
#define OP_INT_LE 13
|
||||
#define OP_INT_GT 14
|
||||
#define OP_INT_GE 15
|
||||
+#define OP_FILE_EXISTS 16
|
||||
|
||||
const struct {
|
||||
int arg;
|
||||
@@ -55,6 +57,7 @@ const struct {
|
||||
{0, "-a", OP_AND, 1},
|
||||
{0, "-z", OP_STR_EMPTY, 2},
|
||||
{0, "-n", OP_STR_NEMPTY, 2},
|
||||
+ {0, "-e", OP_FILE_EXISTS, 4},
|
||||
};
|
||||
|
||||
static int do_test(cmd_tbl_t *cmdtp, int flag, int argc, char * const argv[])
|
||||
@@ -143,6 +146,9 @@ static int do_test(cmd_tbl_t *cmdtp, int flag, int argc, char * const argv[])
|
||||
expr = simple_strtol(ap[0], NULL, 10) >=
|
||||
simple_strtol(ap[2], NULL, 10);
|
||||
break;
|
||||
+ case OP_FILE_EXISTS:
|
||||
+ expr = file_exists(ap[1], ap[2], ap[3], FS_TYPE_ANY);
|
||||
+ break;
|
||||
}
|
||||
|
||||
switch (op) {
|
||||
--
|
||||
1.8.1.5
|
Loading…
Reference in a new issue