mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
removed community/libextractor
This commit is contained in:
parent
f802b30a35
commit
8192983c69
3 changed files with 0 additions and 203 deletions
|
@ -1,57 +0,0 @@
|
|||
# Maintainer: Sergej Pupykin <pupykin.s@gmail.com>
|
||||
# Contributor: damir <damir@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch from Fedora to fix FTBFS
|
||||
|
||||
pkgname=libextractor
|
||||
pkgver=1.9
|
||||
pkgrel=3
|
||||
pkgdesc="A library used to extract meta-data from files of arbitrary type"
|
||||
arch=("x86_64")
|
||||
license=('GPL')
|
||||
url="https://www.gnu.org/software/libextractor/"
|
||||
depends=('libltdl')
|
||||
makedepends=('exiv2' 'ffmpeg' 'file' 'flac' 'gst-plugins-base-libs' 'libgsf' 'libmpeg2' 'libvorbis'
|
||||
'poppler' 'libsmf')
|
||||
optdepends=('exiv2: metadata support'
|
||||
'ffmpeg: previewopus/thumbnailffmpeg support'
|
||||
'file: mime support'
|
||||
'flac: flac support'
|
||||
'gst-plugins-base-libs: gstreamer support'
|
||||
'libarchive: archive support'
|
||||
'libgsf: (optional) for ODF support'
|
||||
'libmpeg2: mpeg support'
|
||||
'libvorbis: ogg/vorbis support'
|
||||
'poppler: pdf support'
|
||||
'libsmf: midi support')
|
||||
validpgpkeys=('19647543F7861D3BF4E64FF7BF60708B48426C7E'
|
||||
'D8423BCB326C7907033929C7939E6BE1E29FC3CC')
|
||||
source=("https://ftp.gnu.org/gnu/libextractor/${pkgname}-${pkgver}.tar.gz"{,.sig}
|
||||
libextractor-exiv2-0.27.patch
|
||||
libextractor-1.7-segfault.patch)
|
||||
sha512sums=('c2539b144d026fb0e871c5776aee4deaad4a987a730350744a7e5e74fbe98a4abb635dbe206b93c3aa9cd676b8797ea0b97271de0c903dfb035e245ab42ea149'
|
||||
'SKIP'
|
||||
'6411df1498fd3594088b3488e490b25009e9243684b777d35fa26189c20f410b42496b5fb42f762c468df746a9bdcd6a310f645db5ab0bbe3bd121e82aa9d48c'
|
||||
'60f8847b95ae568b55c1ef528472c71166701963a419d3a17afc7359ced4d7d7b9e607410d678412b59ab9fb937e9abc3437d266508200bf6d199271a7574a81')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
patch -p1 -i ../libextractor-exiv2-0.27.patch # Fix build with exiv2 0.27 (Gentoo)
|
||||
sed -e 's/ CODEC_FLAG_QSCALE/ AV_CODEC_FLAG_QSCALE/' \
|
||||
-e 's/FF_INPUT_BUFFER_PADDING_SIZE/AV_INPUT_BUFFER_PADDING_SIZE/' \
|
||||
-i src/plugins/thumbnailffmpeg_extractor.c
|
||||
patch -p0 -i ../libextractor-1.7-segfault.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
./configure --prefix=/usr --enable-shared --disable-static
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname-$pkgver
|
||||
make DESTDIR="$pkgdir" install
|
||||
rm "$pkgdir"/usr/share/info/dir
|
||||
}
|
|
@ -1,19 +0,0 @@
|
|||
*** src/plugins/ole2_extractor.c~ 2018-06-20 15:02:55.000000000 -0500
|
||||
--- src/plugins/ole2_extractor.c 2018-07-18 15:21:13.411495048 -0500
|
||||
***************
|
||||
*** 336,342 ****
|
||||
(buf[1] != 0x0) ||
|
||||
(0 != strncmp (&buf[2],
|
||||
"SfxDocumentInfo",
|
||||
! strlen ("SfxDocumentInfo"))) ||
|
||||
(buf[0x11] != 0x0B) ||
|
||||
(buf[0x13] != 0x00) || /* pw protected! */
|
||||
(buf[0x12] != 0x00) )
|
||||
--- 336,342 ----
|
||||
(buf[1] != 0x0) ||
|
||||
(0 != strncmp (&buf[2],
|
||||
"SfxDocumentInfo",
|
||||
! strlen ("SfxDocumentInfo") + 1)) ||
|
||||
(buf[0x11] != 0x0B) ||
|
||||
(buf[0x13] != 0x00) || /* pw protected! */
|
||||
(buf[0x12] != 0x00) )
|
|
@ -1,127 +0,0 @@
|
|||
From bbe21db4bf8face03adf0efd2eb18540582cb5ba Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
|
||||
Date: Sun, 30 Dec 2018 00:46:57 +0100
|
||||
Subject: [PATCH] Fix build with exiv2-0.27
|
||||
|
||||
---
|
||||
src/plugins/exiv2_extractor.cc | 35 +++++++++++++++++++++++++++-------
|
||||
1 file changed, 28 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/src/plugins/exiv2_extractor.cc b/src/plugins/exiv2_extractor.cc
|
||||
index 8741d40..ef402a8 100644
|
||||
--- a/src/plugins/exiv2_extractor.cc
|
||||
+++ b/src/plugins/exiv2_extractor.cc
|
||||
@@ -27,10 +27,7 @@
|
||||
#include <cassert>
|
||||
#include <cstring>
|
||||
#include <math.h>
|
||||
-#include <exiv2/exif.hpp>
|
||||
-#include <exiv2/error.hpp>
|
||||
-#include <exiv2/image.hpp>
|
||||
-#include <exiv2/futils.hpp>
|
||||
+#include <exiv2/exiv2.hpp>
|
||||
|
||||
/**
|
||||
* Enable debugging to get error messages.
|
||||
@@ -180,7 +177,7 @@ public:
|
||||
*
|
||||
* @return -1 on error
|
||||
*/
|
||||
-#if EXIV2_VERSION >= EXIV2_MAKE_VERSION(0,26,0)
|
||||
+#if EXIV2_TEST_VERSION(0,26,0)
|
||||
virtual size_t size (void) const;
|
||||
#else
|
||||
virtual long int size (void) const;
|
||||
@@ -316,7 +313,11 @@ ExtractorIO::getb ()
|
||||
const unsigned char *r;
|
||||
|
||||
if (1 != ec->read (ec->cls, &data, 1))
|
||||
+#if EXIV2_TEST_VERSION(0,27,0)
|
||||
+ throw Exiv2::BasicError<char> (Exiv2::kerDecodeLangAltQualifierFailed);
|
||||
+#else
|
||||
throw Exiv2::BasicError<char> (42 /* error code */);
|
||||
+#endif
|
||||
r = (const unsigned char *) data;
|
||||
return *r;
|
||||
}
|
||||
@@ -371,7 +372,11 @@ ExtractorIO::putb (Exiv2::byte data)
|
||||
void
|
||||
ExtractorIO::transfer (Exiv2::BasicIo& src)
|
||||
{
|
||||
+#if EXIV2_TEST_VERSION(0,27,0)
|
||||
+ throw Exiv2::BasicError<char> (Exiv2::kerDecodeLangAltQualifierFailed);
|
||||
+#else
|
||||
throw Exiv2::BasicError<char> (42 /* error code */);
|
||||
+#endif
|
||||
}
|
||||
|
||||
|
||||
@@ -416,7 +421,11 @@ ExtractorIO::seek (long offset,
|
||||
Exiv2::byte *
|
||||
ExtractorIO::mmap (bool isWritable)
|
||||
{
|
||||
+#if EXIV2_TEST_VERSION(0,27,0)
|
||||
+ throw Exiv2::BasicError<char> (Exiv2::kerDecodeLangAltQualifierFailed);
|
||||
+#else
|
||||
throw Exiv2::BasicError<char> (42 /* error code */);
|
||||
+#endif
|
||||
}
|
||||
|
||||
|
||||
@@ -449,7 +458,7 @@ ExtractorIO::tell (void) const
|
||||
*
|
||||
* @return -1 on error
|
||||
*/
|
||||
-#if EXIV2_VERSION >= EXIV2_MAKE_VERSION(0,26,0)
|
||||
+#if EXIV2_TEST_VERSION(0,26,0)
|
||||
size_t
|
||||
#else
|
||||
long int
|
||||
@@ -504,7 +513,11 @@ ExtractorIO::eof () const
|
||||
std::string
|
||||
ExtractorIO::path () const
|
||||
{
|
||||
+#if EXIV2_TEST_VERSION(0,27,0)
|
||||
+ throw Exiv2::BasicError<char> (Exiv2::kerDecodeLangAltQualifierFailed);
|
||||
+#else
|
||||
throw Exiv2::BasicError<char> (42 /* error code */);
|
||||
+#endif
|
||||
}
|
||||
|
||||
|
||||
@@ -517,7 +530,11 @@ ExtractorIO::path () const
|
||||
std::wstring
|
||||
ExtractorIO::wpath () const
|
||||
{
|
||||
+#if EXIV2_TEST_VERSION(0,27,0)
|
||||
+ throw Exiv2::BasicError<char> (Exiv2::kerDecodeLangAltQualifierFailed);
|
||||
+#else
|
||||
throw Exiv2::BasicError<char> (42 /* error code */);
|
||||
+#endif
|
||||
}
|
||||
#endif
|
||||
|
||||
@@ -531,7 +548,11 @@ Exiv2::BasicIo::AutoPtr
|
||||
ExtractorIO::temporary () const
|
||||
{
|
||||
fprintf (stderr, "throwing temporary error\n");
|
||||
+#if EXIV2_TEST_VERSION(0,27,0)
|
||||
+ throw Exiv2::BasicError<char> (Exiv2::kerDecodeLangAltQualifierFailed);
|
||||
+#else
|
||||
throw Exiv2::BasicError<char> (42 /* error code */);
|
||||
+#endif
|
||||
}
|
||||
|
||||
|
||||
@@ -697,7 +718,7 @@ EXTRACTOR_exiv2_extract_method (struct EXTRACTOR_ExtractContext *ec)
|
||||
{
|
||||
try
|
||||
{
|
||||
-#if EXIV2_MAKE_VERSION(0,23,0) <= EXIV2_VERSION
|
||||
+#if !EXIV2_TEST_VERSION(0,24,0)
|
||||
Exiv2::LogMsg::setLevel (Exiv2::LogMsg::mute);
|
||||
#endif
|
||||
std::auto_ptr<Exiv2::BasicIo> eio(new ExtractorIO (ec));
|
||||
--
|
||||
2.20.1
|
||||
|
Loading…
Reference in a new issue