extra/v4l-utils to 1.26.0-1

This commit is contained in:
David Beauchamp 2023-12-05 11:34:36 -05:00
parent 989540681d
commit 81b3f17ff8
3 changed files with 45 additions and 48 deletions

31
extra/v4l-utils/.SRCINFO Normal file
View file

@ -0,0 +1,31 @@
pkgbase = v4l-utils
pkgdesc = Userspace tools and conversion library for Video 4 Linux
pkgver = 1.26.0
pkgrel = 1
url = https://linuxtv.org/
arch = x86_64
license = LGPL
makedepends = qt5-base
makedepends = alsa-lib
makedepends = meson
makedepends = clang
makedepends = doxygen
makedepends = libbpf
depends = hicolor-icon-theme
depends = gcc-libs
depends = libjpeg-turbo
depends = systemd-libs
depends = json-c
optdepends = qt5-base: for qv4l2 and qvidcap
optdepends = alsa-lib: for qv4l2
provides = libv4l=1.26.0
conflicts = libv4l
replaces = libv4l
backup = etc/rc_maps.cfg
source = https://linuxtv.org/downloads/v4l-utils/v4l-utils-1.26.0.tar.xz
source = https://linuxtv.org/downloads/v4l-utils/v4l-utils-1.26.0.tar.xz.asc
validpgpkeys = 05D0169C26E41593418129DF199A64FADFB500FF
sha256sums = dab463dc0215e55b2ef1f7a7ab230c3ae8102ea029547eefb4478da0fa8af505
sha256sums = SKIP
pkgname = v4l-utils

View file

@ -1,36 +0,0 @@
From 02f295d4c4c1b401cdb589df5bef2645c7f83813 Mon Sep 17 00:00:00 2001
From: Hans Verkuil <hverkuil-cisco@xs4all.nl>
Date: Mon, 15 Mar 2021 08:13:14 +0100
Subject: [PATCH] v4l2-tpg.patch: rename min/max defines to tpg_min/max
With gcc 11 the min/max defines clash with what gcc provides,
so rename these defines. They are only used in the min3/max3
defines, so the change it kept to a minimum.
Signed-off-by: Hans Verkuil <hverkuil-cisco@xs4all.nl>
Reported-by: Gregor Jasny <gjasny@googlemail.com>
---
utils/common/v4l2-tpg.h | 10 ++++------
utils/common/v4l2-tpg.patch | 12 +++++-------
2 files changed, 9 insertions(+), 13 deletions(-)
diff --git a/utils/common/v4l2-tpg.h b/utils/common/v4l2-tpg.h
index caf7b1a1..ecdb6eba 100644
--- a/utils/common/v4l2-tpg.h
+++ b/utils/common/v4l2-tpg.h
@@ -28,12 +28,10 @@ typedef __s8 s8;
#define pr_info printf
#define noinline
-#ifndef min
-#define min(a,b) ((a) < (b) ? (a) : (b))
-#define max(a,b) ((a) > (b) ? (a) : (b))
-#endif /* !min */
-#define min3(x, y, z) min((typeof(x))min(x, y), z)
-#define max3(x, y, z) max((typeof(x))max(x, y), z)
+#define tpg_min(a,b) ((a) < (b) ? (a) : (b))
+#define tpg_max(a,b) ((a) > (b) ? (a) : (b))
+#define min3(x, y, z) tpg_min((typeof(x))tpg_min(x, y), z)
+#define max3(x, y, z) tpg_max((typeof(x))tpg_max(x, y), z)
#define array_size(a, b) ((a) * (b))
#define array3_size(a, b, c) ((a) * (b) * (c))

View file

@ -4,8 +4,8 @@
# - disable distcc - configure checks for clang first
pkgname=v4l-utils
pkgver=1.24.1
pkgrel=2
pkgver=1.26.0
pkgrel=1
pkgdesc="Userspace tools and conversion library for Video 4 Linux"
arch=('x86_64')
url="https://linuxtv.org/"
@ -16,22 +16,24 @@ backup=(etc/rc_maps.cfg)
license=('LGPL')
options=('!distcc')
depends=('hicolor-icon-theme' 'gcc-libs' 'libjpeg-turbo' 'systemd-libs' 'json-c')
makedepends=('qt5-base' 'alsa-lib')
makedepends=('qt5-base' 'alsa-lib' 'meson' 'clang' 'doxygen' 'libbpf')
optdepends=('qt5-base: for qv4l2 and qvidcap' 'alsa-lib: for qv4l2')
source=(https://linuxtv.org/downloads/v4l-utils/${pkgname}-${pkgver}.tar.bz2{,.asc})
sha256sums=('cbb7fe8a6307f5ce533a05cded70bb93c3ba06395ab9b6d007eb53b75d805f5b'
source=(https://linuxtv.org/downloads/v4l-utils/${pkgname}-${pkgver}.tar.xz{,.asc})
sha256sums=('dab463dc0215e55b2ef1f7a7ab230c3ae8102ea029547eefb4478da0fa8af505'
'SKIP')
validpgpkeys=('05D0169C26E41593418129DF199A64FADFB500FF') # Gregor Jasny <gjasny@googlemail.com>
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
prepare() {
# HACK: inform upstream to make this configurable
cd "${pkgname}-${pkgver}"
sed -i 's/sbin/bin/' utils/v4l2-dbg/meson.build
}
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin
make
build() {
arch-meson -Dgconv=disabled "${pkgname}-${pkgver}" build
meson compile -C build
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
MAKEFLAGS="-j1" make install DESTDIR="${pkgdir}/"
rm "${pkgdir}/usr/bin/ivtv-ctl"
meson install -C build --destdir "$pkgdir"
}