extra/libfbclient to 2.5.8.27089-1

This commit is contained in:
Kevin Mihelich 2018-06-13 12:44:43 +00:00
parent 29d153ba6a
commit 81c8e2a5b6
3 changed files with 5 additions and 57 deletions

View file

@ -6,29 +6,23 @@
# - patch to link with atomic_ops
pkgname=libfbclient
pkgver=2.5.7.27050
pkgrel=5
pkgdesc="Client library for Firebird."
pkgver=2.5.8.27089
pkgrel=1
pkgdesc="Client library for Firebird"
arch=('x86_64')
url="http://www.firebirdsql.org/"
license=('custom')
depends=('gcc-libs' 'icu')
options=('!makeflags')
source=(http://downloads.sourceforge.net/firebird/Firebird-$pkgver-0.tar.bz2
firebird-c++11.patch
firebird-c++14.patch
source=(https://github.com/FirebirdSQL/firebird/releases/download/R2_5_8/Firebird-$pkgver-0.tar.bz2
link_atomic_ops.patch
LICENSE)
md5sums=('fb34241e96f9707604bf6cd78357d5a2'
'5094347a8298143ca147edd49b552fe9'
'a02710203cee81b4f48b7bdca3b1b33f'
md5sums=('38862a3da39cf91f4f2366fb510f18a6'
'ca8e2c7a1fe0d3398f72d63a6c85422a'
'0d61798861e159c85dbdf0f30fe2f2ce')
prepare() {
cd $srcdir/Firebird-$pkgver-0
patch -Np1 -i ../firebird-c++11.patch
patch -Np0 -i ../firebird-c++14.patch
patch -p1 -i ../link_atomic_ops.patch
}

View file

@ -1,16 +0,0 @@
# -*- Mode: Diff -*-
--- firebird/src/dudley/exe.epp
+++ firebird/src/dudley/exe.epp
@@ -2884,9 +2884,9 @@
blr_parameter, 0, 0, 0,
blr_parameter, 0, 1, 0,
blr_parameter, 1, 0, 0,
- blr_end,
- blr_end,
- blr_end,
+ SCHAR(blr_end),
+ SCHAR(blr_end),
+ SCHAR(blr_end),
blr_eoc
};
static FB_API_HANDLE req_handle;

View file

@ -1,30 +0,0 @@
--- src/common/classes/alloc.cpp
+++ src/common/classes/alloc.cpp
@@ -2121,3 +2121,11 @@
{
Firebird::MemoryPool::globalFree(mem);
}
+void operator delete(void* mem, size_t) throw()
+{
+ Firebird::MemoryPool::globalFree(mem);
+}
+void operator delete[](void* mem, size_t) throw()
+{
+ Firebird::MemoryPool::globalFree(mem);
+}
--- src/common/classes/alloc.h
+++ src/common/classes/alloc.h
@@ -491,13 +491,6 @@
inline static MemoryPool* getDefaultMemoryPool() { return Firebird::MemoryPool::processMemoryPool; }
-// Global versions of operators new and delete
-void* operator new(size_t s) THROW_BAD_ALLOC;
-void* operator new[](size_t s) THROW_BAD_ALLOC;
-
-void operator delete(void* mem) throw();
-void operator delete[](void* mem) throw();
-
#ifdef DEBUG_GDS_ALLOC
inline void* operator new(size_t s, Firebird::MemoryPool& pool, const char* file, int line)
{