extra/chromium to 119.0.6045.199-1

This commit is contained in:
Kevin Mihelich 2023-12-01 19:43:03 +00:00
parent e3e75877f2
commit 81e13bb58a
3 changed files with 52 additions and 5 deletions

View file

@ -1,6 +1,6 @@
pkgbase = chromium
pkgdesc = A web browser built for speed, simplicity, and security
pkgver = 119.0.6045.159
pkgver = 119.0.6045.199
pkgrel = 1
url = https://www.chromium.org/Home
arch = x86_64
@ -57,14 +57,16 @@ pkgbase = chromium
optdepends = org.freedesktop.secrets: password storage backend on GNOME / Xfce
optdepends = kwallet: support for storing passwords in KWallet on Plasma
options = !lto
source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-119.0.6045.159.tar.xz
source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-119.0.6045.199.tar.xz
source = https://github.com/foutrelis/chromium-launcher/archive/v8/chromium-launcher-8.tar.gz
source = https://gitlab.com/Matt.Jolly/chromium-patches/-/archive/119/chromium-patches-119.tar.bz2
source = libxml2-2.12.patch
source = REVERT-disable-autoupgrading-debug-info.patch
source = use-oauth2-client-switches-as-default.patch
sha256sums = d0d842712805ac81582dc0fecd4396fbf4380713df2fb50ceeb853dd38d1538f
sha256sums = b1ae62beb7907d99802b74821d5198bd54a7456df1116d317da653bde8ce6388
sha256sums = 213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a
sha256sums = 09ecf142254525ddb9c2dbbb2c71775e68722412923a5a9bba5cc2e46af8d087
sha256sums = 1808df5ba4d1e2f9efa07ac6b510bec866fa6d60e44505d82aea3f6072105a71
sha256sums = 1b782b0f6d4f645e4e0daa8a4852d63f0c972aa0473319216ff04613a0592a69
sha256sums = e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711

View file

@ -15,7 +15,7 @@
highmem=1
pkgname=chromium
pkgver=119.0.6045.159
pkgver=119.0.6045.199
pkgrel=1
_launcher_ver=8
_manual_clone=0
@ -38,14 +38,16 @@ options=('!lto') # Chromium adds its own flags for ThinLTO
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://gitlab.com/Matt.Jolly/chromium-patches/-/archive/${pkgver%%.*}/chromium-patches-${pkgver%%.*}.tar.bz2
libxml2-2.12.patch
REVERT-disable-autoupgrading-debug-info.patch
use-oauth2-client-switches-as-default.patch
0001-widevine-support-for-arm.patch
0002-Run-blink-bindings-generation-single-threaded.patch
0003-Fix-eu-strip-build-for-newer-GCC.patch)
sha256sums=('d0d842712805ac81582dc0fecd4396fbf4380713df2fb50ceeb853dd38d1538f'
sha256sums=('b1ae62beb7907d99802b74821d5198bd54a7456df1116d317da653bde8ce6388'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'09ecf142254525ddb9c2dbbb2c71775e68722412923a5a9bba5cc2e46af8d087'
'1808df5ba4d1e2f9efa07ac6b510bec866fa6d60e44505d82aea3f6072105a71'
'1b782b0f6d4f645e4e0daa8a4852d63f0c972aa0473319216ff04613a0592a69'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711'
'b5bb3d0e2cd06aa92bb0ea62d6915dac1635cee79e9e1405cf17fe471baa393e'
@ -134,6 +136,7 @@ prepare() {
patch -Np1 -i ../use-oauth2-client-switches-as-default.patch
# Upstream fixes
patch -Np1 -i ../libxml2-2.12.patch
# Revert addition of compiler flag that needs newer clang
patch -Rp1 -i ../REVERT-disable-autoupgrading-debug-info.patch

View file

@ -0,0 +1,42 @@
From 871f8ae9b65ce2679b0bc0be36902d65edf0c1e4 Mon Sep 17 00:00:00 2001
From: Joey Arhar <jarhar@chromium.org>
Date: Thu, 2 Nov 2023 20:45:11 +0000
Subject: [PATCH] Roll libxml from b8961a75 to 7a2d412f
Bug: 934413
Change-Id: I6fb176d76dba9a9adf411395fa5f6b950b52920a
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/4985186
Reviewed-by: David Baron <dbaron@chromium.org>
Commit-Queue: Joey Arhar <jarhar@chromium.org>
Cr-Commit-Position: refs/heads/main@{#1219084}
---
third_party/blink/renderer/core/xml/xslt_processor.h | 2 +-
third_party/blink/renderer/core/xml/xslt_processor_libxslt.cc | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/third_party/blink/renderer/core/xml/xslt_processor.h b/third_party/blink/renderer/core/xml/xslt_processor.h
index d53835e9675..2eaea31ed29 100644
--- a/third_party/blink/renderer/core/xml/xslt_processor.h
+++ b/third_party/blink/renderer/core/xml/xslt_processor.h
@@ -77,7 +77,7 @@ class XSLTProcessor final : public ScriptWrappable {
void reset();
- static void ParseErrorFunc(void* user_data, xmlError*);
+ static void ParseErrorFunc(void* user_data, const xmlError*);
static void GenericErrorFunc(void* user_data, const char* msg, ...);
// Only for libXSLT callbacks
diff --git a/third_party/blink/renderer/core/xml/xslt_processor_libxslt.cc b/third_party/blink/renderer/core/xml/xslt_processor_libxslt.cc
index 133e0b3355d..f424077089d 100644
--- a/third_party/blink/renderer/core/xml/xslt_processor_libxslt.cc
+++ b/third_party/blink/renderer/core/xml/xslt_processor_libxslt.cc
@@ -66,7 +66,7 @@ void XSLTProcessor::GenericErrorFunc(void*, const char*, ...) {
// It would be nice to do something with this error message.
}
-void XSLTProcessor::ParseErrorFunc(void* user_data, xmlError* error) {
+void XSLTProcessor::ParseErrorFunc(void* user_data, const xmlError* error) {
FrameConsole* console = static_cast<FrameConsole*>(user_data);
if (!console)
return;