mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/openal to 1.19.0-1
This commit is contained in:
parent
ae6d339002
commit
82176bd474
2 changed files with 13 additions and 17 deletions
|
@ -1,4 +1,3 @@
|
|||
# $Id$
|
||||
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
|
||||
# Contributor: Allan McRae <allan@archlinux.org>
|
||||
# Contributor: Jason Chu <jchu@xentac.net>
|
||||
|
@ -9,8 +8,8 @@
|
|||
|
||||
pkgbase=openal
|
||||
pkgname=(openal openal-examples)
|
||||
pkgver=1.18.2
|
||||
pkgrel=2
|
||||
pkgver=1.19.0
|
||||
pkgrel=1
|
||||
pkgdesc="Cross-platform 3D audio library, software implementation"
|
||||
arch=(i686 x86_64)
|
||||
url="https://github.com/kcat/openal-soft"
|
||||
|
@ -18,28 +17,25 @@ license=(LGPL)
|
|||
depends=(glibc)
|
||||
makedepends=(alsa-lib libpulse fluidsynth portaudio jack qt5-base sdl2 sdl_sound ffmpeg
|
||||
git cmake ninja)
|
||||
_commit=ce6076091bac3c00cd10803916e8911495580bd0 # tags/openal-soft-1.18.2
|
||||
_commit=96aacac10ca852fc30fd7f72f3e3c6ddbe02858c # tags/openal-soft-1.19.0
|
||||
source=("git+https://github.com/kcat/openal-soft#commit=$_commit"
|
||||
'no-fpuextended.patch'
|
||||
'openal-soft-arm_neon-only-for-32bit.patch')
|
||||
sha512sums=('SKIP'
|
||||
'e782025501a62003ee7e63dcdb50343add8b1241b2efd606cc9a7f61a01d4625c777a647d7647b0b19798f247efca213bce3b3f40e22c8903355f7058e3d2011'
|
||||
'55e1b6f9b0fd11ac85d1a01dd6353e3ef6875f3f2485147728d577f1066aa1c425eb0fffed603df10ccd7d6bf94e99d911fadbc8881a39674a9830c01fb41635')
|
||||
'e2bdf53d9bb154be83db134ad256333dcbb25715946e4f4098808200a3ff250d2ff492008ec64ddc2b0b67c84fca1392f568a455c819c487c7efc92793ede98a')
|
||||
|
||||
pkgver() {
|
||||
cd openal-soft
|
||||
git describe --tags | sed 's/^openal-soft-//;s/-/+/g'
|
||||
}
|
||||
|
||||
# https://bugs.archlinux.org/task/54908
|
||||
git cherry-pick -n d4f3490a880f779f460332689a396ade69840f50
|
||||
|
||||
prepare() {
|
||||
mkdir build examples
|
||||
cd openal-soft
|
||||
|
||||
patch -p1 -i "${srcdir}"/no-fpuextended.patch
|
||||
patch -p1 -i "${srcdir}"/openal-soft-arm_neon-only-for-32bit.patch
|
||||
patch -p0 -i "${srcdir}"/openal-soft-arm_neon-only-for-32bit.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -59,7 +55,9 @@ package_openal() {
|
|||
install -Dt "$pkgdir/usr/share/doc/openal" -m644 openal-soft/docs/*
|
||||
|
||||
### Split openal-examples
|
||||
mv -v "$pkgdir"/usr/bin/al{ffplay,hrtf,latency,loopback,reverb,stream} examples/
|
||||
cd "$pkgdir/usr/bin"
|
||||
mv -vt "$srcdir/examples" alffplay alhrtf allatency alloopback almultireverb \
|
||||
alplay alrecord alreverb alstream altonegen
|
||||
}
|
||||
|
||||
package_openal-examples() {
|
||||
|
|
|
@ -1,11 +1,9 @@
|
|||
Index: openal-soft-1.16.0/CMakeLists.txt
|
||||
===================================================================
|
||||
--- openal-soft-1.16.0.orig/CMakeLists.txt
|
||||
+++ openal-soft-1.16.0/CMakeLists.txt
|
||||
@@ -679,7 +679,7 @@ ENDIF()
|
||||
--- CMakeLists.txt.orig 2018-09-11 07:50:54.763206560 -0600
|
||||
+++ CMakeLists.txt 2018-09-11 07:51:56.040874745 -0600
|
||||
@@ -945,7 +945,7 @@
|
||||
# Check for ARM Neon support
|
||||
OPTION(ALSOFT_REQUIRE_NEON "Require ARM Neon support" OFF)
|
||||
CHECK_INCLUDE_FILE(arm_neon.h HAVE_ARM_NEON_H)
|
||||
CHECK_INCLUDE_FILE(arm_neon.h HAVE_ARM_NEON_H ${FPU_NEON_SWITCH})
|
||||
-IF(HAVE_ARM_NEON_H)
|
||||
+IF(HAVE_ARM_NEON_H AND CMAKE_SIZEOF_VOID_P EQUAL 4) # only 32-bit ARM
|
||||
OPTION(ALSOFT_CPUEXT_NEON "Enable ARM Neon support" ON)
|
||||
|
|
Loading…
Reference in a new issue