extra/chromium to 95.0.4638.69-2

This commit is contained in:
Kevin Mihelich 2021-11-02 12:59:56 +00:00
parent e0be4d3669
commit 824a49da2b
2 changed files with 44 additions and 1 deletions

View file

@ -18,7 +18,7 @@ highmem=1
pkgname=chromium
pkgver=95.0.4638.69
pkgrel=1
pkgrel=2
_launcher_ver=8
_gcc_patchset=4
pkgdesc="A web browser built for speed, simplicity, and security"
@ -40,6 +40,7 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
maldoca-depend-on-zlib-instead-of-headers-only.patch
ozone-x11-fix-VA-API.patch
chromium-95-harfbuzz-3.patch
xfce-set-zero-insets-on-maximising-the-window.patch
replace-blacklist-with-ignorelist.patch
add-a-TODO-about-a-missing-pnacl-flag.patch
use-ffile-compilation-dir.patch
@ -58,6 +59,7 @@ sha256sums=('38a37d737c6c9a7198402ca614746b2dbb7abbb793bb2cb02dc796b62a22efe7'
'074b32078b9e53fd9b33709ce5785c120eb0346b015a93921897caed4f95f7b6'
'3af6dfe5c4e6ed1be52a292c30bc0c447cc8498bb108f7973adb438239961474'
'd9002f1e33390c3e770637773c81be6731584b18f68f086e955bcc3f66f4510d'
'3e45d88b805e61e990439820fbda802cf095972661e9944c5cd487c61d708f51'
'd3344ba39b8c6ed202334ba7f441c70d81ddf8cdb15af1aa8c16e9a3a75fbb35'
'd53da216538f2e741a6e048ed103964a91a98e9a3c10c27fdfa34d4692fdc455'
'921010cd8fab5f30be76c68b68c9b39fac9e21f4c4133bb709879592bbdf606e'
@ -157,6 +159,7 @@ prepare() {
patch -Np1 -i ../maldoca-depend-on-zlib-instead-of-headers-only.patch
patch -Np1 -i ../ozone-x11-fix-VA-API.patch
patch -Np1 -i ../chromium-95-harfbuzz-3.patch
patch -Np1 -i ../xfce-set-zero-insets-on-maximising-the-window.patch
# Revert transition to -fsanitize-ignorelist (needs newer clang)
patch -Rp1 -i ../replace-blacklist-with-ignorelist.patch

View file

@ -0,0 +1,40 @@
From 24a90f9327ac1a4d2b6dbb410cd28f65e3e33839 Mon Sep 17 00:00:00 2001
From: Alexander Dunaev <adunaev@igalia.com>
Date: Mon, 1 Nov 2021 19:29:27 +0000
Subject: [PATCH] [linux/xfce] Set zero insets on maximising the window.
It turned out that Xfwm handles the frame insets not the way KWin and
Mutter do, which causes wrong window size when it is maximised (see the
linked crbug).
This patch resets the frame insets to zero when the window is maximised,
which fixes the behaviour on Xfwm.
Bug: 1260821
Change-Id: I69e71049157c03b74d78bc5edb7a60bf39cdda8b
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3250747
Commit-Queue: Thomas Anderson <thomasanderson@chromium.org>
Reviewed-by: Thomas Anderson <thomasanderson@chromium.org>
Cr-Commit-Position: refs/heads/main@{#936990}
---
ui/platform_window/x11/x11_window.cc | 7 +++++++
1 file changed, 7 insertions(+)
diff --git a/ui/platform_window/x11/x11_window.cc b/ui/platform_window/x11/x11_window.cc
index 017ff15a0a..dd416c031e 100644
--- a/ui/platform_window/x11/x11_window.cc
+++ b/ui/platform_window/x11/x11_window.cc
@@ -675,6 +675,13 @@ void X11Window::Maximize() {
// save this one for later too.
should_maximize_after_map_ = !window_mapped_in_client_;
+ // Some WMs keep respecting the frame extents even if the window is maximised.
+ // Remove the insets when maximising. The extents will be set again when the
+ // window is restored to normal state.
+ // See https://crbug.com/1260821
+ if (CanSetDecorationInsets())
+ SetDecorationInsets(nullptr);
+
SetWMSpecState(true, x11::GetAtom("_NET_WM_STATE_MAXIMIZED_VERT"),
x11::GetAtom("_NET_WM_STATE_MAXIMIZED_HORZ"));
}