mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/gnuradio to 3.9.3.0-1
This commit is contained in:
parent
8dfea8e061
commit
8298f5fc30
2 changed files with 298 additions and 3 deletions
|
@ -8,8 +8,8 @@
|
|||
|
||||
pkgbase=gnuradio
|
||||
pkgname=(gnuradio gnuradio-companion)
|
||||
pkgver=3.9.2.0
|
||||
pkgrel=3
|
||||
pkgver=3.9.3.0
|
||||
pkgrel=1
|
||||
pkgdesc="General purpose DSP and SDR toolkit. With drivers for usrp and fcd."
|
||||
arch=('x86_64')
|
||||
url="https://gnuradio.org"
|
||||
|
@ -44,16 +44,19 @@ source=("gnuradio-$pkgver.tgz::https://github.com/gnuradio/gnuradio/archive/refs
|
|||
#"https://github.com/gnuradio/gnuradio/releases/download/v$pkgver/gnuradio-$pkgver.tar.gz"
|
||||
# "https://github.com/gnuradio/gnuradio/releases/download/v$pkgver/gnuradio-$pkgver.tar.gz.asc"
|
||||
gnuradio-bind-placeholders.patch
|
||||
gnuradio-qwt-6.2.patch
|
||||
"21-fcd.rules")
|
||||
validpgpkeys=('B90DDFAC56989BF62262EB812987C77CBB8ED9B2' # GNU Radio Project
|
||||
'D74F9F146E7F755783583158B343B2BA293E5174') # Marcus Müller
|
||||
sha512sums=('4a2807d6713fff10906354553ef5810b81ef4116573fdf15b122e8fc18373c56e1685b8592a8f0f08c0524c4983f3d7d4774bdada98dff0990d028f71cbd7898'
|
||||
sha512sums=('c82043ddca97654630cf815007c5f263f99588ccdd9298d011634159850eb604b16fe4c72aa06a6eea67c3af57e2960fe5d17d57313ed0cbe2cec26ada16a5c7'
|
||||
'f4e52e6e9ef6054f358d3ee00cbcb70bab65c36dfac8975c3182f6514c547905f36801a049f0918d69c9ffd98ce801891a3bfc4e4faeb8fb33582d84140a70b7'
|
||||
'e169f3ac23930d4d42dabb96c3142dc254e7eb453e3e4bd3a96acdbccb1952e232447801e13eedad46874995a8f3c7ac1dc5abe79571b81f0715b70b593dbb98'
|
||||
'6f02dc8e20a7a1cd11099c851a7c8427fcd21e9652e6cddd0a72ca747b0e93cd4fd1b7b7b7e426b6231348bcc34fb2417716a2f03c92ec141889edc65031c3a0')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/$pkgbase-$pkgver"
|
||||
#patch -Np1 -i ../gnuradio-bind-placeholders.patch
|
||||
patch -p1 -i ../gnuradio-qwt-6.2.patch # Fix build with qwt 6.2
|
||||
sed -i -e "s|GR_PKG_LIBEXEC_DIR|GR_RUNTIME_DIR|" grc/scripts/freedesktop/CMakeLists.txt
|
||||
#sed -i -e "s|/qwt$|/qwt5|" -e "s| qwt | qwt5 |" cmake/Modules/FindQwt.cmake
|
||||
#sed -i -e "s| sphinx-build$| sphinx-build2|" cmake/Modules/FindSphinx.cmake
|
||||
|
|
292
community/gnuradio/gnuradio-qwt-6.2.patch
Normal file
292
community/gnuradio/gnuradio-qwt-6.2.patch
Normal file
|
@ -0,0 +1,292 @@
|
|||
From e00ff78c9c2278cdf41e7197389cec707a30c672 Mon Sep 17 00:00:00 2001
|
||||
From: Bill Muzika <bill.muzika@outlook.com>
|
||||
Date: Fri, 3 Sep 2021 00:40:22 -0400
|
||||
Subject: [PATCH] qt-gui: enables use of Qwt 6.2
|
||||
|
||||
Adds the typedefs and includes needed to build with Qwt 6.2.
|
||||
|
||||
Signed-off-by: Bill Muzika <bill.muzika@outlook.com>
|
||||
---
|
||||
gr-qtgui/include/gnuradio/qtgui/DisplayPlot.h | 5 ++++-
|
||||
gr-qtgui/include/gnuradio/qtgui/TimeRasterDisplayPlot.h | 4 +++-
|
||||
gr-qtgui/include/gnuradio/qtgui/WaterfallDisplayPlot.h | 4 +++-
|
||||
gr-qtgui/include/gnuradio/qtgui/plot_raster.h | 6 ++++--
|
||||
gr-qtgui/include/gnuradio/qtgui/plot_waterfall.h | 6 ++++--
|
||||
gr-qtgui/include/gnuradio/qtgui/qtgui_types.h | 1 +
|
||||
gr-qtgui/include/gnuradio/qtgui/timeRasterGlobalData.h | 9 +++++++--
|
||||
gr-qtgui/include/gnuradio/qtgui/waterfallGlobalData.h | 9 +++++++--
|
||||
gr-qtgui/lib/ConstellationDisplayPlot.cc | 1 +
|
||||
gr-qtgui/lib/plot_raster.cc | 9 +++++++++
|
||||
gr-qtgui/lib/plot_waterfall.cc | 9 +++++++++
|
||||
gr-qtgui/lib/timeRasterGlobalData.cc | 7 +++++++
|
||||
gr-qtgui/lib/waterfallGlobalData.cc | 6 ++++++
|
||||
13 files changed, 65 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/gr-qtgui/include/gnuradio/qtgui/DisplayPlot.h b/gr-qtgui/include/gnuradio/qtgui/DisplayPlot.h
|
||||
index 04de962fa3d..4e8afa26794 100644
|
||||
--- a/gr-qtgui/include/gnuradio/qtgui/DisplayPlot.h
|
||||
+++ b/gr-qtgui/include/gnuradio/qtgui/DisplayPlot.h
|
||||
@@ -29,7 +29,10 @@
|
||||
#include <vector>
|
||||
|
||||
#if QWT_VERSION >= 0x060000
|
||||
-#include <qwt_compat.h>
|
||||
+typedef QPointF QwtDoublePoint;
|
||||
+typedef QRectF QwtDoubleRect;
|
||||
+
|
||||
+typedef QwtInterval QwtDoubleInterval;
|
||||
#endif
|
||||
|
||||
typedef QList<QColor> QColorList;
|
||||
diff --git a/gr-qtgui/include/gnuradio/qtgui/TimeRasterDisplayPlot.h b/gr-qtgui/include/gnuradio/qtgui/TimeRasterDisplayPlot.h
|
||||
index 170b62cafbf..09bad218bee 100644
|
||||
--- a/gr-qtgui/include/gnuradio/qtgui/TimeRasterDisplayPlot.h
|
||||
+++ b/gr-qtgui/include/gnuradio/qtgui/TimeRasterDisplayPlot.h
|
||||
@@ -23,7 +23,9 @@
|
||||
#if QWT_VERSION < 0x060000
|
||||
#include <gnuradio/qtgui/plot_waterfall.h>
|
||||
#else
|
||||
-#include <qwt_compat.h>
|
||||
+#include <qwt_interval.h>
|
||||
+
|
||||
+typedef QwtInterval QwtDoubleInterval;
|
||||
#endif
|
||||
|
||||
/*!
|
||||
diff --git a/gr-qtgui/include/gnuradio/qtgui/WaterfallDisplayPlot.h b/gr-qtgui/include/gnuradio/qtgui/WaterfallDisplayPlot.h
|
||||
index ed2196b63ef..afe7a6a6774 100644
|
||||
--- a/gr-qtgui/include/gnuradio/qtgui/WaterfallDisplayPlot.h
|
||||
+++ b/gr-qtgui/include/gnuradio/qtgui/WaterfallDisplayPlot.h
|
||||
@@ -22,7 +22,9 @@
|
||||
#if QWT_VERSION < 0x060000
|
||||
#include <gnuradio/qtgui/plot_waterfall.h>
|
||||
#else
|
||||
-#include <qwt_compat.h>
|
||||
+#include <qwt_interval.h>
|
||||
+
|
||||
+typedef QwtInterval QwtDoubleInterval;
|
||||
#endif
|
||||
|
||||
/*!
|
||||
diff --git a/gr-qtgui/include/gnuradio/qtgui/plot_raster.h b/gr-qtgui/include/gnuradio/qtgui/plot_raster.h
|
||||
index dc7ee543872..4b4c4f2afb2 100644
|
||||
--- a/gr-qtgui/include/gnuradio/qtgui/plot_raster.h
|
||||
+++ b/gr-qtgui/include/gnuradio/qtgui/plot_raster.h
|
||||
@@ -16,8 +16,10 @@
|
||||
#include <qwt_plot_rasteritem.h>
|
||||
|
||||
#if QWT_VERSION >= 0x060000
|
||||
-#include <qwt_compat.h>
|
||||
-#include <qwt_point_3d.h> // doesn't seem necessary, but is...
|
||||
+#include <qsize.h>
|
||||
+#include <qwt_interval.h>
|
||||
+
|
||||
+typedef QwtInterval QwtDoubleInterval;
|
||||
#endif
|
||||
|
||||
class QwtColorMap;
|
||||
diff --git a/gr-qtgui/include/gnuradio/qtgui/plot_waterfall.h b/gr-qtgui/include/gnuradio/qtgui/plot_waterfall.h
|
||||
index c3dba76bb95..f40446e25ca 100644
|
||||
--- a/gr-qtgui/include/gnuradio/qtgui/plot_waterfall.h
|
||||
+++ b/gr-qtgui/include/gnuradio/qtgui/plot_waterfall.h
|
||||
@@ -16,8 +16,10 @@
|
||||
#include <qwt_plot_rasteritem.h>
|
||||
|
||||
#if QWT_VERSION >= 0x060000
|
||||
-#include <qwt_compat.h>
|
||||
-#include <qwt_point_3d.h> // doesn't seem necessary, but is...
|
||||
+#include <qsize.h>
|
||||
+#include <qwt_interval.h>
|
||||
+
|
||||
+typedef QwtInterval QwtDoubleInterval;
|
||||
#endif
|
||||
|
||||
class QwtColorMap;
|
||||
diff --git a/gr-qtgui/include/gnuradio/qtgui/qtgui_types.h b/gr-qtgui/include/gnuradio/qtgui/qtgui_types.h
|
||||
index e2735cf945d..670876afc7c 100644
|
||||
--- a/gr-qtgui/include/gnuradio/qtgui/qtgui_types.h
|
||||
+++ b/gr-qtgui/include/gnuradio/qtgui/qtgui_types.h
|
||||
@@ -14,6 +14,7 @@
|
||||
#include <gnuradio/high_res_timer.h>
|
||||
#include <qwt_color_map.h>
|
||||
#include <qwt_scale_draw.h>
|
||||
+#include <qwt_text.h>
|
||||
|
||||
namespace gr {
|
||||
namespace qtgui {
|
||||
diff --git a/gr-qtgui/include/gnuradio/qtgui/timeRasterGlobalData.h b/gr-qtgui/include/gnuradio/qtgui/timeRasterGlobalData.h
|
||||
index 09cd42883cd..5c743f4cad5 100644
|
||||
--- a/gr-qtgui/include/gnuradio/qtgui/timeRasterGlobalData.h
|
||||
+++ b/gr-qtgui/include/gnuradio/qtgui/timeRasterGlobalData.h
|
||||
@@ -15,8 +15,9 @@
|
||||
#include <cinttypes>
|
||||
|
||||
#if QWT_VERSION >= 0x060000
|
||||
-#include <qwt_compat.h>
|
||||
-#include <qwt_point_3d.h> // doesn't seem necessary, but is...
|
||||
+#include <qwt_interval.h>
|
||||
+
|
||||
+typedef QwtInterval QwtDoubleInterval;
|
||||
#endif
|
||||
|
||||
class TimeRasterData : public QwtRasterData
|
||||
@@ -35,6 +36,9 @@ class TimeRasterData : public QwtRasterData
|
||||
#if QWT_VERSION < 0x060000
|
||||
virtual QwtDoubleInterval range() const;
|
||||
virtual void setRange(const QwtDoubleInterval&);
|
||||
+#else
|
||||
+ virtual QwtInterval interval(Qt::Axis) const;
|
||||
+ void setInterval(Qt::Axis, const QwtInterval&);
|
||||
#endif
|
||||
|
||||
double value(double x, double y) const override;
|
||||
@@ -56,6 +60,7 @@ class TimeRasterData : public QwtRasterData
|
||||
QwtDoubleInterval d_intensityRange;
|
||||
#else
|
||||
QwtInterval d_intensityRange;
|
||||
+ QwtInterval d_intervals[3];
|
||||
#endif
|
||||
|
||||
private:
|
||||
diff --git a/gr-qtgui/include/gnuradio/qtgui/waterfallGlobalData.h b/gr-qtgui/include/gnuradio/qtgui/waterfallGlobalData.h
|
||||
index 03d9d13dc6a..9895e658c62 100644
|
||||
--- a/gr-qtgui/include/gnuradio/qtgui/waterfallGlobalData.h
|
||||
+++ b/gr-qtgui/include/gnuradio/qtgui/waterfallGlobalData.h
|
||||
@@ -15,8 +15,9 @@
|
||||
#include <cinttypes>
|
||||
|
||||
#if QWT_VERSION >= 0x060000
|
||||
-#include <qwt_compat.h>
|
||||
-#include <qwt_point_3d.h> // doesn't seem necessary, but is...
|
||||
+#include <qwt_interval.h>
|
||||
+
|
||||
+typedef QwtInterval QwtDoubleInterval;
|
||||
#endif
|
||||
|
||||
class WaterfallData : public QwtRasterData
|
||||
@@ -36,6 +37,9 @@ class WaterfallData : public QwtRasterData
|
||||
#if QWT_VERSION < 0x060000
|
||||
virtual QwtDoubleInterval range() const;
|
||||
virtual void setRange(const QwtDoubleInterval&);
|
||||
+#else
|
||||
+ virtual QwtInterval interval(Qt::Axis) const;
|
||||
+ void setInterval(Qt::Axis, const QwtInterval&);
|
||||
#endif
|
||||
|
||||
double value(double x, double y) const override;
|
||||
@@ -60,6 +64,7 @@ class WaterfallData : public QwtRasterData
|
||||
QwtDoubleInterval _intensityRange;
|
||||
#else
|
||||
QwtInterval _intensityRange;
|
||||
+ QwtInterval d_intervals[3];
|
||||
#endif
|
||||
|
||||
private:
|
||||
diff --git a/gr-qtgui/lib/ConstellationDisplayPlot.cc b/gr-qtgui/lib/ConstellationDisplayPlot.cc
|
||||
index ffd3ecf5943..4283fad40f9 100644
|
||||
--- a/gr-qtgui/lib/ConstellationDisplayPlot.cc
|
||||
+++ b/gr-qtgui/lib/ConstellationDisplayPlot.cc
|
||||
@@ -16,6 +16,7 @@
|
||||
#include <qwt_legend.h>
|
||||
#include <qwt_scale_draw.h>
|
||||
#include <QColor>
|
||||
+#include <cmath>
|
||||
|
||||
class ConstellationDisplayZoomer : public QwtPlotZoomer
|
||||
{
|
||||
diff --git a/gr-qtgui/lib/plot_raster.cc b/gr-qtgui/lib/plot_raster.cc
|
||||
index 7bb439881a4..d79def0f44a 100644
|
||||
--- a/gr-qtgui/lib/plot_raster.cc
|
||||
+++ b/gr-qtgui/lib/plot_raster.cc
|
||||
@@ -244,7 +244,11 @@ QImage PlotTimeRaster::renderImage(const QwtScaleMap& xMap,
|
||||
}
|
||||
d_data->data->incrementResidual();
|
||||
} else if (d_data->colorMap->format() == QwtColorMap::Indexed) {
|
||||
+#if QWT_VERSION >= 0x060200
|
||||
+ image.setColorTable(d_data->colorMap->colorTable(256));
|
||||
+#else
|
||||
image.setColorTable(d_data->colorMap->colorTable(intensityRange));
|
||||
+#endif
|
||||
|
||||
for (int y = rect.top(); y <= rect.bottom(); y++) {
|
||||
const double ty = yyMap.invTransform(y);
|
||||
@@ -253,8 +257,13 @@ QImage PlotTimeRaster::renderImage(const QwtScaleMap& xMap,
|
||||
for (int x = rect.left(); x <= rect.right(); x++) {
|
||||
const double tx = xxMap.invTransform(x);
|
||||
|
||||
+#if QWT_VERSION >= 0x060200
|
||||
+ *line++ = d_data->colorMap->colorIndex(
|
||||
+ 256, intensityRange, d_data->data->value(tx, ty));
|
||||
+#else
|
||||
*line++ = d_data->colorMap->colorIndex(intensityRange,
|
||||
d_data->data->value(tx, ty));
|
||||
+#endif
|
||||
}
|
||||
}
|
||||
}
|
||||
diff --git a/gr-qtgui/lib/plot_waterfall.cc b/gr-qtgui/lib/plot_waterfall.cc
|
||||
index ff47ea20032..94c44051d6d 100644
|
||||
--- a/gr-qtgui/lib/plot_waterfall.cc
|
||||
+++ b/gr-qtgui/lib/plot_waterfall.cc
|
||||
@@ -240,7 +240,11 @@ QImage PlotWaterfall::renderImage(const QwtScaleMap& xMap,
|
||||
}
|
||||
}
|
||||
} else if (d_data->colorMap->format() == QwtColorMap::Indexed) {
|
||||
+#if QWT_VERSION >= 0x060200
|
||||
+ image.setColorTable(d_data->colorMap->colorTable(256));
|
||||
+#else
|
||||
image.setColorTable(d_data->colorMap->colorTable(intensityRange));
|
||||
+#endif
|
||||
|
||||
for (int y = rect.top(); y <= rect.bottom(); y++) {
|
||||
const double ty = yyMap.invTransform(y);
|
||||
@@ -249,8 +253,13 @@ QImage PlotWaterfall::renderImage(const QwtScaleMap& xMap,
|
||||
for (int x = rect.left(); x <= rect.right(); x++) {
|
||||
const double tx = xxMap.invTransform(x);
|
||||
|
||||
+#if QWT_VERSION >= 0x060200
|
||||
+ *line++ = d_data->colorMap->colorIndex(
|
||||
+ 256, intensityRange, d_data->data->value(tx, ty));
|
||||
+#else
|
||||
*line++ = d_data->colorMap->colorIndex(intensityRange,
|
||||
d_data->data->value(tx, ty));
|
||||
+#endif
|
||||
}
|
||||
}
|
||||
}
|
||||
diff --git a/gr-qtgui/lib/timeRasterGlobalData.cc b/gr-qtgui/lib/timeRasterGlobalData.cc
|
||||
index 1b9e7a0332d..4ec028ffb3a 100644
|
||||
--- a/gr-qtgui/lib/timeRasterGlobalData.cc
|
||||
+++ b/gr-qtgui/lib/timeRasterGlobalData.cc
|
||||
@@ -132,6 +132,13 @@ void TimeRasterData::setRange(const QwtDoubleInterval& newRange)
|
||||
{
|
||||
d_intensityRange = newRange;
|
||||
}
|
||||
+#else
|
||||
+void TimeRasterData::setInterval(Qt::Axis axis, const QwtInterval& interval)
|
||||
+{
|
||||
+ d_intervals[axis] = interval;
|
||||
+}
|
||||
+
|
||||
+QwtInterval TimeRasterData::interval(Qt::Axis a) const { return d_intervals[a]; }
|
||||
|
||||
#endif
|
||||
|
||||
diff --git a/gr-qtgui/lib/waterfallGlobalData.cc b/gr-qtgui/lib/waterfallGlobalData.cc
|
||||
index 4c703310475..38c955f2ee7 100644
|
||||
--- a/gr-qtgui/lib/waterfallGlobalData.cc
|
||||
+++ b/gr-qtgui/lib/waterfallGlobalData.cc
|
||||
@@ -139,7 +139,13 @@ void WaterfallData::setRange(const QwtDoubleInterval& newRange)
|
||||
{
|
||||
_intensityRange = newRange;
|
||||
}
|
||||
+#else
|
||||
+void WaterfallData::setInterval(Qt::Axis axis, const QwtInterval& interval)
|
||||
+{
|
||||
+ d_intervals[axis] = interval;
|
||||
+}
|
||||
|
||||
+QwtInterval WaterfallData::interval(Qt::Axis a) const { return d_intervals[a]; }
|
||||
#endif
|
||||
|
||||
|
Loading…
Reference in a new issue