mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/claws-mail to 3.7.10-2
This commit is contained in:
parent
23f8781c2f
commit
82c9252b1b
2 changed files with 22 additions and 5 deletions
|
@ -1,14 +1,14 @@
|
||||||
# $Id: PKGBUILD 136386 2011-08-28 17:30:30Z andyrtr $
|
# $Id: PKGBUILD 144878 2011-12-08 21:06:16Z andyrtr $
|
||||||
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
|
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@plugapps.com>
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
# - removed valgrind from makedepends
|
# - removed valgrind from makedepends
|
||||||
|
|
||||||
plugrel=1
|
plugrel=1
|
||||||
|
|
||||||
pkgname=claws-mail
|
pkgname=claws-mail
|
||||||
pkgver=3.7.10
|
pkgver=3.7.10
|
||||||
pkgrel=1
|
pkgrel=2
|
||||||
pkgdesc="A GTK+ based e-mail client."
|
pkgdesc="A GTK+ based e-mail client."
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
license=('GPL3')
|
license=('GPL3')
|
||||||
|
@ -24,12 +24,17 @@ replaces=('sylpheed-claws')
|
||||||
provides=('claws')
|
provides=('claws')
|
||||||
options=(!libtool)
|
options=(!libtool)
|
||||||
install=claws-mail.install
|
install=claws-mail.install
|
||||||
source=(http://downloads.sourceforge.net/sourceforge/sylpheed-claws/${pkgname}-${pkgver}.tar.bz2)
|
source=(http://downloads.sourceforge.net/sourceforge/sylpheed-claws/${pkgname}-${pkgver}.tar.bz2
|
||||||
md5sums=('fcf58dcff52f0908ff3bc368d820408b')
|
gnutls_buildfix.patch)
|
||||||
|
md5sums=('fcf58dcff52f0908ff3bc368d820408b'
|
||||||
|
'372bf7a9da58ae49d9da50f79db69fb6')
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd ${srcdir}/${pkgname}-${pkgver}
|
cd ${srcdir}/${pkgname}-${pkgver}
|
||||||
|
|
||||||
|
# fix build with latest gnutls
|
||||||
|
patch -Np1 -i ${srcdir}/gnutls_buildfix.patch
|
||||||
|
|
||||||
sed -i 's@^#!.*python.*@#!/usr/bin/python2@' tools/*.py
|
sed -i 's@^#!.*python.*@#!/usr/bin/python2@' tools/*.py
|
||||||
|
|
||||||
./configure --prefix=/usr --disable-static \
|
./configure --prefix=/usr --disable-static \
|
||||||
|
|
12
extra/claws-mail/gnutls_buildfix.patch
Normal file
12
extra/claws-mail/gnutls_buildfix.patch
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
--- claws-mail-3.7.10/src/common/ssl.c 2011-12-07 14:55:08.682553870 +0100
|
||||||
|
+++ claws-mail-3.7.10/src/common/ssl.c 2011-12-07 14:55:43.808349602 +0100
|
||||||
|
@@ -270,7 +270,9 @@ gboolean ssl_init_socket_with_method(Soc
|
||||||
|
if (session == NULL || r != 0)
|
||||||
|
return FALSE;
|
||||||
|
|
||||||
|
+#if GNUTLS_VERSION_NUMBER < 0x020c00
|
||||||
|
gnutls_transport_set_lowat (session, 1);
|
||||||
|
+#endif
|
||||||
|
gnutls_set_default_priority(session);
|
||||||
|
gnutls_protocol_set_priority (session, proto_prio);
|
||||||
|
gnutls_cipher_set_priority (session, cipher_prio);
|
Loading…
Reference in a new issue