core/linux-kirkwood-dt to 4.2.0-2

This commit is contained in:
moonman 2015-09-07 08:59:44 +00:00
parent 1aa845f946
commit 82e3f342c8
2 changed files with 60 additions and 12 deletions

View file

@ -8,7 +8,7 @@ _kernelname=${pkgbase#linux}
_desc="Marvell Kirkwood DT"
pkgver=4.2.0
srcver=${pkgver%.0}
pkgrel=1
pkgrel=2
cryptodev_commit=da730106c2558c8e0c8e1b1b1812d32ef9574ab7
bfqver=v7r8
@ -42,10 +42,9 @@ source=("https://kernel.org/pub/linux/kernel/v4.x/linux-${srcver}.tar.xz"
md5sums=('3d5ea06d767e2f35c999eeadafc76523'
'c48409c4f93ad90390a234aea96ab345'
'ed6ea949989ccfd47e35349856a4fd27'
'8f6f89b315a249a4827783fd9b458e63'
'9b5a265440abf57d2052838f31486a3a'
'09d44b9f07abfaeaf4f688ee52034786'
# 'SKIP'
'8fb4d3b7cc970351f3b5078b7893a107'
'74bf103542cbdee0363819309adb97a2'
'f09baae3c7add4ed9bedde22ae3efe19'
@ -57,31 +56,31 @@ md5sums=('3d5ea06d767e2f35c999eeadafc76523'
prepare() {
cd "${srcdir}/linux-${srcver}"
#msg2 "Copying aufs patches into the kernel source tree"
# msg2 "Copying aufs patches into the kernel source tree"
# cp -ru "${srcdir}/aufs4-standalone/"{Documentation,fs} "${srcdir}/linux-${srcver}/"
# cp -ru "${srcdir}/aufs4-standalone/include/uapi/linux/aufs_type.h" "${srcdir}/linux-${srcver}/include/"{linux/,uapi/linux/}
#msg2 "Applying aufs patches"
# msg2 "Applying aufs patches"
# patch -Np1 -i ../aufs4-standalone/aufs4-kbuild.patch
# patch -Np1 -i ../aufs4-standalone/aufs4-base.patch
# patch -Np1 -i ../aufs4-standalone/aufs4-mmap.patch
# patch -Np1 -i ../aufs4-standalone/aufs4-standalone.patch
msg2 "Disable buggy TCP segmentation offload implementation"
msg2 "http://archlinuxarm.org/forum/viewtopic.php?f=9&t=7692"
msg2 "Disable buggy TCP segmentation offload implementation"
msg2 "http://archlinuxarm.org/forum/viewtopic.php?f=9&t=7692"
patch -Np1 -i ${srcdir}/0001-disable-mv643xx_eth-TSO.patch
msg2 "Add the USB_QUIRK_RESET_RESUME for several webcams"
msg2 "Add the USB_QUIRK_RESET_RESUME for several webcams"
# FS#26528
patch -Np1 -i "${srcdir}/usb-add-reset-resume-quirk-for-several-webcams.patch"
msg2 "Add Arch Linux ARM patch for ARMv5te plug computers"
msg2 "Add Arch Linux ARM patch for ARMv5te plug computers"
patch -Np1 -i "${srcdir}/archlinuxarm.patch"
patch -Np1 -i "${srcdir}/goflexhome_fdt.patch"
patch -Np1 -i "${srcdir}/pogoplugv4_fdt.patch"
patch -Np1 -i "${srcdir}/nsa325_fdt.patch"
msg2 "Add BFQ patches"
msg2 "Add BFQ patches"
patch -Np1 -i "${srcdir}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${bfqkern}.patch"
patch -Np1 -i "${srcdir}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${bfqkern}.patch"
patch -Np1 -i "${srcdir}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${bfqkern}.0.patch"
@ -121,10 +120,10 @@ build() {
#yes "" | make config
msg "Building!"
msg "Building!"
make ${MAKEFLAGS} zImage modules dtbs kirkwood-nsa320.dtb kirkwood-nsa325.dtb
msg "Building cryptodev module"
msg "Building cryptodev module"
cd "${srcdir}/cryptodev-linux-${cryptodev_commit}"
make KERNEL_DIR="${srcdir}/linux-${srcver}"
}

View file

@ -454,3 +454,52 @@ diff -ruN a/include/linux/nsa3xx-hwmon.h b/include/linux/nsa3xx-hwmon.h
+};
+
+#endif /* __LINUX_NSA3XX_HWMON_H */
diff -Naur a/arch/arm/boot/dts/kirkwood-nsa320.dts b/arch/arm/boot/dts/kirkwood-nsa320.dts
--- a/arch/arm/boot/dts/kirkwood-nsa320.dts 2015-08-30 11:34:09.000000000 -0700
+++ b/arch/arm/boot/dts/kirkwood-nsa320.dts 2015-08-31 00:50:12.000000000 -0700
@@ -193,10 +193,19 @@
};
};
+ nsa3xx-hwmon {
+ compatible = "zyxel,nsa320-mcu";
+ pinctrl-0 = <&pmx_mcu_data &pmx_mcu_clk &pmx_mcu_act>;
+ pinctrl-names = "default";
+
+ data-gpios = <&gpio0 14 GPIO_ACTIVE_HIGH>;
+ clk-gpios = <&gpio0 16 GPIO_ACTIVE_HIGH>;
+ act-gpios = <&gpio0 17 GPIO_ACTIVE_HIGH>;
+ };
+
/* The following pins are currently not assigned to a driver,
some of them should be configured as inputs.
- pinctrl-0 = <&pmx_mcu_data &pmx_mcu_clk &pmx_mcu_act
- &pmx_htp &pmx_vid_b1
+ pinctrl-0 = <&pmx_htp &pmx_vid_b1
&pmx_power_resume_data &pmx_power_resume_clk>; */
};
diff -ruN a/arch/arm/boot/dts/kirkwood-pogo_e02.dts b/arch/arm/boot/dts/kirkwood-pogo_e02.dts
--- a/arch/arm/boot/dts/kirkwood-pogo_e02.dts 2015-08-30 18:34:09.000000000 +0000
+++ b/arch/arm/boot/dts/kirkwood-pogo_e02.dts 2015-09-07 08:17:05.277878971 +0000
@@ -38,7 +38,7 @@
health {
label = "pogo_e02:green:health";
gpios = <&gpio1 16 GPIO_ACTIVE_LOW>;
- default-state = "keep";
+ default-state = "default-on";
};
fault {
label = "pogo_e02:orange:fault";
diff -ruN a/arch/arm/boot/dts/kirkwood.dtsi b/arch/arm/boot/dts/kirkwood.dtsi
--- a/arch/arm/boot/dts/kirkwood.dtsi 2015-08-30 18:34:09.000000000 +0000
+++ b/arch/arm/boot/dts/kirkwood.dtsi 2015-09-07 08:13:46.968601230 +0000
@@ -41,7 +41,7 @@
pcie-io-aperture = <0xf2000000 0x100000>; /* 1 MiB I/O space */
cesa: crypto@0301 {
- compatible = "marvell,orion-crypto";
+ compatible = "marvell,kirkwood-crypto";
reg = <MBUS_ID(0xf0, 0x01) 0x30000 0x10000>,
<MBUS_ID(0x03, 0x01) 0 0x800>;
reg-names = "regs", "sram";