extra/vlc to 3.0.4-1

This commit is contained in:
Kevin Mihelich 2018-09-04 00:44:06 +00:00
parent 30cc436a71
commit 832eec111a
2 changed files with 16 additions and 49 deletions

View file

@ -7,11 +7,11 @@
# - enable gles2
pkgname=vlc
_vlcver=3.0.3
_vlcver=3.0.4
# optional fixup version including hyphen
_vlcfixupver=-1
_vlcfixupver=
pkgver=${_vlcver}${_vlcfixupver//-/.r}
pkgrel=2
pkgrel=1
pkgdesc='Multi-platform MPEG, VCD/DVD, and DivX player'
url='https://www.videolan.org/vlc/'
arch=('x86_64')
@ -31,7 +31,7 @@ makedepends=('gst-plugins-base-libs' 'live-media' 'libnotify' 'libbluray'
'libvorbis' 'speex' 'opus' 'libtheora' 'libpng' 'libjpeg-turbo'
'libx265.so' 'libx264.so' 'zvbi' 'libass' 'libkate' 'libtiger'
'sdl_image' 'libpulse' 'alsa-lib' 'jack' 'libsamplerate' 'libsoxr'
'lirc' 'libgoom2' 'projectm' 'chromaprint')
'lirc' 'libgoom2' 'projectm' 'chromaprint' 'aribb24')
optdepends=('avahi: service discovery using bonjour protocol'
'gst-plugins-base-libs: for libgst plugins'
'libdvdcss: decoding encrypted DVDs'
@ -75,6 +75,7 @@ optdepends=('avahi: service discovery using bonjour protocol'
'x265: HEVC/H.265 encoder'
'zvbi: VBI/Teletext decoding'
'libass: Subtitle support'
'aribb24: ARIB subtitles'
'libkate: Kate codec'
'libtiger: Tiger rendering for Kate streams'
'sdl_image: SDL image support'
@ -97,14 +98,12 @@ replaces=('vlc-plugin')
options=('!emptydirs')
source=(https://download.videolan.org/${pkgname}/${_vlcver}/${pkgname}-${_vlcver}${_vlcfixupver}.tar.xz{,.asc}
update-vlc-plugin-cache.hook
aom-remove-unsupported-pixel-formats.patch
lua53_compat.patch
vlc-qt5.11.patch
vlc-x264-155.patch)
sha512sums=('d1979f6149821cf91d7b40b18d83d399b9021966b60589615638423a4e2c3ff86fdbbe9c0d92c85bfdd90f03991256ccee95d7a33ae96326177bb2bfe85e7a0f'
sha512sums=('55c5a45a1573d559f8d62272dc446bebfb328bd48f938e634693a45032e1a3095148e634de5bc53a3a3c0e4858f7df3ed7e5dc91f3f5447e47d0ab5775171271'
'SKIP'
'80357bae69e32b353d3784932d854e294906798e14faffb87c3383c3b6f6bdc57cbabb9c6e3f3c1adf0f8ddbb24153e72104c963cf1934970c2983c96daef9df'
'5757a6f35e106883072c31d137fd247c65a544f730cf736ca2e81a31357305b5c002b52349337d8e1667fbe68628bc253ec69eee727f268aee7902a5bef82dce'
'33cda373aa1fb3ee19a78748e2687f2b93c8662c9fda62ecd122a2e649df8edaceb54dda3991bc38c80737945a143a9e65baa2743a483bb737bb94cd590dc25f'
'66aad0ec32d1a96f65566b04eb9c0b4574824e281940fe5c0de54ac5f92189693a9f2576203d2c8562d7174ec5315cbbd683d93c481d16119d3038e30a58cbf5'
'47b844c7ada22042a0aab67d485ee68fda4847400dedd0f5662eb3738c1e45a06b50a6a045f3af1f07625ebd6f021bd43acaa9a8e63720e3b1207ad0d23bb36f')
@ -116,10 +115,14 @@ prepare() {
sed -e 's|-Werror-implicit-function-declaration||g' -i configure
sed 's|whoami|echo builduser|g' -i configure
sed 's|hostname -f|echo arch|g' -i configure
patch -Np1 < "${srcdir}/aom-remove-unsupported-pixel-formats.patch"
patch -Np1 < "${srcdir}/lua53_compat.patch"
patch -Np1 < "${srcdir}/vlc-qt5.11.patch"
patch -Np1 < "${srcdir}/vlc-x264-155.patch"
local src
for src in "${source[@]}"; do
src="${src%%::*}"
src="${src##*/}"
[[ $src = *.patch ]] || continue
msg2 "Applying patch $src..."
patch -Np1 < "../$src"
done
}
build() {
@ -134,6 +137,7 @@ build() {
./configure --prefix=/usr \
--sysconfdir=/etc \
--with-kde-solid=/usr/share/solid/actions/ \
--disable-rpath \
--enable-nls \
--enable-archive \
@ -222,7 +226,7 @@ build() {
--enable-notify \
--enable-libplacebo \
--enable-vlc \
--with-kde-solid=/usr/share/solid/actions/ \
--enable-aribsub \
--enable-gles2
make
}

View file

@ -1,37 +0,0 @@
From 622360c2c4335fff793f81f5e673326a581f5c0c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Martin=20Storsj=C3=B6?= <martin@martin.st>
Date: Thu, 19 Apr 2018 18:25:07 +0300
Subject: [PATCH] aom: Remove unsupported pixel formats
Support for these was apparently never in the codebase, and the enum
values were recently removed from the public headers [1].
This fixes build with latest libaom build.
[1] https://aomedia.googlesource.com/aom/+/3f29cc20e3a4c348cb41a797c68de856ddb84e12
---
modules/codec/aom.c | 11 -----------
1 file changed, 11 deletions(-)
diff --git a/modules/codec/aom.c b/modules/codec/aom.c
index 5bb442b5d50..60034158c47 100644
--- a/modules/codec/aom.c
+++ b/modules/codec/aom.c
@@ -116,17 +116,6 @@ static const struct
{ VLC_CODEC_YV12, AOM_IMG_FMT_YV12, 8, 0 },
{ VLC_CODEC_YUVA, AOM_IMG_FMT_444A, 8, 0 },
- { VLC_CODEC_YUYV, AOM_IMG_FMT_YUY2, 8, 0 },
- { VLC_CODEC_UYVY, AOM_IMG_FMT_UYVY, 8, 0 },
- { VLC_CODEC_YVYU, AOM_IMG_FMT_YVYU, 8, 0 },
-
- { VLC_CODEC_RGB15, AOM_IMG_FMT_RGB555, 8, 0 },
- { VLC_CODEC_RGB16, AOM_IMG_FMT_RGB565, 8, 0 },
- { VLC_CODEC_RGB24, AOM_IMG_FMT_RGB24, 8, 0 },
- { VLC_CODEC_RGB32, AOM_IMG_FMT_RGB32, 8, 0 },
-
- { VLC_CODEC_ARGB, AOM_IMG_FMT_ARGB, 8, 0 },
- { VLC_CODEC_BGRA, AOM_IMG_FMT_ARGB_LE, 8, 0 },
{ VLC_CODEC_GBR_PLANAR, AOM_IMG_FMT_I444, 8, 1 },
{ VLC_CODEC_GBR_PLANAR_10L, AOM_IMG_FMT_I44416, 10, 1 },