core/linux-aarch64-rc to 5.11.rc4-1

This commit is contained in:
Kevin Mihelich 2021-01-18 19:40:55 +00:00
parent 44c3fe2db9
commit 834bfc388f
6 changed files with 456 additions and 171 deletions

View file

@ -1,4 +1,4 @@
From e801f0f40fc676ffeecff80d2dfbfd0c26d6cfc1 Mon Sep 17 00:00:00 2001
From 4c4a7f5be455b62eab03af8d664b790a6453c999 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 1/4] net/smsc95xx: Allow mac address to be set as a parameter
@ -8,18 +8,18 @@ Subject: [PATCH 1/4] net/smsc95xx: Allow mac address to be set as a parameter
1 file changed, 56 insertions(+)
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
index 355be77f4241..c94a7193e0b9 100644
index ea0d5f04dc3a..88ebceb84193 100644
--- a/drivers/net/usb/smsc95xx.c
+++ b/drivers/net/usb/smsc95xx.c
@@ -48,6 +48,7 @@
@@ -50,6 +50,7 @@
#define SUSPEND_SUSPEND3 (0x08)
#define SUSPEND_ALLMODES (SUSPEND_SUSPEND0 | SUSPEND_SUSPEND1 | \
SUSPEND_SUSPEND2 | SUSPEND_SUSPEND3)
+#define MAC_ADDR_LEN (6)
#define CARRIER_CHECK_DELAY (2 * HZ)
@@ -70,6 +71,10 @@ static bool turbo_mode = true;
struct smsc95xx_priv {
u32 mac_cr;
@@ -67,6 +68,10 @@ static bool turbo_mode = true;
module_param(turbo_mode, bool, 0644);
MODULE_PARM_DESC(turbo_mode, "Enable multiple frames per Rx transaction");
@ -30,8 +30,8 @@ index 355be77f4241..c94a7193e0b9 100644
static int __must_check __smsc95xx_read_reg(struct usbnet *dev, u32 index,
u32 *data, int in_pm)
{
@@ -899,8 +904,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
return generic_mii_ioctl(&dev->mii, if_mii(rq), cmd, NULL);
@@ -753,8 +758,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
return phy_mii_ioctl(netdev->phydev, rq, cmd);
}
+/* Check the macaddr module parameter for a MAC address */
@ -87,9 +87,9 @@ index 355be77f4241..c94a7193e0b9 100644
+ if (smsc95xx_is_macaddr_param(dev, dev->net->dev_addr))
+ return;
+
const u8 *mac_addr;
/* maybe the boot loader passed the MAC address in devicetree */
if (!eth_platform_get_mac_address(&dev->udev->dev,
dev->net->dev_addr)) {
--
2.24.0
2.30.0

View file

@ -1,4 +1,4 @@
From 146609a19fd2b48730a098d19383226c26794ffb Mon Sep 17 00:00:00 2001
From fda1e1c741e44548eb6ef93f34d8e35487302c2e Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 7 Aug 2017 19:34:57 -0600
Subject: [PATCH 2/4] arm64: dts: rockchip: disable pwm0 on rk3399-firefly
@ -9,10 +9,10 @@ Workaround for intermittent boot hangs due to pwm0 probe disabling the PWM clock
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
index c706db0ee9ec..24adeca99711 100644
index 6db18808b9c5..c7c49ace4b5b 100644
--- a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
+++ b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
@@ -640,7 +640,7 @@ diy_led_gpio: diy_led-gpio {
@@ -640,7 +640,7 @@ diy_led_pin: diy-led-pin {
};
&pwm0 {
@ -22,5 +22,5 @@ index c706db0ee9ec..24adeca99711 100644
&pwm2 {
--
2.24.0
2.30.0

View file

@ -1,4 +1,4 @@
From 9a32f275686f725fa7326a52a47a6e888fa54253 Mon Sep 17 00:00:00 2001
From 049261c33ab0f5cb4156f5b9a894f30dcc50e2ab Mon Sep 17 00:00:00 2001
From: William Wu <william.wu@rock-chips.com>
Date: Mon, 4 Dec 2017 10:40:39 +0100
Subject: [PATCH 3/4] arm64: dts: rockchip: add usb3 controller node for RK3328
@ -16,10 +16,10 @@ Signed-off-by: Heiko Stuebner <heiko@sntech.de>
1 file changed, 27 insertions(+)
diff --git a/arch/arm64/boot/dts/rockchip/rk3328.dtsi b/arch/arm64/boot/dts/rockchip/rk3328.dtsi
index 91306ebed4da..ac4bc0935c86 100644
index db0d5c8e5f96..980dce4830d2 100644
--- a/arch/arm64/boot/dts/rockchip/rk3328.dtsi
+++ b/arch/arm64/boot/dts/rockchip/rk3328.dtsi
@@ -968,6 +968,33 @@ usb_host0_ohci: usb@ff5d0000 {
@@ -983,6 +983,33 @@ usb_host0_ohci: usb@ff5d0000 {
status = "disabled";
};
@ -54,5 +54,5 @@ index 91306ebed4da..ac4bc0935c86 100644
compatible = "arm,gic-400";
#interrupt-cells = <3>;
--
2.24.0
2.30.0

View file

@ -1,4 +1,4 @@
From 513ab442c8ee60a2c3f785f45cf9aae530e30bc8 Mon Sep 17 00:00:00 2001
From 10446b4ecaee72bb5cdc437fcd73f1aea012e7cc Mon Sep 17 00:00:00 2001
From: Heiko Stuebner <heiko@sntech.de>
Date: Mon, 4 Dec 2017 10:40:41 +0100
Subject: [PATCH 4/4] arm64: dts: rockchip: enable usb3 nodes on rk3328-rock64
@ -11,10 +11,10 @@ Signed-off-by: Heiko Stuebner <heiko@sntech.de>
1 file changed, 9 insertions(+)
diff --git a/arch/arm64/boot/dts/rockchip/rk3328-rock64.dts b/arch/arm64/boot/dts/rockchip/rk3328-rock64.dts
index 62936b432f9a..c684ca7b7e2d 100644
index 86cfb5c50a94..ae27f449f4a3 100644
--- a/arch/arm64/boot/dts/rockchip/rk3328-rock64.dts
+++ b/arch/arm64/boot/dts/rockchip/rk3328-rock64.dts
@@ -391,6 +391,15 @@ &usb_host0_ohci {
@@ -392,6 +392,15 @@ &usb_host0_ohci {
status = "okay";
};
@ -31,5 +31,5 @@ index 62936b432f9a..c684ca7b7e2d 100644
status = "okay";
};
--
2.24.0
2.30.0

View file

@ -3,7 +3,7 @@
buildarch=8
_rcver=5.9
_rcver=5.11
_rcrel=4
pkgbase=linux-aarch64-rc
@ -29,12 +29,12 @@ source=("https://git.kernel.org/torvalds/t/${_srcname}.tar.gz"
'linux.preset'
'60-linux.hook'
'90-linux.hook')
md5sums=('c0181a3ddb056a18e5376aa3d85b2b7a'
'8f50ae936659ff174e292e1164d279c1'
'e85e2b7aa3bc42d7dd6b36c325d29e3f'
'2c36fb143c27ed46f498c4d4633ea0c6'
'2e3fe5b9053d6a2c5327113836409d13'
'd655a4f903d386ae2ee8b6a0f63aa82e'
md5sums=('bd6e8d6caf0c6d6724b830dadd2129e6'
'f9b6f367eef351eaa89b23a9b1ffc5a2'
'369fb1dd626c4e0a4a7e068d27dd51c8'
'1553fe4abbe675ed8abd4644561d8e8c'
'9844db3484f4d4fa3e63c7e083f656f7'
'ff6bfb082d44603205f641ef7fa45285'
'7f1a96e24f5150f790df94398e9525a3'
'61c5ff73c136ed07a7aadbf58db3d96a'
'584777ae88bce2c5659960151b64c7d8'
@ -168,7 +168,7 @@ _package-headers() {
cp -t "${_builddir}" -a include scripts
install -Dt "${_builddir}/arch/${KARCH}" -m644 arch/${KARCH}/Makefile
install -Dt "${_builddir}/arch/${KARCH}/kernel" -m644 arch/${KARCH}/kernel/asm-offsets.s arch/$KARCH/kernel/module.lds
install -Dt "${_builddir}/arch/${KARCH}/kernel" -m644 arch/${KARCH}/kernel/asm-offsets.s
cp -t "${_builddir}/arch/${KARCH}" -a arch/${KARCH}/include
mkdir -p "${_builddir}/arch/arm"

File diff suppressed because it is too large Load diff