mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/libgda to 5.2.10-1
This commit is contained in:
parent
239c350c2f
commit
8371c19230
4 changed files with 131 additions and 103 deletions
118
extra/libgda/0001-Use-single-header-with-GtkSource.patch
Normal file
118
extra/libgda/0001-Use-single-header-with-GtkSource.patch
Normal file
|
@ -0,0 +1,118 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Corentin=20No=C3=ABl?= <corentin@elementary.io>
|
||||
Date: Wed, 4 Apr 2018 22:51:50 +0100
|
||||
Subject: [PATCH] Use single header with GtkSource
|
||||
|
||||
---
|
||||
libgda-ui/data-entries/plugins/gdaui-entry-text.c | 10 +---------
|
||||
libgda-ui/data-entries/plugins/libmain.c | 10 +---------
|
||||
tools/browser/data-manager/data-favorite-selector.c | 10 +---------
|
||||
tools/browser/data-manager/xml-spec-editor.c | 10 +---------
|
||||
tools/browser/query-exec/query-editor.c | 10 +---------
|
||||
5 files changed, 5 insertions(+), 45 deletions(-)
|
||||
|
||||
diff --git a/libgda-ui/data-entries/plugins/gdaui-entry-text.c b/libgda-ui/data-entries/plugins/gdaui-entry-text.c
|
||||
index e359820eb..b483128a4 100644
|
||||
--- a/libgda-ui/data-entries/plugins/gdaui-entry-text.c
|
||||
+++ b/libgda-ui/data-entries/plugins/gdaui-entry-text.c
|
||||
@@ -25,15 +25,7 @@
|
||||
#include <libgda/gda-blob-op.h>
|
||||
|
||||
#ifdef HAVE_GTKSOURCEVIEW
|
||||
- #ifdef GTK_DISABLE_SINGLE_INCLUDES
|
||||
- #undef GTK_DISABLE_SINGLE_INCLUDES
|
||||
- #endif
|
||||
-
|
||||
- #include <gtksourceview/gtksourceview.h>
|
||||
- #include <gtksourceview/gtksourcelanguagemanager.h>
|
||||
- #include <gtksourceview/gtksourcebuffer.h>
|
||||
- #include <gtksourceview/gtksourcestyleschememanager.h>
|
||||
- #include <gtksourceview/gtksourcestylescheme.h>
|
||||
+ #include <gtksourceview/gtksource.h>
|
||||
#endif
|
||||
#define LANGUAGE_SQL "gda-sql"
|
||||
|
||||
diff --git a/libgda-ui/data-entries/plugins/libmain.c b/libgda-ui/data-entries/plugins/libmain.c
|
||||
index a30c2db2c..c3a0f8f53 100644
|
||||
--- a/libgda-ui/data-entries/plugins/libmain.c
|
||||
+++ b/libgda-ui/data-entries/plugins/libmain.c
|
||||
@@ -39,15 +39,7 @@
|
||||
#endif
|
||||
|
||||
#ifdef HAVE_GTKSOURCEVIEW
|
||||
- #ifdef GTK_DISABLE_SINGLE_INCLUDES
|
||||
- #undef GTK_DISABLE_SINGLE_INCLUDES
|
||||
- #endif
|
||||
-
|
||||
- #include <gtksourceview/gtksourceview.h>
|
||||
- #include <gtksourceview/gtksourcelanguagemanager.h>
|
||||
- #include <gtksourceview/gtksourcebuffer.h>
|
||||
- #include <gtksourceview/gtksourcestyleschememanager.h>
|
||||
- #include <gtksourceview/gtksourcestylescheme.h>
|
||||
+ #include <gtksourceview/gtksource.h>
|
||||
#endif
|
||||
|
||||
static GdauiDataEntry *plugin_entry_filesel_create_func (GdaDataHandler *handler, GType type, const gchar *options);
|
||||
diff --git a/tools/browser/data-manager/data-favorite-selector.c b/tools/browser/data-manager/data-favorite-selector.c
|
||||
index d472fd5f6..815204d64 100644
|
||||
--- a/tools/browser/data-manager/data-favorite-selector.c
|
||||
+++ b/tools/browser/data-manager/data-favorite-selector.c
|
||||
@@ -33,15 +33,7 @@
|
||||
#include <libgda-ui/internal/popup-container.h>
|
||||
|
||||
#ifdef HAVE_GTKSOURCEVIEW
|
||||
- #ifdef GTK_DISABLE_SINGLE_INCLUDES
|
||||
- #undef GTK_DISABLE_SINGLE_INCLUDES
|
||||
- #endif
|
||||
-
|
||||
- #include <gtksourceview/gtksourceview.h>
|
||||
- #include <gtksourceview/gtksourcelanguagemanager.h>
|
||||
- #include <gtksourceview/gtksourcebuffer.h>
|
||||
- #include <gtksourceview/gtksourcestyleschememanager.h>
|
||||
- #include <gtksourceview/gtksourcestylescheme.h>
|
||||
+ #include <gtksourceview/gtksource.h>
|
||||
#endif
|
||||
|
||||
struct _DataFavoriteSelectorPrivate {
|
||||
diff --git a/tools/browser/data-manager/xml-spec-editor.c b/tools/browser/data-manager/xml-spec-editor.c
|
||||
index f4b893a00..b337d107c 100644
|
||||
--- a/tools/browser/data-manager/xml-spec-editor.c
|
||||
+++ b/tools/browser/data-manager/xml-spec-editor.c
|
||||
@@ -28,15 +28,7 @@
|
||||
#include <libgda/gda-debug-macros.h>
|
||||
|
||||
#ifdef HAVE_GTKSOURCEVIEW
|
||||
-#ifdef GTK_DISABLE_SINGLE_INCLUDES
|
||||
-#undef GTK_DISABLE_SINGLE_INCLUDES
|
||||
-#endif
|
||||
-
|
||||
-#include <gtksourceview/gtksourceview.h>
|
||||
-#include <gtksourceview/gtksourcelanguagemanager.h>
|
||||
-#include <gtksourceview/gtksourcebuffer.h>
|
||||
-#include <gtksourceview/gtksourcestyleschememanager.h>
|
||||
-#include <gtksourceview/gtksourcestylescheme.h>
|
||||
+#include <gtksourceview/gtksource.h>
|
||||
#endif
|
||||
|
||||
struct _XmlSpecEditorPrivate {
|
||||
diff --git a/tools/browser/query-exec/query-editor.c b/tools/browser/query-exec/query-editor.c
|
||||
index 061aefb9d..7cb9923ac 100644
|
||||
--- a/tools/browser/query-exec/query-editor.c
|
||||
+++ b/tools/browser/query-exec/query-editor.c
|
||||
@@ -22,15 +22,7 @@
|
||||
#include <string.h>
|
||||
#include <gdk/gdkkeysyms.h>
|
||||
#ifdef HAVE_GTKSOURCEVIEW
|
||||
- #ifdef GTK_DISABLE_SINGLE_INCLUDES
|
||||
- #undef GTK_DISABLE_SINGLE_INCLUDES
|
||||
- #endif
|
||||
-
|
||||
- #include <gtksourceview/gtksourceview.h>
|
||||
- #include <gtksourceview/gtksourcelanguagemanager.h>
|
||||
- #include <gtksourceview/gtksourcebuffer.h>
|
||||
- #include <gtksourceview/gtksourcestyleschememanager.h>
|
||||
- #include <gtksourceview/gtksourcestylescheme.h>
|
||||
+ #include <gtksourceview/gtksource.h>
|
||||
#endif
|
||||
#include "query-editor.h"
|
||||
#include <binreloc/gda-binreloc.h>
|
|
@ -1,68 +0,0 @@
|
|||
diff --git a/libgda-report/RML/gda-report-rml-document.c b/libgda-report/RML/gda-report-rml-document.c
|
||||
index 7bb13bc..3f905e5 100644
|
||||
--- a/libgda-report/RML/gda-report-rml-document.c
|
||||
+++ b/libgda-report/RML/gda-report-rml-document.c
|
||||
@@ -189,61 +189,11 @@ gda_report_rml_document_new (GdaReportEngine *engine)
|
||||
static gboolean
|
||||
gda_report_rml_document_run_as_html (GdaReportDocument *doc, const gchar *filename, GError **error)
|
||||
{
|
||||
- static GMutex init_mutex;
|
||||
- static gchar *converter = NULL;
|
||||
-
|
||||
- g_return_val_if_fail (GDA_IS_REPORT_RML_DOCUMENT (doc), FALSE);
|
||||
- g_return_val_if_fail (filename && *filename, FALSE);
|
||||
-
|
||||
- g_mutex_lock (&init_mutex);
|
||||
- if (!converter) {
|
||||
- converter = g_find_program_in_path ("trml2html.py");
|
||||
- if (!converter) {
|
||||
- converter = gda_gbr_get_file_path (GDA_DATA_DIR, LIBGDA_ABI_NAME, "gda_trml2html", "trml2html.py", NULL);
|
||||
- if (!g_file_test (converter, G_FILE_TEST_IS_EXECUTABLE)) {
|
||||
- g_free (converter);
|
||||
- converter = NULL;
|
||||
- }
|
||||
- }
|
||||
- if (!converter) {
|
||||
- g_set_error (error, 0, 0,
|
||||
- _("Could not find the '%s' program"), "trml2html.py");
|
||||
- g_mutex_unlock (&init_mutex);
|
||||
- return FALSE;
|
||||
- }
|
||||
- }
|
||||
- g_mutex_unlock (&init_mutex);
|
||||
-
|
||||
- return _gda_report_document_run_converter_path (doc, filename, converter, "trml2html", error);
|
||||
+ return TRUE;
|
||||
}
|
||||
|
||||
static gboolean
|
||||
gda_report_rml_document_run_as_pdf (GdaReportDocument *doc, const gchar *filename, GError **error)
|
||||
{
|
||||
- static GMutex init_mutex;
|
||||
- static gchar *converter = NULL;
|
||||
-
|
||||
- g_return_val_if_fail (GDA_IS_REPORT_RML_DOCUMENT (doc), FALSE);
|
||||
- g_return_val_if_fail (filename && *filename, FALSE);
|
||||
-
|
||||
- g_mutex_lock (&init_mutex);
|
||||
- if (!converter) {
|
||||
- converter = g_find_program_in_path ("trml2pdf.py");
|
||||
- if (!converter) {
|
||||
- converter = gda_gbr_get_file_path (GDA_DATA_DIR, LIBGDA_ABI_NAME, "gda_trml2pdf", "trml2pdf.py", NULL);
|
||||
- if (!g_file_test (converter, G_FILE_TEST_IS_EXECUTABLE)) {
|
||||
- g_free (converter);
|
||||
- converter = NULL;
|
||||
- }
|
||||
- }
|
||||
- if (!converter) {
|
||||
- g_set_error (error, 0, 0,
|
||||
- _("Could not find the '%s' program"), "trml2pdf.py");
|
||||
- g_mutex_unlock (&init_mutex);
|
||||
- return FALSE;
|
||||
- }
|
||||
- }
|
||||
- g_mutex_unlock (&init_mutex);
|
||||
-
|
||||
- return _gda_report_document_run_converter_path (doc, filename, converter, "trml2pdf", error);
|
||||
+ return TRUE;
|
||||
}
|
|
@ -6,22 +6,20 @@
|
|||
# - remove firebird package, makedepends on libfbclient
|
||||
|
||||
pkgname=(libgda libgda-{jdbc,mysql,postgres})
|
||||
pkgver=5.2.9
|
||||
pkgrel=4
|
||||
pkgver=5.2.10
|
||||
pkgrel=1
|
||||
pkgdesc="Database access library"
|
||||
url="https://www.gnome-db.org/"
|
||||
arch=(x86_64)
|
||||
license=(GPL)
|
||||
depends=(gtksourceview3 libxslt libsecret graphviz goocanvas iso-codes libgee openssl)
|
||||
depends=(gtksourceview3 libxslt python libsecret graphviz goocanvas iso-codes libgee openssl)
|
||||
makedepends=(glade mariadb-libs postgresql-libs jdk8-openjdk intltool
|
||||
gobject-introspection gtk-doc vala itstool gnome-common git)
|
||||
_commit=295fa78d29eee6dbbc5d07fd6884cb95f48d92e0 # tags/LIBGDA_5_2_9^0
|
||||
_commit=85a2532df64698306fd3be324bb2052fb1b80fd3 # tags/LIBGDA_5_2_10^0
|
||||
source=("git+https://gitlab.gnome.org/GNOME/libgda.git#commit=$_commit"
|
||||
fix-crash.diff
|
||||
0001-libgda-report-remove-trml2pdf-trml2html-functionalit.patch)
|
||||
0001-Use-single-header-with-GtkSource.patch)
|
||||
sha256sums=('SKIP'
|
||||
'7eab1c7f5c11a87ce7a3e47c5c9058595f14c0b601daa6e0a32d797b708d97ba'
|
||||
'd74a70bd7b8a7750049b123c8fc8e38c9b9c85b51f63c061998cf06b3cfc65af')
|
||||
'104594a6034b041d87c1129b0b5544c8899393d66a6a0fb7a8b55f7fcb77e560')
|
||||
|
||||
_apiver=5.0
|
||||
|
||||
|
@ -37,9 +35,13 @@ prepare() {
|
|||
[[ $CARCH != "aarch64" ]] && export LD_LIBRARY_PATH=/usr/lib/jvm/java-8-openjdk/jre/lib/arm/server:$LD_LIBRARY_PATH
|
||||
|
||||
cd $pkgname
|
||||
patch -Np1 -i ../fix-crash.diff
|
||||
# remove converter functionality that relies on eight-year-old python2 scripts/taken from Fedora
|
||||
patch -Np1 -i ../0001-libgda-report-remove-trml2pdf-trml2html-functionalit.patch
|
||||
|
||||
# Remove conflicting typedef
|
||||
git revert -n e1aea5ffb3fd9b49ad8c0dc01a915b47de3dc3d2
|
||||
|
||||
# Fix use of gtksourceview headers
|
||||
git apply -3 ../0001-Use-single-header-with-GtkSource.patch
|
||||
|
||||
NOCONFIGURE=1 ./autogen.sh
|
||||
}
|
||||
|
||||
|
@ -74,9 +76,6 @@ package_libgda() {
|
|||
mv "$pkgdir"/usr/lib/libgda-$_apiver/providers/gdaprovider-${_apiver}.jar \
|
||||
"$pkgdir"/usr/bin/gda-list-jdbc-providers-${_apiver} \
|
||||
"$srcdir/providers"
|
||||
|
||||
# remove eight-year-old python2 report converter scripts
|
||||
rm -r "$pkgdir"/usr/share/libgda-5.0/gda_trml2{html,pdf}
|
||||
}
|
||||
|
||||
_packageprovider() {
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
diff --git i/libgda-ui/data-entries/plugins/libmain.c w/libgda-ui/data-entries/plugins/libmain.c
|
||||
index a30c2db2c3258111..1356488c8b0940f9 100644
|
||||
--- i/libgda-ui/data-entries/plugins/libmain.c
|
||||
+++ w/libgda-ui/data-entries/plugins/libmain.c
|
||||
@@ -39,15 +39,7 @@
|
||||
#endif
|
||||
|
||||
#ifdef HAVE_GTKSOURCEVIEW
|
||||
- #ifdef GTK_DISABLE_SINGLE_INCLUDES
|
||||
- #undef GTK_DISABLE_SINGLE_INCLUDES
|
||||
- #endif
|
||||
-
|
||||
- #include <gtksourceview/gtksourceview.h>
|
||||
- #include <gtksourceview/gtksourcelanguagemanager.h>
|
||||
- #include <gtksourceview/gtksourcebuffer.h>
|
||||
- #include <gtksourceview/gtksourcestyleschememanager.h>
|
||||
- #include <gtksourceview/gtksourcestylescheme.h>
|
||||
+#include <gtksourceview/gtksource.h>
|
||||
#endif
|
||||
|
||||
static GdauiDataEntry *plugin_entry_filesel_create_func (GdaDataHandler *handler, GType type, const gchar *options);
|
Loading…
Reference in a new issue