diff --git a/extra/graphite/PKGBUILD b/extra/graphite/PKGBUILD
index b24b12041..8ca9a041c 100644
--- a/extra/graphite/PKGBUILD
+++ b/extra/graphite/PKGBUILD
@@ -5,7 +5,7 @@
 #  - patch for arm
 
 pkgname=graphite
-pkgver=1.3.0
+pkgver=1.3.1
 pkgrel=1
 epoch=1
 arch=('i686' 'x86_64')
@@ -20,11 +20,11 @@ options=('!emptydirs')
 source=(http://downloads.sourceforge.net/project/silgraphite/graphite2/graphite2-${pkgver}.tgz
         graphite2-1.2.0-cmakepath.patch
         graphite-arm-nodefaultlibs.patch)
-md5sums=('ca6da3ba3ff914e4974c167a7a63a3ae'
-         '00353b67941dbc30b76a43253760769e'
-         '35a628ad03433fa8e3febe7222844d4c')
+sha1sums=('e1d4b129b1fea1a44428da59f200c6a07dc5aad2'
+          '7283d73e21f28a0b4221af9ce7998d68fcced16a'
+          '67b4fb81303484a65ab5bfa183da999d14169157')
 
-build() {
+prepare() {
   cd "${srcdir}"
 
   # python2 fixes
@@ -35,7 +35,9 @@ build() {
   patch -Np1 -i ${srcdir}/graphite2-1.2.0-cmakepath.patch
   patch -Np1 -i ${srcdir}/graphite-arm-nodefaultlibs.patch
   popd
-  
+}
+
+build() { 
   mkdir build
   cd build
   cmake -G "Unix Makefiles" ../graphite2-${pkgver} \