mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/qt5-webkit: fixes
This commit is contained in:
parent
488c462e0f
commit
83b4224e6e
2 changed files with 21 additions and 6 deletions
|
@ -4,8 +4,8 @@
|
|||
# Contributor: Andrea Scarpino <andrea@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to link with libatomic on v5/v6
|
||||
# - disable jit on v5/v6
|
||||
# - disable OpenGL
|
||||
|
||||
highmem=1
|
||||
|
||||
|
@ -20,14 +20,16 @@ pkgdesc='Classes for a WebKit2 based implementation and a new QML API'
|
|||
depends=(qt5-location qt5-sensors qt5-webchannel libwebp libxslt libxcomposite gst-plugins-base hyphen)
|
||||
makedepends=(cmake ruby gperf python2 qt5-doc qt5-tools)
|
||||
optdepends=('gst-plugins-good: Webm codec support')
|
||||
conflicts=(qt5-webkit-ng)
|
||||
replaces=(qt5-webkit-ng)
|
||||
conflicts=(qt5-webkit-ng qt5-webkit-og)
|
||||
replaces=(qt5-webkit-ng qt5-webkit-og)
|
||||
groups=(qt qt5)
|
||||
_pkgfqn="${pkgname/5-/}-opensource-src-${_qtver}"
|
||||
source=("https://github.com/annulen/webkit/releases/download/qtwebkit-$_qtver/qtwebkit-$_qtver.tar.xz"
|
||||
qt5-webkit-gcc7.patch)
|
||||
qt5-webkit-gcc7.patch
|
||||
atomic.patch)
|
||||
sha256sums=('f8f901de567e11fc5659402b6b827eac75505ff9c5072d8e919aa306003f8f8a'
|
||||
'f108833562d766d4c086026f9202b2ebc8c19e97fddedce952afed78df3c0720')
|
||||
'f108833562d766d4c086026f9202b2ebc8c19e97fddedce952afed78df3c0720'
|
||||
'23fbd785daf116c71b3ce87d40860f0a6c56ab1065ee98ec41634626ca961129')
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
|
@ -35,6 +37,9 @@ prepare() {
|
|||
# Fix crashes with GCC7 https://bugs.webkit.org/show_bug.cgi?id=173407
|
||||
cd qtwebkit-$_qtver
|
||||
patch -p1 -i ../qt5-webkit-gcc7.patch
|
||||
if [[ $CARCH == "arm" || $CARCH == "armv6h" ]]; then
|
||||
patch -p0 -i ../atomic.patch
|
||||
fi
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -47,7 +52,7 @@ build() {
|
|||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DPORT=Qt \
|
||||
-DENABLE_TOOLS=OFF \
|
||||
-DENABLE_OPENGL=OFF $CONFIG
|
||||
$CONFIG
|
||||
make
|
||||
}
|
||||
|
||||
|
|
10
extra/qt5-webkit/atomic.patch
Normal file
10
extra/qt5-webkit/atomic.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- Source/WebKit2/CMakeLists.txt.orig 2017-08-13 19:35:45.853721395 -0600
|
||||
+++ Source/WebKit2/CMakeLists.txt 2017-08-13 19:36:02.668686476 -0600
|
||||
@@ -734,6 +734,7 @@
|
||||
set(WebKit2_LIBRARIES
|
||||
JavaScriptCore
|
||||
WebCore
|
||||
+ atomic
|
||||
)
|
||||
|
||||
set(PluginProcess_LIBRARIES
|
Loading…
Reference in a new issue