community/nodejs: v6 fix

This commit is contained in:
Kevin Mihelich 2018-10-29 17:58:51 +00:00
parent a396a5341b
commit 83bd6a40b7
2 changed files with 15 additions and 1 deletions

View file

@ -26,7 +26,7 @@ optdepends=('npm: nodejs package manager')
source=("nodejs-$pkgver.tar.gz::https://github.com/nodejs/node/archive/v$pkgver.tar.gz"
'atomic.patch')
sha512sums=('1362f6e0a55b34b102149ac37b153d00e1aa42cb523daee23a7de272a10208982324ef07fffb8a2f71dab6ce41d7d184d2812b6a09e8570288e1682ee1d0404b'
'fa6d8a03f397b170353cdf2ca6578b5173d1cbc1f588e404e5aab1e34c05d99ad4fe2f1cf28cbbeb3bf8b7563960f37f9469c312484bdbe41c20d6fe05121c95')
'b1dd60c8f594fc07d66c0c77ea682555064cfd66a778e02d94b39be471ffc39ed9e57059e2f9e4dfc8434f0bd4cb958bce2e186e249aeeb179b854add5b4d9d6')
prepare() {
cd node-$pkgver

View file

@ -13,3 +13,17 @@
'sources': [
'src/async_wrap.cc',
'src/bootstrapper.cc',
--- deps/v8/gypfiles/v8.gyp.orig 2018-10-29 07:54:38.292831964 -0600
+++ deps/v8/gypfiles/v8.gyp 2018-10-29 07:56:38.192570653 -0600
@@ -483,6 +483,11 @@
'<(DEPTH)',
'<(SHARED_INTERMEDIATE_DIR)'
],
+ 'link_settings': {
+ 'libraries': [
+ '-latomic',
+ ],
+ },
'sources': [
'<@(inspector_all_sources)',
'../include//v8-inspector-protocol.h',