mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/gcc to 4.8.1-2
This commit is contained in:
parent
9fdbc6736a
commit
83f92169c4
2 changed files with 28 additions and 6 deletions
|
@ -16,8 +16,8 @@ noautobuild=1
|
|||
|
||||
pkgname=('gcc' 'gcc-libs' 'gcc-fortran' 'gcc-objc' 'gcc-go')
|
||||
pkgver=4.8.1
|
||||
pkgrel=1
|
||||
#_snapshot=4.8-20130502
|
||||
pkgrel=2
|
||||
_snapshot=4.8-20130725
|
||||
pkgdesc="The GNU Compiler Collection"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL' 'LGPL' 'FDL' 'custom')
|
||||
|
@ -25,11 +25,13 @@ url="http://gcc.gnu.org"
|
|||
makedepends=('binutils>=2.23' 'libmpc' 'cloog' 'doxygen')
|
||||
checkdepends=('dejagnu' 'inetutils')
|
||||
options=('!libtool' '!emptydirs' '!distcc')
|
||||
source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
|
||||
#ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
|
||||
armhf-triplet-trunk.diff)
|
||||
source=(#ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
|
||||
ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
|
||||
armhf-triplet-trunk.diff
|
||||
gcc-4.8-filename-output.patch)
|
||||
md5sums=('3b2386c114cd74185aa3754b58a79304'
|
||||
'bd7330bd41845929f1e0efb3b7d0a060')
|
||||
'bd7330bd41845929f1e0efb3b7d0a060'
|
||||
'40cb437805e2f7a006aa0d0c3098ab0f')
|
||||
|
||||
if [ -n "${_snapshot}" ]; then
|
||||
_basedir=gcc-${_snapshot}
|
||||
|
@ -48,6 +50,9 @@ prepare() {
|
|||
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
|
||||
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
|
||||
|
||||
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57653
|
||||
patch -p0 -i ${srcdir}/gcc-4.8-filename-output.patch
|
||||
|
||||
mkdir ${srcdir}/gcc-build
|
||||
}
|
||||
|
||||
|
|
17
core/gcc/gcc-4.8-filename-output.patch
Normal file
17
core/gcc/gcc-4.8-filename-output.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- gcc/c-family/c-opts.c (revision 200330)
|
||||
+++ gcc/c-family/c-opts.c (working copy)
|
||||
@@ -1338,10 +1338,14 @@ c_finish_options (void)
|
||||
|
||||
/* Give CPP the next file given by -include, if any. */
|
||||
static void
|
||||
push_command_line_include (void)
|
||||
{
|
||||
+ // This can happen if disabled by -imacros for example.
|
||||
+ if (include_cursor > deferred_count)
|
||||
+ return;
|
||||
+
|
||||
if (!done_preinclude)
|
||||
{
|
||||
done_preinclude = true;
|
||||
if (flag_hosted && std_inc && !cpp_opts->preprocessed)
|
||||
{
|
Loading…
Reference in a new issue