mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/mariadb to 10.1.17-1
This commit is contained in:
parent
f2f7ea484b
commit
84223845d7
2 changed files with 3 additions and 39 deletions
|
@ -1,30 +0,0 @@
|
|||
From 82691c53c7d84f79116b3f94cbe5fd7d7006d5e4 Mon Sep 17 00:00:00 2001
|
||||
From: Christian Hesse <mail@eworm.de>
|
||||
Date: Tue, 23 Aug 2016 09:43:14 +0200
|
||||
Subject: [PATCH 1/1] remove const qualifier and fix crash with wsrep
|
||||
initialization
|
||||
|
||||
Compiling MariaDB with GCC 6.x makes it crash in wsrep/galera
|
||||
initialization. This fixes the crash.
|
||||
|
||||
Signed-off-by: Christian Hesse <mail@eworm.de>
|
||||
---
|
||||
sql/wsrep_mysqld.cc | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/sql/wsrep_mysqld.cc b/sql/wsrep_mysqld.cc
|
||||
index 823a2a7..8760a11 100644
|
||||
--- a/sql/wsrep_mysqld.cc
|
||||
+++ b/sql/wsrep_mysqld.cc
|
||||
@@ -169,7 +169,7 @@ static PSI_file_info wsrep_files[]=
|
||||
|
||||
my_bool wsrep_inited = 0; // initialized ?
|
||||
|
||||
-static const wsrep_uuid_t cluster_uuid = WSREP_UUID_UNDEFINED;
|
||||
+static wsrep_uuid_t cluster_uuid = WSREP_UUID_UNDEFINED;
|
||||
static char cluster_uuid_str[40]= { 0, };
|
||||
static const char* cluster_status_str[WSREP_VIEW_MAX] =
|
||||
{
|
||||
--
|
||||
2.9.3
|
||||
|
|
@ -7,22 +7,20 @@
|
|||
|
||||
pkgbase=mariadb
|
||||
pkgname=('libmariadbclient' 'mariadb-clients' 'mytop' 'mariadb')
|
||||
pkgver=10.1.16
|
||||
pkgver=10.1.17
|
||||
_pkgver=${pkgver/.a/a}
|
||||
pkgrel=2
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL')
|
||||
url='http://mariadb.org/'
|
||||
makedepends=('cmake' 'zlib' 'libaio' 'libxml2' 'openssl' 'pcre' 'jemalloc'
|
||||
'lz4' 'boost' 'libevent' 'systemd')
|
||||
source=(http://ftp.heanet.ie/mirrors/mariadb/mariadb-$pkgver/source/mariadb-$pkgver.tar.gz{,.asc}
|
||||
0001-remove-const-qualifier-and-fix-crash-with-wsrep-init.patch
|
||||
mariadb-sysusers.conf
|
||||
mariadb-tmpfile.conf)
|
||||
validpgpkeys=('199369E5404BD5FC7D2FE43BCBCB082A1BB943DB') # MariaDB Package Signing Key <package-signing-key@mariadb.org>
|
||||
md5sums=('2a26b8d6560693cfc51031e76522cb78'
|
||||
md5sums=('036aca95257cb2948dd100605ec6d5a1'
|
||||
'SKIP'
|
||||
'e20903f4749af55fa4bf82f7d61be3b0'
|
||||
'97364065dd980909e04f97821a037ab0'
|
||||
'2fa6e456964d4ff5e6d4f9ff0126aed6')
|
||||
|
||||
|
@ -33,10 +31,6 @@ prepare() {
|
|||
sed -i -e '/^Alias/d' \
|
||||
-e '/^PrivateTmp/c PrivateTmp=true' \
|
||||
$pkgbase-$_pkgver/support-files/mariadb{,@}.service.in
|
||||
|
||||
cd $pkgbase-$_pkgver
|
||||
|
||||
patch -Np1 < "${srcdir}/0001-remove-const-qualifier-and-fix-crash-with-wsrep-init.patch"
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue