community/gdc to 6.2.1-1

This commit is contained in:
Kevin Mihelich 2016-12-27 01:08:57 +00:00
parent 8dba974f12
commit 842d26763f
4 changed files with 129 additions and 168 deletions

View file

@ -1,3 +1,4 @@
# $Id$
# Maintainer: Mihails Strasuns <public@dicebot.lv>
# Contributor: Moritz Maxeiner <moritz@ucworks.org>
# Contributor: Jerome Berger <jeberger@free.fr>
@ -7,96 +8,106 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - use GitHub gcc mirror commit archive (order of magnitude size difference)
# - --disable-libmpx
# - specified build host
# - make -j 4
# ALARM: Johannes Pfau <johannespfau@gmail.com>
# - specifid build host
# - replaced bugurl with our GitHub issue page
pkgname=('gdc' 'libgphobos-devel')
pkgver=6.1.1
pkgname=('gdc' 'libgphobos-devel' 'libgphobos')
pkgver=6.2.1
pkgrel=1
_pkgver=6
_islver=0.16.1
_commit=80f78834
_gcc_commit=c2103c1
arch=('i686' 'x86_64')
license=('GPL')
url="https://github.com/D-Programming-GDC/GDC"
makedepends=('binutils>=2.26' 'git' 'gcc' 'make' 'perl' 'automake')
options=('!emptydirs' '!buildflags')
groups=('dlang' 'dlang-gdc')
conflicts=('gdc1-bin' 'gdc1-hg' 'gdc-git')
makedepends=('binutils>=2.26' 'git')
source=(
https://github.com/gcc-mirror/gcc/archive/${_commit}.tar.gz
http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
gdc::git://github.com/D-Programming-GDC/GDC.git#commit=73a7fb5d4e75c0e1a4ee7cdb67d080cceb8ff955
https://github.com/gcc-mirror/gcc/archive/${_gcc_commit}.tar.gz
http://isl.gforge.inria.fr/isl-$_islver.tar.bz2
gdc::git://github.com/D-Programming-GDC/GDC.git#tag=v2.068.2_gcc6
git+https://github.com/D-Programming-GDC/GDMD.git
folders.diff
system_zlib.diff
paths.diff
)
sha256sums=('aaefafea139d07e802214fb37b5aec2ae96baf323b528b4f4b84294629e4a874'
sha256sums=('fef2f7ae26641cad4819f8664b03e71060905c337117ec3b703ab72f857a1026'
'412538bb65c799ac98e17e8cfcdacbb257a57362acfaaff254b0fcae970126d2'
'SKIP'
'SKIP'
'ea5c80a28026393bd4627485602660a4a01d9fbc65299e95e768013e197bad20'
'3c818788b5435794c37e5d3d131fe74c813368a3b7260f85fb2cd725308e4889')
'e04cea391007ebab5d9b0ff33179c1fded0afcf43059b811290472ea52222361')
# gcc-6.0 forces a changed triplet - need to address in pacman/devtools
[[ $CARCH == "x86_64" ]] && CHOST=x86_64-pc-linux-gnu
_libdir="usr/lib/gcc/$CHOST/$pkgver"
prepare() {
mv gcc-${_commit}* gcc
cd ${srcdir}/gcc
mv gcc-${_commit}* gcc
cd $srcdir/gcc
# link isl for in-tree build
ln -sf ../isl-${_islver} isl
# link isl for in-tree build
ln -s ../isl-$_islver isl
# Do not run fixincludes
sed -i 's@\./fixinc\.sh@-c true@' gcc/Makefile.in
# Do not run fixincludes
sed -i 's@\./fixinc\.sh@-c true@' gcc/Makefile.in
# Arch Linux installs x86_64 libraries /lib
[[ $CARCH == "x86_64" ]] && sed -i '/m64=/s/lib64/lib/' gcc/config/i386/t-linux64
# Arch Linux installs x86_64 libraries /lib
[[ $CARCH == "x86_64" ]] && sed -i '/m64=/s/lib64/lib/' gcc/config/i386/t-linux64
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
# Arch Linux ARM installs aarch64 libraries /lib
[[ $CARCH == "aarch64" ]] && sed -i '/lp64=/s/lib64/lib/' gcc/config/aarch64/t-aarch64-linux
cd $srcdir/gdc
git apply $srcdir/folders.diff # fix gdc_include_path
git apply $srcdir/system_zlib.diff # use correct system zlib
./setup-gcc.sh ../gcc
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
mkdir ${srcdir}/gcc-build
# GDC setup
cd $srcdir/gdc
git apply $srcdir/paths.diff
./setup-gcc.sh ../gcc
mkdir $srcdir/gcc-build
}
build() {
cd ${srcdir}/gcc-build
cd $srcdir/gcc-build
# ALARM: Specify build host types
[[ $CARCH == "arm" ]] && CONFIGFLAG="--host=armv5tel-unknown-linux-gnueabi --build=armv5tel-unknown-linux-gnueabi"
[[ $CARCH == "armv6h" ]] && CONFIGFLAG="--host=armv6l-unknown-linux-gnueabihf --build=armv6l-unknown-linux-gnueabihf --with-arch=armv6 --with-float=hard --with-fpu=vfp"
[[ $CARCH == "armv7h" ]] && CONFIGFLAG="--host=armv7l-unknown-linux-gnueabihf --build=armv7l-unknown-linux-gnueabihf --with-arch=armv7-a --with-float=hard --with-fpu=vfpv3-d16"
[[ $CARCH == "aarch64" ]] && CONFIGFLAG="--host=aarch64-unknown-linux-gnu --build=aarch64-unknown-linux-gnu --with-arch=armv8-a"
# ALARM: Specify build host types, triplet patch
[[ $CARCH == "arm" ]] && CONFIGFLAG="--host=armv5tel-unknown-linux-gnueabi --build=armv5tel-unknown-linux-gnueabi --with-arch=armv5te --with-float=soft"
[[ $CARCH == "armv6h" ]] && CONFIGFLAG="--host=armv6l-unknown-linux-gnueabihf --build=armv6l-unknown-linux-gnueabihf --with-arch=armv6 --with-float=hard --with-fpu=vfp"
[[ $CARCH == "armv7h" ]] && CONFIGFLAG="--host=armv7l-unknown-linux-gnueabihf --build=armv7l-unknown-linux-gnueabihf --with-arch=armv7-a --with-float=hard --with-fpu=vfpv3-d16"
[[ $CARCH == "aarch64" ]] && CONFIGFLAG="--host=aarch64-unknown-linux-gnu --build=aarch64-unknown-linux-gnu --with-arch=armv8-a"
# using -pipe causes spurious test-suite failures
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=48565
CFLAGS=${CFLAGS/-pipe/}
CXXFLAGS=${CXXFLAGS/-pipe/}
# using -pipe causes spurious test-suite failures
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=48565
CFLAGS=${CFLAGS/-pipe/}
CXXFLAGS=${CXXFLAGS/-pipe/}
${srcdir}/gcc/configure --prefix=/usr \
--libdir=/usr/lib --libexecdir=/usr/lib \
--mandir=/usr/share/man --infodir=/usr/share/info \
--with-bugurl=https://archlinuxarm.org/forum \
--enable-languages=d \
--enable-shared --enable-threads=posix --disable-libmpx \
--with-system-zlib --with-isl --enable-__cxa_atexit \
--disable-libunwind-exceptions --enable-clocale=gnu \
--disable-libstdcxx-pch --disable-libssp \
--enable-gnu-unique-object --enable-linker-build-id \
--enable-lto --enable-plugin --enable-install-libiberty \
--with-linker-hash-style=gnu --enable-gnu-indirect-function \
--disable-multilib --disable-werror \
--enable-checking=release $CONFIGFLAG
$srcdir/gcc/configure --prefix=/usr \
--libdir=/usr/lib \
--libexecdir=/usr/lib \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--with-bugurl=https://archlinuxarm.org/forum \
--enable-shared \
--enable-static \
--enable-threads=posix \
--disable-libmpx \
--with-system-zlib \
--with-isl \
--enable-__cxa_atexit \
--disable-libunwind-exceptions \
--enable-clocale=gnu \
--disable-libstdcxx-pch \
--disable-libssp \
--enable-gnu-unique-object \
--enable-linker-build-id \
--enable-lto \
--enable-plugin \
--enable-install-libiberty \
--with-linker-hash-style=gnu \
--enable-gnu-indirect-function \
--enable-default-pie \
--disable-multilib \
--disable-werror \
--enable-languages=d \
gdc_include_dir=/usr/include/dlang/gdc $CONFIGFLAG
make -j 4
make -j 4
}
package_gdc()
@ -104,7 +115,8 @@ package_gdc()
depends=('gcc' 'perl' 'binutils' 'libgphobos-devel')
provides=("d-compiler")
pkgdesc="Compiler for D programming language which uses gcc backend"
# compiler
install -D -m755 $srcdir/gcc-build/gcc/gdc $pkgdir/usr/bin/gdc
install -D -m755 $srcdir/gcc-build/gcc/cc1d $pkgdir/usr/lib/gcc/$CHOST/$pkgver/cc1d
@ -113,28 +125,26 @@ package_gdc()
install -D -m644 $srcdir/GDMD/dmd-script.1 $pkgdir/usr/share/man/man1/gdmd.1
}
package_libgphobos-devel()
{
pkgdesc="Standard library for D programming language, GDC port"
provides=("d-runtime" "d-stdlib")
options=("staticlibs")
# druntime
install -D $srcdir/gdc/libphobos/libdruntime/object.d $pkgdir/usr/include/dlang/gdc/object.d
install -D $srcdir/gdc/libphobos/libdruntime/__entrypoint.di ${pkgdir}/usr/include/dlang/gdc/__entrypoint.di
cp -r $srcdir/gdc/libphobos/libdruntime/core $pkgdir/usr/include/dlang/gdc/core
cp -r $srcdir/gdc/libphobos/libdruntime/gcc $pkgdir/usr/include/dlang/gdc/gcc
cd $srcdir/gcc-build
make -C $CHOST/libphobos DESTDIR=$pkgdir install
# workaround for auto-generated libbacktrace issue
# script needs to be re-written to first call normal gcc instalaltion targets to
# avoid such problems in future
cp $srcdir/gcc-build/$CHOST/libphobos/libdruntime/gcc/libbacktrace.d $pkgdir/usr/include/dlang/gdc/gcc/
rm $pkgdir/usr/include/dlang/gdc/gcc/libbacktrace.d.in
# phobos
# cp $srcdir/gdc/libphobos/src/crc32.d ${pkgdir}/usr/include/dlang/gdc/
cp -r $srcdir/gdc/libphobos/src/std ${pkgdir}/usr/include/dlang/gdc/std
cp -r $srcdir/gdc/libphobos/src/etc ${pkgdir}/usr/include/dlang/gdc/etc
install -D -m644 $srcdir/gcc-build/$CHOST/libphobos/src/libgphobos2.a $pkgdir/usr/lib/libgphobos2.a
# remove shared library bits, they go into own package
rm $pkgdir/usr/lib/lib*so*
}
package_libgphobos()
{
pkgdesc="Shared standard library for D programming language, GDC port"
provides=("d-runtime" "d-stdlib")
cd $srcdir/gcc-build
install -D -m644 $CHOST/libphobos/src/.libs/libgphobos.so $pkgdir/usr/lib/libgphobos.so
install -D -m644 $CHOST/libphobos/libdruntime/.libs/libgdruntime.so $pkgdir/usr/lib/libgdruntime.so
}

View file

@ -1,39 +0,0 @@
diff --git a/gcc/d/d-incpath.cc b/gcc/d/d-incpath.cc
index e04ddc6..168a033 100644
--- a/gcc/d/d-incpath.cc
+++ b/gcc/d/d-incpath.cc
@@ -202,7 +202,7 @@ add_import_paths(const char *iprefix, const char *imultilib, bool stdinc)
import_path = xstrdup(p->fname);
// Add D-specific suffix.
- import_path = concat(import_path, "/d", NULL);
+ import_path = concat(import_path, "/dlang/gdc", NULL);
// Ignore duplicate entries.
bool found = false;
diff --git a/libphobos/configure b/libphobos/configure
index 2ff7114..f7f0660 100755
--- a/libphobos/configure
+++ b/libphobos/configure
@@ -3883,7 +3883,7 @@ fi
# Default case for install directory for D sources files.
-gdc_include_dir='${libdir}/gcc/${target_alias}'/${d_gcc_ver}/include/d
+gdc_include_dir=${prefix}/include/dlang/gdc
# Sanity check for the cross-compilation case:
diff --git a/libphobos/configure.ac b/libphobos/configure.ac
index 84492dd..947f6a8 100644
--- a/libphobos/configure.ac
+++ b/libphobos/configure.ac
@@ -167,7 +167,7 @@ AC_SUBST(phobos_toolexecdir)
AC_SUBST(phobos_toolexeclibdir)
# Default case for install directory for D sources files.
-gdc_include_dir='${libdir}/gcc/${target_alias}'/${d_gcc_ver}/include/d
+gdc_include_dir=${prefix}/include/dlang/gdc
AC_SUBST(gdc_include_dir)
dnl Checks for header files.

39
community/gdc/paths.diff Normal file
View file

@ -0,0 +1,39 @@
diff --git a/gcc/d/d-incpath.cc b/gcc/d/d-incpath.cc
index 995ff792..3e06bc0a 100644
--- a/gcc/d/d-incpath.cc
+++ b/gcc/d/d-incpath.cc
@@ -206,7 +206,7 @@ add_import_paths(const char *iprefix, const char *imultilib, bool stdinc)
import_path = xstrdup(p->fname);
// Add D-specific suffix.
- import_path = concat(import_path, "/d", NULL);
+ import_path = concat(import_path, "/dlang/gdc", NULL);
// Ignore duplicate entries.
bool found = false;
diff --git a/libphobos/configure b/libphobos/configure
index 7325fcbf..a75286c8 100755
--- a/libphobos/configure
+++ b/libphobos/configure
@@ -14658,7 +14658,7 @@ fi
# Default case for install directory for D sources files.
- gdc_include_dir='${libdir}/gcc/${target_alias}'/${d_gcc_ver}/include/d
+ gdc_include_dir='/usr/include/dlang/gdc/'
diff --git a/libphobos/m4/druntime.m4 b/libphobos/m4/druntime.m4
index fac44aac..6ff6b2c7 100644
--- a/libphobos/m4/druntime.m4
+++ b/libphobos/m4/druntime.m4
@@ -78,7 +78,7 @@ AC_DEFUN([DRUNTIME_INSTALL_DIRECTORIES],
AC_SUBST(toolexeclibdir)
# Default case for install directory for D sources files.
- gdc_include_dir='${libdir}/gcc/${target_alias}'/${d_gcc_ver}/include/d
+ gdc_include_dir='/usr/include/dlang/gdc/'
AC_SUBST(gdc_include_dir)
])

View file

@ -1,49 +0,0 @@
diff --git a/gcc/d/d-spec.c b/gcc/d/d-spec.c
index d45c648..9010edb 100644
--- a/gcc/d/d-spec.c
+++ b/gcc/d/d-spec.c
@@ -96,7 +96,7 @@ lang_specific_driver (cl_decoded_option **in_decoded_options,
/* The number of arguments being added to what's in argv, other than
libraries. We use this to track the number of times we've inserted
-xd/-xnone. */
- int added = 0;
+ int added = 1; /* -lz */
/* The new argument list will be contained in this. */
cl_decoded_option *new_decoded_options;
@@ -468,6 +468,14 @@ lang_specific_driver (cl_decoded_option **in_decoded_options,
j++;
}
+ /* Use the up-to-date system zlib with libphobos */
+ {
+ generate_option (OPT_l, "z", 1, CL_DRIVER,
+ &new_decoded_options[j]);
+ added_libraries++;
+ j++;
+ }
+
/* Add `-lgphobos' if we haven't already done so. */
if (library > 0 && phobos)
{
diff --git a/libphobos/src/Makefile.in b/libphobos/src/Makefile.in
index 6597116..f0f42e3 100644
--- a/libphobos/src/Makefile.in
+++ b/libphobos/src/Makefile.in
@@ -151,7 +151,6 @@ SHELL = @SHELL@
STRIP = @STRIP@
VERSION = @VERSION@
WERROR = @WERROR@
-ZLIB_OBJS = @ZLIB_OBJS@
abs_builddir = @abs_builddir@
abs_srcdir = @abs_srcdir@
abs_top_builddir = @abs_top_builddir@
@@ -283,7 +282,7 @@ WINDOWS_OBJS = std/c/windows/com.o std/c/windows/stat.o std/c/wcharh.o \
std/windows/charset.o std/windows/iunknown.o std/windows/registry.o \
std/windows/syserror.o std/internal/windows/advapi32.o
-ALL_PHOBOS_OBJS = $(D_EXTRA_OBJS) $(MAIN_OBJS) $(ZLIB_OBJS)
+ALL_PHOBOS_OBJS = $(D_EXTRA_OBJS) $(MAIN_OBJS)
# Work around what appears to be a GNU make bug handling MAKEFLAGS
# values defined in terms of make variables, as is the case for CC and