mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
alarm/vlc-rpi to 3.0.18-1
This commit is contained in:
parent
e581353ba6
commit
84468925ae
10 changed files with 131 additions and 189 deletions
12
alarm/vlc-rpi/0001-vlc-live-media-2021.patch
Normal file
12
alarm/vlc-rpi/0001-vlc-live-media-2021.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -ru vlc-3.0.13.orig/configure.ac vlc-3.0.13/configure.ac
|
||||
--- vlc-3.0.13.orig/configure.ac 2021-04-27 15:18:39.000000000 +0200
|
||||
+++ vlc-3.0.13/configure.ac 2021-05-03 16:26:26.691200904 +0200
|
||||
@@ -1825,7 +1825,7 @@
|
||||
AC_MSG_ERROR([Update live555 or pass --disable-live555 to disable RTSP input support.])
|
||||
])
|
||||
], [
|
||||
- other_libs="-lgroupsock -lBasicUsageEnvironment -lUsageEnvironment"
|
||||
+ other_libs="-lcrypto -lssl -lgroupsock -lBasicUsageEnvironment -lUsageEnvironment"
|
||||
other_libs_pic="-lgroupsock_pic -lBasicUsageEnvironment_pic -lUsageEnvironment_pic"
|
||||
AS_IF([test "${SYS}" = "mingw32"], [
|
||||
# add ws2_32 for closesocket, select, recv
|
|
@ -1,130 +0,0 @@
|
|||
From 900318072a7ebce28745aa3863e1364b7258baff Mon Sep 17 00:00:00 2001
|
||||
From: Alexandre Janniaux <ajanni@videolabs.io>
|
||||
Date: Wed, 10 Nov 2021 15:37:52 +0100
|
||||
Subject: [PATCH] caca: fix to newer version
|
||||
|
||||
Migrate to the new API instead of libcucul API, which has been merged
|
||||
into libcaca since 0.99.beta15:
|
||||
|
||||
commit f61816ceb7445f8bf818936151554ac060764b39
|
||||
Author: Sam Hocevar <sam@hocevar.net>
|
||||
Date: Sat Sep 27 13:12:46 2008 +0000
|
||||
|
||||
Starting refactoring to get rid of libcucul. The initial reason for the
|
||||
split is rendered moot by the plugin system: when enabled, binaries do
|
||||
not link directly with libX11 or libGL. I hope this is a step towards
|
||||
more consisteny and clarity.
|
||||
|
||||
It was then completely wiped out by the following commit, which is part
|
||||
of v0.99.beta20:
|
||||
|
||||
commit 5f0ec215f8c9915ed028324a8ecac8212f68e18d
|
||||
Author: Sam Hocevar <sam@hocevar.net>
|
||||
Date: Thu May 3 10:33:30 2018 +0200
|
||||
|
||||
Remove legacy code from 10 years ago.
|
||||
|
||||
(cherry picked from commit d35391caa03c046149e7fe2497f51bf59ed8551d)
|
||||
---
|
||||
modules/video_output/caca.c | 30 +++++++++++++++---------------
|
||||
1 file changed, 15 insertions(+), 15 deletions(-)
|
||||
|
||||
diff --git a/modules/video_output/caca.c b/modules/video_output/caca.c
|
||||
index 33a0409820..a2e922a864 100644
|
||||
--- a/modules/video_output/caca.c
|
||||
+++ b/modules/video_output/caca.c
|
||||
@@ -74,9 +74,9 @@ static void Place(vout_display_t *, vout_display_place_t *);
|
||||
|
||||
/* */
|
||||
struct vout_display_sys_t {
|
||||
- cucul_canvas_t *cv;
|
||||
+ caca_canvas_t *cv;
|
||||
caca_display_t *dp;
|
||||
- cucul_dither_t *dither;
|
||||
+ caca_dither_t *dither;
|
||||
|
||||
picture_pool_t *pool;
|
||||
vout_display_event_thread_t *et;
|
||||
@@ -153,9 +153,9 @@ static int Open(vlc_object_t *object)
|
||||
if (!sys)
|
||||
goto error;
|
||||
|
||||
- sys->cv = cucul_create_canvas(0, 0);
|
||||
+ sys->cv = caca_create_canvas(0, 0);
|
||||
if (!sys->cv) {
|
||||
- msg_Err(vd, "cannot initialize libcucul");
|
||||
+ msg_Err(vd, "cannot initialize libcaca");
|
||||
goto error;
|
||||
}
|
||||
|
||||
@@ -209,11 +209,11 @@ error:
|
||||
if (sys->pool)
|
||||
picture_pool_Release(sys->pool);
|
||||
if (sys->dither)
|
||||
- cucul_free_dither(sys->dither);
|
||||
+ caca_free_dither(sys->dither);
|
||||
if (sys->dp)
|
||||
caca_free_display(sys->dp);
|
||||
if (sys->cv)
|
||||
- cucul_free_canvas(sys->cv);
|
||||
+ caca_free_canvas(sys->cv);
|
||||
|
||||
free(sys);
|
||||
}
|
||||
@@ -235,9 +235,9 @@ static void Close(vlc_object_t *object)
|
||||
if (sys->pool)
|
||||
picture_pool_Release(sys->pool);
|
||||
if (sys->dither)
|
||||
- cucul_free_dither(sys->dither);
|
||||
+ caca_free_dither(sys->dither);
|
||||
caca_free_display(sys->dp);
|
||||
- cucul_free_canvas(sys->cv);
|
||||
+ caca_free_canvas(sys->cv);
|
||||
|
||||
#if defined(_WIN32)
|
||||
FreeConsole();
|
||||
@@ -266,7 +266,7 @@ static void Prepare(vout_display_t *vd, picture_t *picture, subpicture_t *subpic
|
||||
|
||||
if (!sys->dither) {
|
||||
/* Create the libcaca dither object */
|
||||
- sys->dither = cucul_create_dither(32,
|
||||
+ sys->dither = caca_create_dither(32,
|
||||
vd->source.i_visible_width,
|
||||
vd->source.i_visible_height,
|
||||
picture->p[0].i_pitch,
|
||||
@@ -284,12 +284,12 @@ static void Prepare(vout_display_t *vd, picture_t *picture, subpicture_t *subpic
|
||||
vout_display_place_t place;
|
||||
Place(vd, &place);
|
||||
|
||||
- cucul_set_color_ansi(sys->cv, CUCUL_COLOR_DEFAULT, CUCUL_COLOR_BLACK);
|
||||
- cucul_clear_canvas(sys->cv);
|
||||
+ caca_set_color_ansi(sys->cv, CACA_DEFAULT, CACA_BLACK);
|
||||
+ caca_clear_canvas(sys->cv);
|
||||
|
||||
const int crop_offset = vd->source.i_y_offset * picture->p->i_pitch +
|
||||
vd->source.i_x_offset * picture->p->i_pixel_pitch;
|
||||
- cucul_dither_bitmap(sys->cv, place.x, place.y,
|
||||
+ caca_dither_bitmap(sys->cv, place.x, place.y,
|
||||
place.width, place.height,
|
||||
sys->dither,
|
||||
&picture->p->p_pixels[crop_offset]);
|
||||
@@ -328,7 +328,7 @@ static int Control(vout_display_t *vd, int query, va_list args)
|
||||
|
||||
case VOUT_DISPLAY_CHANGE_SOURCE_CROP:
|
||||
if (sys->dither)
|
||||
- cucul_free_dither(sys->dither);
|
||||
+ caca_free_dither(sys->dither);
|
||||
sys->dither = NULL;
|
||||
return VLC_SUCCESS;
|
||||
|
||||
@@ -366,8 +366,8 @@ static void Place(vout_display_t *vd, vout_display_place_t *place)
|
||||
|
||||
vout_display_PlacePicture(place, &vd->source, vd->cfg, false);
|
||||
|
||||
- const int canvas_width = cucul_get_canvas_width(sys->cv);
|
||||
- const int canvas_height = cucul_get_canvas_height(sys->cv);
|
||||
+ const int canvas_width = caca_get_canvas_width(sys->cv);
|
||||
+ const int canvas_height = caca_get_canvas_height(sys->cv);
|
||||
const int display_width = caca_get_display_width(sys->dp);
|
||||
const int display_height = caca_get_display_height(sys->dp);
|
||||
|
108
alarm/vlc-rpi/0002-libplacebo-5.patch
Normal file
108
alarm/vlc-rpi/0002-libplacebo-5.patch
Normal file
|
@ -0,0 +1,108 @@
|
|||
patch vaguely ported from: https://code.videolan.org/videolan/vlc/-/merge_requests/2233
|
||||
|
||||
diff --git a/modules/video_output/opengl/converter.h b/modules/video_output/opengl/converter.h
|
||||
index 7000e1f..49fa667 100644
|
||||
--- a/modules/video_output/opengl/converter.h
|
||||
+++ b/modules/video_output/opengl/converter.h
|
||||
@@ -26,6 +26,9 @@
|
||||
#include <vlc_picture_pool.h>
|
||||
#include <vlc_opengl.h>
|
||||
|
||||
+#include <libplacebo/log.h>
|
||||
+#include <libplacebo/shaders.h>
|
||||
+
|
||||
/* if USE_OPENGL_ES2 is defined, OpenGL ES version 2 will be used, otherwise
|
||||
* normal OpenGL will be used */
|
||||
#ifdef __APPLE__
|
||||
@@ -253,10 +256,6 @@ static inline bool HasExtension(const char *apis, const char *api)
|
||||
return false;
|
||||
}
|
||||
|
||||
-struct pl_context;
|
||||
-struct pl_shader;
|
||||
-struct pl_shader_res;
|
||||
-
|
||||
/*
|
||||
* Structure that is filled by "glhw converter" module probe function
|
||||
* The implementation should initialize every members of the struct that are
|
||||
@@ -273,7 +272,7 @@ struct opengl_tex_converter_t
|
||||
vlc_gl_t *gl;
|
||||
|
||||
/* libplacebo context, created by the caller (optional) */
|
||||
- struct pl_context *pl_ctx;
|
||||
+ pl_log pl_log;
|
||||
|
||||
/* Function pointers to OpenGL functions, set by the caller */
|
||||
const opengl_vtable_t *vt;
|
||||
@@ -337,7 +336,7 @@ struct opengl_tex_converter_t
|
||||
bool yuv_color;
|
||||
GLfloat yuv_coefficients[16];
|
||||
|
||||
- struct pl_shader *pl_sh;
|
||||
+ pl_shader pl_sh;
|
||||
const struct pl_shader_res *pl_sh_res;
|
||||
|
||||
/* Private context */
|
||||
diff --git a/modules/video_output/opengl/fragment_shaders.c b/modules/video_output/opengl/fragment_shaders.c
|
||||
index ecf7226..29f4148 100644
|
||||
--- a/modules/video_output/opengl/fragment_shaders.c
|
||||
+++ b/modules/video_output/opengl/fragment_shaders.c
|
||||
@@ -611,7 +611,7 @@ opengl_fragment_shader_init_impl(opengl_tex_converter_t *tc, GLenum tex_target,
|
||||
|
||||
#ifdef HAVE_LIBPLACEBO
|
||||
if (tc->pl_sh) {
|
||||
- struct pl_shader *sh = tc->pl_sh;
|
||||
+ pl_shader sh = tc->pl_sh;
|
||||
struct pl_color_map_params color_params = pl_color_map_default_params;
|
||||
color_params.intent = var_InheritInteger(tc->gl, "rendering-intent");
|
||||
color_params.tone_mapping_algo = var_InheritInteger(tc->gl, "tone-mapping");
|
||||
@@ -634,7 +634,7 @@ opengl_fragment_shader_init_impl(opengl_tex_converter_t *tc, GLenum tex_target,
|
||||
pl_color_space_from_video_format(&tc->fmt),
|
||||
dst_space, NULL, false);
|
||||
|
||||
- struct pl_shader_obj *dither_state = NULL;
|
||||
+ pl_shader_obj dither_state = NULL;
|
||||
int method = var_InheritInteger(tc->gl, "dither-algo");
|
||||
if (method >= 0) {
|
||||
|
||||
diff --git a/modules/video_output/opengl/vout_helper.c b/modules/video_output/opengl/vout_helper.c
|
||||
index 13d65e0..1ee99af 100644
|
||||
--- a/modules/video_output/opengl/vout_helper.c
|
||||
+++ b/modules/video_output/opengl/vout_helper.c
|
||||
@@ -570,8 +570,7 @@ opengl_deinit_program(vout_display_opengl_t *vgl, struct prgm *prgm)
|
||||
|
||||
#ifdef HAVE_LIBPLACEBO
|
||||
FREENULL(tc->uloc.pl_vars);
|
||||
- if (tc->pl_ctx)
|
||||
- pl_context_destroy(&tc->pl_ctx);
|
||||
+ pl_log_destroy(&tc->pl_log);
|
||||
#endif
|
||||
|
||||
vlc_object_release(tc);
|
||||
@@ -622,21 +621,21 @@ opengl_init_program(vout_display_opengl_t *vgl, struct prgm *prgm,
|
||||
// create the main libplacebo context
|
||||
if (!subpics)
|
||||
{
|
||||
- tc->pl_ctx = pl_context_create(PL_API_VER, &(struct pl_context_params) {
|
||||
+ tc->pl_log = pl_log_create(PL_API_VER, &(struct pl_log_params) {
|
||||
.log_cb = log_cb,
|
||||
.log_priv = tc,
|
||||
.log_level = PL_LOG_INFO,
|
||||
});
|
||||
- if (tc->pl_ctx) {
|
||||
+ if (tc->pl_log) {
|
||||
# if PL_API_VER >= 20
|
||||
- tc->pl_sh = pl_shader_alloc(tc->pl_ctx, &(struct pl_shader_params) {
|
||||
+ tc->pl_sh = pl_shader_alloc(tc->pl_log, &(struct pl_shader_params) {
|
||||
.glsl.version = tc->glsl_version,
|
||||
.glsl.gles = tc->is_gles,
|
||||
});
|
||||
# elif PL_API_VER >= 6
|
||||
- tc->pl_sh = pl_shader_alloc(tc->pl_ctx, NULL, 0);
|
||||
+ tc->pl_sh = pl_shader_alloc(tc->pl_log, NULL, 0);
|
||||
# else
|
||||
- tc->pl_sh = pl_shader_alloc(tc->pl_ctx, NULL, 0, 0);
|
||||
+ tc->pl_sh = pl_shader_alloc(tc->pl_log, NULL, 0, 0);
|
||||
# endif
|
||||
}
|
||||
}
|
|
@ -1,26 +0,0 @@
|
|||
diff -ru vlc-3.0.13.orig/configure.ac vlc-3.0.13/configure.ac
|
||||
--- vlc-3.0.13.orig/configure.ac 2021-04-27 15:18:39.000000000 +0200
|
||||
+++ vlc-3.0.13/configure.ac 2021-05-03 16:26:26.691200904 +0200
|
||||
@@ -1825,7 +1825,7 @@
|
||||
AC_MSG_ERROR([Update live555 or pass --disable-live555 to disable RTSP input support.])
|
||||
])
|
||||
], [
|
||||
- other_libs="-lgroupsock -lBasicUsageEnvironment -lUsageEnvironment"
|
||||
+ other_libs="-lcrypto -lssl -lgroupsock -lBasicUsageEnvironment -lUsageEnvironment"
|
||||
other_libs_pic="-lgroupsock_pic -lBasicUsageEnvironment_pic -lUsageEnvironment_pic"
|
||||
AS_IF([test "${SYS}" = "mingw32"], [
|
||||
# add ws2_32 for closesocket, select, recv
|
||||
diff -ru vlc-3.0.13.orig/modules/access/live555.cpp vlc-3.0.13/modules/access/live555.cpp
|
||||
--- vlc-3.0.13.orig/modules/access/live555.cpp 2019-03-29 20:01:15.000000000 +0100
|
||||
+++ vlc-3.0.13/modules/access/live555.cpp 2021-05-03 16:04:38.030121796 +0200
|
||||
@@ -852,7 +852,9 @@
|
||||
if( !p_sys->b_multicast )
|
||||
{
|
||||
/* We need different rollover behaviour for multicast */
|
||||
- p_sys->b_multicast = IsMulticastAddress( sub->connectionEndpointAddress() );
|
||||
+ struct sockaddr_storage tempAddr;
|
||||
+ sub->getConnectionEndpointAddress(tempAddr);
|
||||
+ p_sys->b_multicast = IsMulticastAddress( tempAddr );
|
||||
}
|
||||
|
||||
tk = (live_track_t*)malloc( sizeof( live_track_t ) );
|
|
@ -1,18 +0,0 @@
|
|||
Description: Add extern to three functions for gcc-10 compatibility.
|
||||
Author: Peter Michael Green <plugwash@raspbian.org>
|
||||
|
||||
--- a/modules/codec/omxil/omxil_core.h
|
||||
+++ b/modules/codec/omxil/omxil_core.h
|
||||
@@ -34,9 +34,9 @@ extern OMX_ERRORTYPE (*pf_component_enum
|
||||
extern OMX_ERRORTYPE (*pf_get_roles_of_component)(OMX_STRING, OMX_U32 *, OMX_U8 **);
|
||||
|
||||
/* Extra IOMX android functions. Can be NULL if we don't link with libiomx */
|
||||
-OMX_ERRORTYPE (*pf_enable_graphic_buffers)(OMX_HANDLETYPE, OMX_U32, OMX_BOOL);
|
||||
-OMX_ERRORTYPE (*pf_get_graphic_buffer_usage)(OMX_HANDLETYPE, OMX_U32, OMX_U32*);
|
||||
-OMX_ERRORTYPE (*pf_get_hal_format) (const char *, int *);
|
||||
+extern OMX_ERRORTYPE (*pf_enable_graphic_buffers)(OMX_HANDLETYPE, OMX_U32, OMX_BOOL);
|
||||
+extern OMX_ERRORTYPE (*pf_get_graphic_buffer_usage)(OMX_HANDLETYPE, OMX_U32, OMX_U32*);
|
||||
+extern OMX_ERRORTYPE (*pf_get_hal_format) (const char *, int *);
|
||||
|
||||
int InitOmxCore(vlc_object_t *p_this);
|
||||
void DeinitOmxCore(void);
|
|
@ -6,12 +6,12 @@
|
|||
|
||||
pkgname=vlc-rpi
|
||||
_pkgname=vlc
|
||||
_vlcver=3.0.17.4
|
||||
_vlcver=3.0.18
|
||||
# optional fixup version including hyphen
|
||||
_vlcfixupver=
|
||||
_commit=b6a28bbbec2b56851085178016c300724d66b41b
|
||||
pkgver=${_vlcver}${_vlcfixupver//-/.r}
|
||||
pkgrel=2
|
||||
pkgrel=1
|
||||
pkgdesc='Multi-platform MPEG, VCD/DVD, and DivX player with hw accel for RPi 3/4/400'
|
||||
url='https://www.videolan.org/vlc/'
|
||||
arch=(aarch64)
|
||||
|
@ -109,25 +109,21 @@ install='vlc.install'
|
|||
source=(https://download.videolan.org/${_pkgname}/${_vlcver}/${_pkgname}-${_vlcver}${_vlcfixupver}.tar.xz{,.asc}
|
||||
99-vlc.rules
|
||||
vlc.config.txt
|
||||
0001-vlc-dav1d-1.0.patch::https://github.com/videolan/vlc/commit/2202c892c8dc.patch
|
||||
0002-caca-fix-to-newer-version.patch
|
||||
0003-vlc-live-media-2021.patch
|
||||
0001-vlc-live-media-2021.patch
|
||||
0002-libplacebo-5.patch
|
||||
# credit to RPi-Distro maintainers for this work
|
||||
# https://github.com/RPi-Distro/vlc/tree/bullseye-rpt/debian/patches
|
||||
0004-add-extern-qualifiers.patch
|
||||
0005-mmal_29.patch
|
||||
0006-mmal_caca.patch
|
||||
0007-mmal_chain.patch
|
||||
0008-mmal_exit_fix.patch
|
||||
0003-mmal_29.patch
|
||||
0004-mmal_caca.patch
|
||||
0005-mmal_chain.patch
|
||||
0006-mmal_exit_fix.patch
|
||||
update-vlc-plugin-cache.hook)
|
||||
sha256sums=('8c5a62d88a4fb45c1b095cf10befef217dfa87aedcec5184b9e7d590b6dd4133'
|
||||
sha256sums=('57094439c365d8aa8b9b41fa3080cc0eef2befe6025bb5cef722accc625aedec'
|
||||
'SKIP'
|
||||
'61125ab0da600d813f1aebd8445fcf03e176389cfb8aa28591f8225a13043089'
|
||||
'be970a020695fdc4d0f968021f057a1cb625eeb6ee62995560e532d61ffb52dc'
|
||||
'1078b8dacbf2a2cacb4bf835f3e5817c816926604d8e564610604d92e20e02db'
|
||||
'a45340d4f4fc371c70ae96e13ee8ced28930e77b1598b2429ac84a4a31029b86'
|
||||
'08f6a07a149039255d34ff04db08c3de477966118f62339a631b53ffa2dfd85a'
|
||||
'5f3513dc82f2acfe27cfd13c604c89e3b201f828f5934dde649318c18fd656a7'
|
||||
'753517a8b88c5950d516f0fe57a3ef169e0665ba7817d4b8d9976c666829a291'
|
||||
'c47ecb0e8e8c03f8c5451aa12fc2e38e380364c38c411a13aa38b7b41def6989'
|
||||
'81af488135039377f5460acc9e8ff4679f3e2033a847fac90b95d14412c2a70a'
|
||||
'53613a6eee1c215a7becd9a8b97d0ed9a034684a586b9437f35f215a5c859d1a'
|
||||
'a06d62bc579405588f5730a707af602d68f17d764a061f74958135aab34e4d92'
|
||||
|
|
Loading…
Reference in a new issue