mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/firefox to 48.0-1
This commit is contained in:
parent
cb47b6f91a
commit
849908dbbc
5 changed files with 41 additions and 101 deletions
|
@ -4,10 +4,9 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - mozconfig changes for ARM
|
||||
# - patch to remove NEON/SIMD checks from configure
|
||||
# - patches to build on ARM
|
||||
|
||||
highmem=1
|
||||
noautobuild=1
|
||||
|
||||
pkgname=firefox
|
||||
pkgver=48.0
|
||||
|
@ -20,7 +19,7 @@ depends=('gtk3' 'gtk2' 'mozilla-common' 'libxt' 'startup-notification' 'mime-typ
|
|||
'dbus-glib' 'alsa-lib' 'ffmpeg' 'libvpx' 'libevent' 'nss' 'hunspell'
|
||||
'sqlite' 'ttf-font' 'icu')
|
||||
makedepends=('unzip' 'zip' 'diffutils' 'python2' 'yasm' 'mesa' 'imake' 'gconf'
|
||||
'xorg-server-xvfb' 'libpulse' 'inetutils' 'autoconf2.13')
|
||||
'libpulse' 'inetutils' 'xorg-server-xvfb' 'autoconf2.13')
|
||||
optdepends=('networkmanager: Location detection via available WiFi networks'
|
||||
'upower: Battery API')
|
||||
options=('!emptydirs' '!makeflags')
|
||||
|
@ -32,7 +31,6 @@ source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/
|
|||
firefox-symbolic.svg
|
||||
firefox-gtk3-20.patch
|
||||
no-libnotify.patch
|
||||
no-neon.patch
|
||||
mozilla-1253216.patch
|
||||
mozilla-build-arm.patch)
|
||||
sha256sums=('f474113a1ee75a01d43e270bf438ba78b9f7f2e397a66652b43603235fa76e21'
|
||||
|
@ -44,8 +42,8 @@ sha256sums=('f474113a1ee75a01d43e270bf438ba78b9f7f2e397a66652b43603235fa76e21'
|
|||
'c984c8bda3c173349d98f3fa71ec8ff8e8b74e6ca20a3f39f33596dbb4c4d1e8'
|
||||
'e4ebdd14096d177d264a7993dbd5df46463605ff45f783732c26d30b9caa53a7'
|
||||
'c1cceeb8875eee7c61289e82c6c6b0f338c045152f3a5e1a8d87bad67548397f'
|
||||
'fbb6011501a74a8ea6d01c041870fcefb7ef2859c134aedc676e5f6452833f65'
|
||||
'56eecee8162c138c442773d66483886f1242c8dd2b16eed5711ae5e63d9b0e3a')
|
||||
'56eecee8162c138c442773d66483886f1242c8dd2b16eed5711ae5e63d9b0e3a'
|
||||
'f7b7ded7e317dab344cf0a10aa179ea6103a2b3d4000c840a05c3e0c7ca279da')
|
||||
validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A')
|
||||
|
||||
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
|
||||
|
@ -91,16 +89,11 @@ prepare() {
|
|||
|
||||
[[ $CARCH != "aarch64" ]] && echo "ac_add_options --disable-ion" >> .mozconfig \
|
||||
&& echo "ac_add_options --disable-elf-hack" >> .mozconfig
|
||||
[[ $CARCH == "aarch64" ]] && echo "ac_add_options --disable-gold" >> .mozconfig \
|
||||
&& echo 'ac_add_options --disable-jemalloc' >> .mozconfig \
|
||||
[[ $CARCH == "aarch64" ]] && echo 'ac_add_options --disable-jemalloc' >> .mozconfig \
|
||||
&& echo 'ac_add_options --enable-optimize="-O2"' >> .mozconfig
|
||||
LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
|
||||
# patch -p1 -i ../no-neon.patch
|
||||
patch -p1 -i ../mozilla-1253216.patch
|
||||
patch -p1 -i ../mozilla-build-arm.patch
|
||||
echo "ac_add_options --with-arch=armv7-a" >> .mozconfig
|
||||
echo "ac_add_options --with-float-abi=hard" >> .mozconfig
|
||||
echo "ac_add_options --with-fpu=vfpv3-d16" >> .mozconfig
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -6,7 +6,8 @@ ac_add_options --enable-pie
|
|||
|
||||
ac_add_options --enable-official-branding
|
||||
|
||||
ac_add_options --disable-neon
|
||||
# ALARM
|
||||
ac_add_options --disable-webrtc
|
||||
|
||||
# System libraries
|
||||
ac_add_options --with-system-nspr
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
diff -up firefox-45.0/firefox-45.0/js/src/jit/AtomicOperations.h.old firefox-45.0/firefox-45.0/js/src/jit/AtomicOperations.h
|
||||
--- firefox-45.0/firefox-45.0/js/src/jit/AtomicOperations.h.old 2016-03-01 09:45:01.000000000 +0100
|
||||
+++ firefox-45.0/firefox-45.0/js/src/jit/AtomicOperations.h 2016-03-03 13:13:34.915015391 +0100
|
||||
@@ -305,7 +305,7 @@ AtomicOperations::isLockfree(int32_t siz
|
||||
|| defined(__ppc__) || defined(__PPC__)
|
||||
# include "jit/none/AtomicOperations-ppc.h"
|
||||
#elif defined(JS_CODEGEN_NONE)
|
||||
-# include "jit/none/AtomicOperations-none.h"
|
||||
+# include "jit/none/AtomicOperations-ppc.h"
|
||||
diff -up firefox-48.0/js/src/jit/AtomicOperations.h.old firefox-48.0/js/src/jit/AtomicOperations.h
|
||||
--- firefox-48.0/js/src/jit/AtomicOperations.h.old 2016-07-27 09:42:43.148175449 +0200
|
||||
+++ firefox-48.0/js/src/jit/AtomicOperations.h 2016-07-27 09:41:13.000000000 +0200
|
||||
@@ -340,7 +340,7 @@ AtomicOperations::isLockfree(int32_t siz
|
||||
# elif defined(__aarch64__)
|
||||
# include "jit/arm64/AtomicOperations-arm64.h"
|
||||
# else
|
||||
-# include "jit/none/AtomicOperations-none.h" // These MOZ_CRASH() always
|
||||
+# include "jit/none/AtomicOperations-ppc.h"
|
||||
# endif
|
||||
#elif defined(JS_CODEGEN_X86) || defined(JS_CODEGEN_X64)
|
||||
# include "jit/x86-shared/AtomicOperations-x86-shared.h"
|
||||
#else
|
||||
|
|
24
extra/firefox/mozilla-build-arm.patch
Normal file
24
extra/firefox/mozilla-build-arm.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
diff -up firefox-46.0/media/webrtc/trunk/webrtc/build/common.gypi.arm firefox-46.0/media/webrtc/trunk/webrtc/build/common.gypi
|
||||
--- firefox-46.0/media/webrtc/trunk/webrtc/build/common.gypi.arm 2016-04-25 12:03:12.486027089 +0200
|
||||
+++ firefox-46.0/media/webrtc/trunk/webrtc/build/common.gypi 2016-04-25 12:05:55.714644873 +0200
|
||||
@@ -312,20 +312,6 @@
|
||||
'defines': [
|
||||
'WEBRTC_ARCH_ARM',
|
||||
],
|
||||
- 'conditions': [
|
||||
- ['arm_version>=7', {
|
||||
- 'defines': ['WEBRTC_ARCH_ARM_V7',
|
||||
- 'WEBRTC_BUILD_NEON_LIBS'],
|
||||
- 'conditions': [
|
||||
- ['arm_neon==1', {
|
||||
- 'defines': ['WEBRTC_ARCH_ARM_NEON',],
|
||||
- }],
|
||||
- ['arm_neon==0 and arm_neon_optional==1', {
|
||||
- 'defines': ['WEBRTC_DETECT_ARM_NEON',],
|
||||
- }],
|
||||
- ],
|
||||
- }],
|
||||
- ],
|
||||
}],
|
||||
['os_bsd==1', {
|
||||
'defines': [
|
|
@ -1,78 +0,0 @@
|
|||
diff -urN a/build/gyp.mozbuild b/build/gyp.mozbuild
|
||||
--- a/build/gyp.mozbuild 2016-05-12 11:13:12.000000000 -0600
|
||||
+++ b/build/gyp.mozbuild 2016-06-08 06:53:25.183006599 -0600
|
||||
@@ -42,7 +42,7 @@
|
||||
|
||||
# turn off mandatory use of NEON and instead use NEON detection
|
||||
'arm_neon': 0,
|
||||
- 'arm_neon_optional': 1,
|
||||
+ 'arm_neon_optional': 0,
|
||||
|
||||
'moz_widget_toolkit_gonk': 0,
|
||||
'moz_webrtc_omx': 0,
|
||||
diff -urN a/mozglue/build/arm.h b/mozglue/build/arm.h
|
||||
--- a/mozglue/build/arm.h 2016-05-12 11:13:28.000000000 -0600
|
||||
+++ b/mozglue/build/arm.h 2016-06-08 06:53:25.183006599 -0600
|
||||
@@ -69,12 +69,6 @@
|
||||
# endif
|
||||
# endif
|
||||
|
||||
- // When using -mfpu=neon, gcc generates neon instructions.
|
||||
-
|
||||
-# if defined(__ARM_NEON__)
|
||||
-# define MOZILLA_PRESUME_NEON 1
|
||||
-# endif
|
||||
-
|
||||
// Currently we only have CPU detection for Linux via /proc/cpuinfo
|
||||
# if defined(__linux__) || defined(ANDROID)
|
||||
# define MOZILLA_ARM_HAVE_CPUID_DETECTION 1
|
||||
diff -urN a/old-configure b/old-configure
|
||||
--- a/old-configure 2016-06-04 20:01:04.000000000 -0600
|
||||
+++ b/old-configure 2016-06-08 06:53:22.463107876 -0600
|
||||
@@ -7480,14 +7480,7 @@
|
||||
rm -f conftest*
|
||||
echo "$ac_t"""$result"" 1>&6
|
||||
if test "$result" = "yes"; then
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' HAVE_ARM_SIMD ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define HAVE_ARM_SIMD 1
|
||||
-EOF
|
||||
-
|
||||
- HAVE_ARM_SIMD=1
|
||||
+ HAVE_ARM_SIMD=
|
||||
fi
|
||||
|
||||
echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
|
||||
@@ -7519,27 +7512,13 @@
|
||||
rm -f conftest*
|
||||
echo "$ac_t"""$result"" 1>&6
|
||||
if test "$result" = "yes"; then
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' HAVE_ARM_NEON ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define HAVE_ARM_NEON 1
|
||||
-EOF
|
||||
+ HAVE_ARM_NEON=
|
||||
|
||||
- HAVE_ARM_NEON=1
|
||||
-
|
||||
- if test -n "$ARM_ARCH"; then
|
||||
+ if test -n "$ARM_ARCH"; then
|
||||
if test "$ARM_ARCH" -lt 7; then
|
||||
BUILD_ARM_NEON=
|
||||
else
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' BUILD_ARM_NEON ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define BUILD_ARM_NEON 1
|
||||
-EOF
|
||||
-
|
||||
- BUILD_ARM_NEON=1
|
||||
+ BUILD_ARM_NEON=
|
||||
fi
|
||||
fi
|
||||
fi
|
Loading…
Reference in a new issue