mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
community/botan: fix
This commit is contained in:
parent
de603f533c
commit
84f578a6d7
2 changed files with 2 additions and 36 deletions
|
@ -1,25 +0,0 @@
|
||||||
From a5b940718d8a0c87ae92a5e8961fd50b6ddc5532 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
||||||
Date: Sun, 2 Aug 2015 12:12:21 -0600
|
|
||||||
Subject: [PATCH] aarch64 support
|
|
||||||
|
|
||||||
---
|
|
||||||
src/build-data/arch/aarch64.txt | 6 ++++++
|
|
||||||
1 file changed, 6 insertions(+)
|
|
||||||
create mode 100644 src/build-data/arch/aarch64.txt
|
|
||||||
|
|
||||||
diff --git a/src/build-data/arch/aarch64.txt b/src/build-data/arch/aarch64.txt
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..863b000
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/src/build-data/arch/aarch64.txt
|
|
||||||
@@ -0,0 +1,6 @@
|
|
||||||
+endian little
|
|
||||||
+
|
|
||||||
+<aliases>
|
|
||||||
+arm64 # For Debian
|
|
||||||
+</aliases>
|
|
||||||
+
|
|
||||||
--
|
|
||||||
2.4.6
|
|
||||||
|
|
|
@ -6,7 +6,6 @@
|
||||||
# Contributor: Jack Lloyd <jack@randombit.net>
|
# Contributor: Jack Lloyd <jack@randombit.net>
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
# - AArch64 patch
|
|
||||||
# - disable neon on !AArch64
|
# - disable neon on !AArch64
|
||||||
|
|
||||||
pkgname=botan
|
pkgname=botan
|
||||||
|
@ -19,17 +18,9 @@ license=(BSD)
|
||||||
makedepends=(python)
|
makedepends=(python)
|
||||||
optdepends=('python: for using botan2.py')
|
optdepends=('python: for using botan2.py')
|
||||||
validpgpkeys=('621DAF6411E1851C4CF9A2E16211EBF1EFBADFBC')
|
validpgpkeys=('621DAF6411E1851C4CF9A2E16211EBF1EFBADFBC')
|
||||||
source=("https://botan.randombit.net/releases/Botan-${pkgver}.tar.xz"{,.asc}
|
source=("https://botan.randombit.net/releases/Botan-${pkgver}.tar.xz"{,.asc})
|
||||||
'0001-aarch64-support.patch')
|
|
||||||
sha256sums=('1eaefd459d52f27de1805cff8c68792e0610919648ee98e101980e94edb90a63'
|
sha256sums=('1eaefd459d52f27de1805cff8c68792e0610919648ee98e101980e94edb90a63'
|
||||||
'SKIP'
|
'SKIP')
|
||||||
'0e279e3b16e115e26f5dc1edf02a4082f063134513aaf6ad1fbd10a1d2624e37')
|
|
||||||
|
|
||||||
prepare() {
|
|
||||||
cd "${pkgname^}-$pkgver"
|
|
||||||
|
|
||||||
patch -p1 -i ../0001-aarch64-support.patch
|
|
||||||
}
|
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "${pkgname^}-$pkgver"
|
cd "${pkgname^}-$pkgver"
|
||||||
|
|
Loading…
Reference in a new issue