extra/boost to 1.57.0-3

This commit is contained in:
Kevin Mihelich 2015-01-28 17:35:21 +00:00
parent d8214cc483
commit 84ffb02f44
2 changed files with 30 additions and 1 deletions

View file

@ -0,0 +1,24 @@
From 02fff0a69e46b4d77844cf7b8c8d3bc2adbc96bb Mon Sep 17 00:00:00 2001
From: Robert Ramey <ramey@rrsd.com>
Date: Tue, 11 Nov 2014 22:13:05 -0800
Subject: [PATCH] fixed shared_ptr_helper include
---
include/boost/serialization/shared_ptr_helper.hpp | 1 +
1 file changed, 1 insertion(+)
diff --git a/include/boost/serialization/shared_ptr_helper.hpp b/include/boost/serialization/shared_ptr_helper.hpp
index f4784ec..64269a9 100644
--- a/include/boost/serialization/shared_ptr_helper.hpp
+++ b/include/boost/serialization/shared_ptr_helper.hpp
@@ -29,6 +29,7 @@
#include <boost/serialization/singleton.hpp>
#include <boost/serialization/extended_type_info.hpp>
#include <boost/serialization/throw_exception.hpp>
+#include <boost/serialization/type_info_implementation.hpp>
#include <boost/archive/archive_exception.hpp>
#include <boost/archive/detail/decl.hpp>
--
2.2.1

View file

@ -15,19 +15,24 @@ pkgbase=boost
pkgname=('boost-libs' 'boost')
pkgver=1.57.0
_boostver=${pkgver//./_}
pkgrel=2
pkgrel=3
url='http://www.boost.org/'
arch=('i686' 'x86_64')
license=('custom')
makedepends=('icu>=53.1' 'python' 'python2' 'bzip2' 'zlib')
source=(https://downloads.sourceforge.net/project/${pkgbase}/${pkgbase}/${pkgver}/${pkgbase}_${_boostver}.tar.bz2
0001-fixed-shared_ptr_helper-include.patch
0001-Add-missing-include-to-signals2-trackable.hpp.patch)
sha1sums=('e151557ae47afd1b43dc3fac46f8b04a8fe51c12'
'b58746c795a99150545ebfa5dba7997d771b3dcc'
'35bc8ad7493a641ec708a691036fe5319aec70cd')
prepare() {
cd ${pkgbase}_${_boostver}
# https://svn.boost.org/trac/boost/ticket/10749
patch -Np2 -i ../0001-fixed-shared_ptr_helper-include.patch
# https://github.com/boostorg/signals2/pull/8
patch -Np2 -i ../0001-Add-missing-include-to-signals2-trackable.hpp.patch
}