extra/boost to 1.60.0-1

This commit is contained in:
Kevin Mihelich 2015-12-23 18:59:16 +00:00
parent 511c46948a
commit 85238dda8b
2 changed files with 7 additions and 43 deletions

View file

@ -1,28 +0,0 @@
From f410fbd64d887e2a8824f968b0533588489b5430 Mon Sep 17 00:00:00 2001
From: Jonathan Wakely <jwakely@redhat.com>
Date: Wed, 2 Sep 2015 13:02:12 +0100
Subject: [PATCH] Python: Fix condition for make_setter overload.
This fixes the regression caused by 42e7d7b.
Fixes #39
---
include/boost/python/data_members.hpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/boost/python/data_members.hpp b/include/boost/python/data_members.hpp
index 139bde3..5d3309c 100644
--- a/include/boost/python/data_members.hpp
+++ b/include/boost/python/data_members.hpp
@@ -305,7 +305,7 @@ inline object make_setter(D& x)
return detail::make_setter(x, default_call_policies(), is_member_pointer<D>(), 0);
}
-# if BOOST_WORKAROUND(__EDG_VERSION__, <= 238)
+# if !BOOST_WORKAROUND(__EDG_VERSION__, <= 238)
template <class D>
inline object make_setter(D const& x)
{
--
2.6.1

View file

@ -1,5 +1,6 @@
# $Id$
# Maintainer: Ionut Biru <ibiru@archlinux.org>
# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
# Contributor: kevin <kevin@archlinux.org>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
@ -13,24 +14,15 @@
pkgbase=boost
pkgname=('boost-libs' 'boost')
pkgver=1.59.0
pkgver=1.60.0
_boostver=${pkgver//./_}
pkgrel=5
pkgrel=1
url='http://www.boost.org/'
arch=('i686' 'x86_64')
license=('custom')
makedepends=('icu>=55.1' 'python>=3.5' 'python<3.6' 'python2' 'bzip2' 'zlib' 'openmpi')
source=(https://downloads.sourceforge.net/project/${pkgbase}/${pkgbase}/${pkgver}/${pkgbase}_${_boostver}.tar.bz2
0001-Python-Fix-condition-for-make_setter-overload.patch)
sha1sums=('b94de47108b2cdb0f931833a7a9834c2dd3ca46e'
'bd76d969b6f8fbe95f05fba13b57a001764c216c')
prepare() {
cd ${pkgbase}_${_boostver}
# https://github.com/boostorg/python/issues/39
patch -Np2 -i ../0001-Python-Fix-condition-for-make_setter-overload.patch
}
source=(https://downloads.sourceforge.net/project/${pkgbase}/${pkgbase}/${pkgver}/${pkgbase}_${_boostver}.tar.bz2)
sha1sums=('7f56ab507d3258610391b47fef6b11635861175a')
build() {
CFLAGS=`echo $CFLAGS | sed -e 's/armv6/armv6k/'` && CXXFLAGS="$CFLAGS"
@ -71,7 +63,7 @@ build() {
link=shared,static \
toolset=gcc \
python=2.7 \
cflags="${CPPFLAGS} ${CFLAGS} -O3" linkflags="${LDFLAGS}" \
cflags="${CPPFLAGS} ${CFLAGS} -fPIC -O3" linkflags="${LDFLAGS}" \
--layout=system \
--prefix="${_stagedir}" \
${JOBS} \