core/linux-aarch64-rc to 4.9.rc1-1

This commit is contained in:
Kevin Mihelich 2016-10-17 01:28:42 +00:00
parent c5cb26f964
commit 8536bb6174
5 changed files with 323 additions and 207 deletions

View file

@ -1,4 +1,4 @@
From e7009ea09b99367602e649037531749965438961 Mon Sep 17 00:00:00 2001 From 3bd7f7f2f62da582ee1e3908648387710b973f32 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com> From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300 Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
@ -8,7 +8,7 @@ Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
1 file changed, 56 insertions(+) 1 file changed, 56 insertions(+)
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
index dc989a8..912be75 100644 index 831aa33..0362554 100644
--- a/drivers/net/usb/smsc95xx.c --- a/drivers/net/usb/smsc95xx.c
+++ b/drivers/net/usb/smsc95xx.c +++ b/drivers/net/usb/smsc95xx.c
@@ -60,6 +60,7 @@ @@ -60,6 +60,7 @@
@ -19,7 +19,7 @@ index dc989a8..912be75 100644
#define CARRIER_CHECK_DELAY (2 * HZ) #define CARRIER_CHECK_DELAY (2 * HZ)
@@ -80,6 +81,10 @@ static bool turbo_mode = true; @@ -82,6 +83,10 @@ static bool turbo_mode = true;
module_param(turbo_mode, bool, 0644); module_param(turbo_mode, bool, 0644);
MODULE_PARM_DESC(turbo_mode, "Enable multiple frames per Rx transaction"); MODULE_PARM_DESC(turbo_mode, "Enable multiple frames per Rx transaction");
@ -30,7 +30,7 @@ index dc989a8..912be75 100644
static int __must_check __smsc95xx_read_reg(struct usbnet *dev, u32 index, static int __must_check __smsc95xx_read_reg(struct usbnet *dev, u32 index,
u32 *data, int in_pm) u32 *data, int in_pm)
{ {
@@ -809,8 +814,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd) @@ -910,8 +915,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
return generic_mii_ioctl(&dev->mii, if_mii(rq), cmd, NULL); return generic_mii_ioctl(&dev->mii, if_mii(rq), cmd, NULL);
} }
@ -91,5 +91,5 @@ index dc989a8..912be75 100644
/* maybe the boot loader passed the MAC address in devicetree */ /* maybe the boot loader passed the MAC address in devicetree */
-- --
2.9.3 2.10.0

View file

@ -1,77 +0,0 @@
From 4af6314960ef8b5381b9f0f67c01d1b82cc16067 Mon Sep 17 00:00:00 2001
From: Marc Zyngier <Marc.Zyngier@arm.com>
Date: Thu, 11 Aug 2016 18:50:50 +0100
Subject: [PATCH 2/2] arm64: dts: qcom: Fix broken interrupt trigger settings
When a device uses the GIC as its interrupt controller and generates
SPIs, only the values 1 (edge rising) and 4 (level high) are legal.
Anything else is just plain wrong (can't be programmed into the HW),
and leads to aborted driver probes (USB doesn't work with 4.8-rc1
on a Dragonboard 410C).
Signed-off-by: Marc Zyngier <marc.zyngier@arm.com>
Reviewed-by: Stephen Boyd <sboyd@codeaurora.org>
---
arch/arm64/boot/dts/qcom/msm8916.dtsi | 10 +++++-----
arch/arm64/boot/dts/qcom/msm8996.dtsi | 2 +-
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/arch/arm64/boot/dts/qcom/msm8916.dtsi b/arch/arm64/boot/dts/qcom/msm8916.dtsi
index 11bdc24..b010d33 100644
--- a/arch/arm64/boot/dts/qcom/msm8916.dtsi
+++ b/arch/arm64/boot/dts/qcom/msm8916.dtsi
@@ -483,7 +483,7 @@
compatible = "qcom,ci-hdrc";
reg = <0x78d9000 0x400>;
dr_mode = "peripheral";
- interrupts = <GIC_SPI 134 IRQ_TYPE_NONE>;
+ interrupts = <GIC_SPI 134 IRQ_TYPE_LEVEL_HIGH>;
usb-phy = <&usb_otg>;
status = "disabled";
};
@@ -491,7 +491,7 @@
usb_host: ehci@78d9000 {
compatible = "qcom,ehci-host";
reg = <0x78d9000 0x400>;
- interrupts = <GIC_SPI 134 IRQ_TYPE_NONE>;
+ interrupts = <GIC_SPI 134 IRQ_TYPE_LEVEL_HIGH>;
usb-phy = <&usb_otg>;
status = "disabled";
};
@@ -499,8 +499,8 @@
usb_otg: phy@78d9000 {
compatible = "qcom,usb-otg-snps";
reg = <0x78d9000 0x400>;
- interrupts = <GIC_SPI 134 IRQ_TYPE_EDGE_BOTH>,
- <GIC_SPI 140 IRQ_TYPE_EDGE_RISING>;
+ interrupts = <GIC_SPI 134 IRQ_TYPE_LEVEL_HIGH>,
+ <GIC_SPI 140 IRQ_TYPE_LEVEL_HIGH>;
qcom,vdd-levels = <500000 1000000 1320000>;
qcom,phy-init-sequence = <0x44 0x6B 0x24 0x13>;
@@ -594,7 +594,7 @@
<0x200a000 0x002100>;
reg-names = "core", "chnls", "obsrvr", "intr", "cnfg";
interrupt-names = "periph_irq";
- interrupts = <GIC_SPI 190 IRQ_TYPE_NONE>;
+ interrupts = <GIC_SPI 190 IRQ_TYPE_LEVEL_HIGH>;
qcom,ee = <0>;
qcom,channel = <0>;
#address-cells = <2>;
diff --git a/arch/arm64/boot/dts/qcom/msm8996.dtsi b/arch/arm64/boot/dts/qcom/msm8996.dtsi
index 55ec3e8..69ed6e1 100644
--- a/arch/arm64/boot/dts/qcom/msm8996.dtsi
+++ b/arch/arm64/boot/dts/qcom/msm8996.dtsi
@@ -339,7 +339,7 @@
<0x400a000 0x002100>;
reg-names = "core", "chnls", "obsrvr", "intr", "cnfg";
interrupt-names = "periph_irq";
- interrupts = <GIC_SPI 326 IRQ_TYPE_NONE>;
+ interrupts = <GIC_SPI 326 IRQ_TYPE_LEVEL_HIGH>;
qcom,ee = <0>;
qcom,channel = <0>;
#address-cells = <2>;
--
2.9.3

View file

@ -0,0 +1,34 @@
From 795af7a613e7aa678d1b6cab0cb40d6e46f06798 Mon Sep 17 00:00:00 2001
From: Srinivas Kandagatla <srinivas.kandagatla@linaro.org>
Date: Mon, 4 Jul 2016 10:21:48 +0100
Subject: [PATCH 2/2] sound: lpass-cpu: add module licence and description
This patch adds module licence to lpass-cpu driver, without this
patch lpass-cpu module would taint with below error:
snd_soc_lpass_cpu: module license 'unspecified' taints kernel.
Disabling lock debugging due to kernel taint
snd_soc_lpass_cpu: Unknown symbol regmap_write (err 0)
snd_soc_lpass_cpu: Unknown symbol devm_kmalloc (err 0)
...
Acked-by: Kenneth Westfield <kwestfie@codeaurora.org>
Signed-off-by: Srinivas Kandagatla <srinivas.kandagatla@linaro.org>
---
sound/soc/qcom/lpass-cpu.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/sound/soc/qcom/lpass-cpu.c b/sound/soc/qcom/lpass-cpu.c
index 3cde9fb..eff3f9a 100644
--- a/sound/soc/qcom/lpass-cpu.c
+++ b/sound/soc/qcom/lpass-cpu.c
@@ -586,3 +586,6 @@ int asoc_qcom_lpass_cpu_platform_remove(struct platform_device *pdev)
return 0;
}
EXPORT_SYMBOL_GPL(asoc_qcom_lpass_cpu_platform_remove);
+
+MODULE_DESCRIPTION("QTi LPASS CPU Driver");
+MODULE_LICENSE("GPL v2");
--
2.10.0

View file

@ -3,12 +3,12 @@
buildarch=8 buildarch=8
_rcver=4.8 _rcver=4.9
_rcrel=8 _rcrel=1
pkgbase=linux-aarch64-rc pkgbase=linux-aarch64-rc
_srcname=linux-4.$((${_rcver##*.}-1)) #_srcname=linux-4.$((${_rcver##*.}-1))
#_srcname=linux-${_rcver}-rc${_rcrel} _srcname=linux-${_rcver}-rc${_rcrel}
_kernelname=${pkgbase#linux} _kernelname=${pkgbase#linux}
_desc="AArch64 multi-platform (release candidate)" _desc="AArch64 multi-platform (release candidate)"
pkgver=${_rcver}.rc${_rcrel} pkgver=${_rcver}.rc${_rcrel}
@ -18,29 +18,28 @@ url="http://www.kernel.org/"
license=('GPL2') license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git') makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
options=('!strip') options=('!strip')
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz" source=(#"http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/testing/patch-${_rcver}-rc${_rcrel}.xz" #"https://www.kernel.org/pub/linux/kernel/v4.x/testing/patch-${_rcver}-rc${_rcrel}.xz"
#"https://www.kernel.org/pub/linux/kernel/v4.x/testing/${_srcname}.tar.xz" "https://www.kernel.org/pub/linux/kernel/v4.x/testing/${_srcname}.tar.xz"
'0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch' '0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
'0002-arm64-dts-qcom-Fix-broken-interrupt-trigger-settings.patch' '0002-sound-lpass-cpu-add-module-licence-and-description.patch'
'config' 'config'
'linux.preset') 'linux.preset')
md5sums=('5276563eb1f39a048e4a8a887408c031' md5sums=('4c8b0801a93c3e4c536c9f2bf4b4d4a2'
'c510e3c3f731325743a51b68dd8b9e36' '7f0233b10dc18fdfd811d5291586da7c'
'8631a338f1c8f58d467809715c6e6deb' '54c3795c29ee4add02845f13341d505a'
'e56e7fb7d65c129d9f242e672b3744ef' '8e8d5772db20adf22e462955acad9718'
'8c6b2df46bc0ca7b99d85da61fba64d6'
'25d8f6983c9a616946848c0e075a949c') '25d8f6983c9a616946848c0e075a949c')
prepare() { prepare() {
cd "${srcdir}/${_srcname}" cd "${srcdir}/${_srcname}"
# add upstream patch # add upstream patch
patch -sp1 -i ../patch-${_rcver}-rc${_rcrel} #patch -sp1 -i ../patch-${_rcver}-rc${_rcrel}
# ALARM patches # ALARM patches
git apply ../0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch git apply ../0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
git apply ../0002-arm64-dts-qcom-Fix-broken-interrupt-trigger-settings.patch git apply ../0002-sound-lpass-cpu-add-module-licence-and-description.patch
cat "${srcdir}/config" > ./.config cat "${srcdir}/config" > ./.config

File diff suppressed because it is too large Load diff