added extra/kdebindings-python

This commit is contained in:
Kevin Mihelich 2011-10-20 00:57:11 -04:00
parent af511628c9
commit 85605fcfa8
2 changed files with 63 additions and 0 deletions

View file

@ -0,0 +1,41 @@
# $Id: PKGBUILD 139913 2011-10-05 19:09:37Z andrea $
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
# ALARM
# - pykde sip patch for arm
plugrel=1
pkgname=kdebindings-python
pkgver=4.7.2
pkgrel=1
pkgdesc="KDE bindings for Python"
url="http://kde.org/"
arch=('i686' 'x86_64')
license=('GPL' 'LGPL' 'FDL')
groups=('kdebindings')
depends=('kdepim-runtime' 'python2-pyqt' 'qscintilla' 'boost-libs')
makedepends=('cmake' 'automoc4' 'boost')
source=("http://download.kde.org/stable/${pkgver}/src/pykde4-${pkgver}.tar.bz2")
sha1sums=('cc7844851110697f06da60cf4a1ee527eda76087')
build() {
cd "${srcdir}/pykde4-${pkgver}"
patch -Np3 -i "$srcdir/pykde4-4.4.4-arm-sip.patch"
cd "${srcdir}"
mkdir build
cd build
cmake ../pykde4-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DPYTHON_EXECUTABLE=/usr/bin/python2
make
}
package() {
cd "${srcdir}"/build
make DESTDIR="${pkgdir}" install
# Use the python2 executable
find "${pkgdir}" -name '*.py' | xargs sed -i 's|#!/usr/bin/env python|#!/usr/bin/env python2|'
}

View file

@ -0,0 +1,22 @@
diff -Naur pykde4-4.4.3.orig/python/pykde4/CMakeLists.txt pykde4-4.4.3/python/pykde4/CMakeLists.txt
--- pykde4-4.4.3.orig/python/pykde4/CMakeLists.txt 2010-03-29 14:57:40.000000000 +0200
+++ pykde4-4.4.3/python/pykde4/CMakeLists.txt 2010-05-31 15:49:17.095615617 +0200
@@ -75,6 +75,9 @@
${KDEPIMLIBS_INCLUDE_DIRS}
)
+# Pull in ARM configuration options if needed
+STRING(REGEX MATCH "PyQt_qreal_double" SIP_ARM_HACK ${PYQT4_SIP_FLAGS} "")
+
SET(SIP_INCLUDES ${PYQT4_SIP_DIR} sip)
SET(SIP_CONCAT_PARTS 8)
IF (WIN32)
@@ -82,7 +85,7 @@
ELSE (WIN32)
SET(SIP_TAGS ALL WS_X11 ${PYQT4_VERSION_TAG})
ENDIF (WIN32)
-SET(SIP_DISABLE_FEATURES VendorID PyQt_NoPrintRangeBug)
+SET(SIP_DISABLE_FEATURES VendorID PyQt_NoPrintRangeBug ${SIP_ARM_HACK})
# Use an extra option when compiling on Python 3.
IF (PYTHON_3)