community/mysql-workbench: v6 fix

This commit is contained in:
Kevin Mihelich 2018-07-30 23:23:10 +00:00
parent 7351e3d2c1
commit 857718c93e
2 changed files with 18 additions and 0 deletions

View file

@ -45,6 +45,7 @@ source=("https://cdn.mysql.com/Downloads/MySQLGUITools/mysql-workbench-community
'0002-disable-unsupported-operating-system-warning.patch'
'0003-Fix-segfault-in-getIssueBanner-add-missing-wrappers.patch'
'0004-fix-build-for-i686.patch'
'atomic.patch'
'arch_linux_profile.xml')
sha256sums=('0241586c95026a7d4d1b552ba2e33d8e66f6826e8f7e1a692b78c405f80cd334'
'SKIP'
@ -61,6 +62,7 @@ sha256sums=('0241586c95026a7d4d1b552ba2e33d8e66f6826e8f7e1a692b78c405f80cd334'
'2d0f6dcf38f22e49ef7ab9de0230484f1ffac41b7ac40feaf5ef4538ae2f7a18'
'f15d8c8b3cc74d2d0b792316834648620fc2299ce103c6419f4c562f759ad755'
'763925b336d9a398c15fdd757b6567a2f374a822090d32ffdefca018231128a4'
'17294a67637ab7ffff5c39262208e63d21acac72cc2492f616ef1d8e0ae9ac02'
'2ade582ca25f6d6d748bc84a913de39b34dcaa6e621a77740fe143007f2833af')
prepare() {
@ -95,6 +97,12 @@ prepare() {
# make sure to link against bundled libraries
sed -i "/target_link_libraries/s|\\$|-L${srcdir}/install-bundle/usr/lib/ \\$|" backend/wbpublic/CMakeLists.txt
# link v6 against libatomic
cd "${srcdir}/mysql-${_mysql_version}"
if [[ $CARCH == "armv6h" ]]; then
patch -Np0 < "${srcdir}"/atomic.patch
fi
}
build() {

View file

@ -0,0 +1,10 @@
--- client/dump/CMakeLists.txt.orig 2018-07-30 12:36:51.808341641 -0600
+++ client/dump/CMakeLists.txt 2018-07-30 12:37:08.520304037 -0600
@@ -102,6 +102,6 @@
MYSQL_ADD_EXECUTABLE(mysqlpump program.cc)
-TARGET_LINK_LIBRARIES(mysqlpump mysqlpump_lib)
+TARGET_LINK_LIBRARIES(mysqlpump mysqlpump_lib atomic)
SET_TARGET_PROPERTIES(mysqlpump PROPERTIES HAS_CXX TRUE)