community/mythtv to 0.24.1-3

This commit is contained in:
Kevin Mihelich 2011-10-23 01:12:00 -04:00
parent cb244e3e8d
commit 85bc57d7a5
2 changed files with 20 additions and 4 deletions

View file

@ -13,7 +13,7 @@ plugrel=1
pkgname=mythtv
pkgver=0.24.1
pkgrel=2
pkgrel=3
epoch=1
pkgdesc="A Homebrew PVR project"
arch=('i686' 'x86_64')
@ -22,7 +22,7 @@ license=('GPL')
depends=('lame' 'libavc1394' 'libiec61883' 'libpulse' 'libvdpau' 'libxinerama'
'libxvmc' 'lirc-utils' 'mesa' 'mysql-clients' 'mysql-python'
'perl-dbd-mysql' 'perl-libwww' 'perl-net-upnp' 'python-lxml' 'qt'
'wget')
'qtwebkit' 'wget')
makedepends=('yasm')
optdepends=('xmltv: to download tv listings')
backup=('etc/conf.d/mythbackend')
@ -30,17 +30,20 @@ install='mythtv.install'
source=("ftp://ftp.osuosl.org/pub/$pkgname/$pkgname-$pkgver.tar.bz2"
'mythbackend.rc'
'mythbackend.conf'
'mythtv-v4l2-fix.patch')
'mythtv-v4l2-fix.patch'
'build.patch')
md5sums=('6870c679619ec58456e76839745411d8'
'feadcc9ad064d93d6dceab1efc0bd9ed'
'bb8e4033d82428d827570fae9ba15e6a'
'ba5c91df80f0d3f7563a873e71a3725c')
'ba5c91df80f0d3f7563a873e71a3725c'
'939329598673cf63cfe9b14e4ebcd06e')
build() {
cd "$srcdir/$pkgname-$pkgver"
find 'bindings/python' 'contrib' -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
patch -Np2 -i ${srcdir}/mythtv-v4l2-fix.patch
patch -Np1 -i ${srcdir}/build.patch
[[ $CARCH == "arm" ]] && ARCH="armv5te"
[[ $CARCH == "armv7" ]] && ARCH="armv7-a"

View file

@ -0,0 +1,13 @@
diff -Nru a/libs/libmythui/mythrender_opengl.cpp b/libs/libmythui/mythrender_opengl.cpp
--- a/libs/libmythui/mythrender_opengl.cpp 2011-05-16 08:57:52.000000000 +1200
+++ b/libs/libmythui/mythrender_opengl.cpp 2011-10-23 15:05:33.178392264 +1300
@@ -2,6 +2,8 @@
#include "mythrender_opengl.h"
#include "mythxdisplay.h"
+#include <GL/glu.h>
+
#define LOC QString("OpenGL: ")
#define LOC_ERR QString("OpenGL Error: ")
Binary files a/libs/libmythui/.mythrender_opengl.cpp.swp and b/libs/libmythui/.mythrender_opengl.cpp.swp differ