mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/xulrunner to 25.0-1
This commit is contained in:
parent
f69273a95e
commit
860c2e09c6
5 changed files with 81 additions and 107 deletions
|
@ -1,83 +0,0 @@
|
|||
diff --git a/gfx/skia/src/opts/SkBlitRow_opts_arm.cpp b/gfx/skia/src/opts/SkBlitRow_opts_arm.cpp
|
||||
--- a/gfx/skia/src/opts/SkBlitRow_opts_arm.cpp
|
||||
+++ b/gfx/skia/src/opts/SkBlitRow_opts_arm.cpp
|
||||
@@ -26,66 +26,78 @@ static void S32A_D565_Opaque(uint16_t* S
|
||||
asm volatile (
|
||||
"1: \n\t"
|
||||
"ldr r3, [%[src]], #4 \n\t"
|
||||
"cmp r3, #0xff000000 \n\t"
|
||||
"blo 2f \n\t"
|
||||
"and r4, r3, #0x0000f8 \n\t"
|
||||
"and r5, r3, #0x00fc00 \n\t"
|
||||
"and r6, r3, #0xf80000 \n\t"
|
||||
+#if SK_ARM_ARCH >= 6
|
||||
"pld [r1, #32] \n\t"
|
||||
+#endif
|
||||
"lsl r3, r4, #8 \n\t"
|
||||
"orr r3, r3, r5, lsr #5 \n\t"
|
||||
"orr r3, r3, r6, lsr #19 \n\t"
|
||||
"subs %[count], %[count], #1 \n\t"
|
||||
"strh r3, [%[dst]], #2 \n\t"
|
||||
"bne 1b \n\t"
|
||||
"b 4f \n\t"
|
||||
"2: \n\t"
|
||||
"lsrs r7, r3, #24 \n\t"
|
||||
"beq 3f \n\t"
|
||||
"ldrh r4, [%[dst]] \n\t"
|
||||
"rsb r7, r7, #255 \n\t"
|
||||
"and r6, r4, #0x001f \n\t"
|
||||
-#if SK_ARM_ARCH == 6
|
||||
+#if SK_ARM_ARCH <= 6
|
||||
"lsl r5, r4, #21 \n\t"
|
||||
"lsr r5, r5, #26 \n\t"
|
||||
#else
|
||||
"ubfx r5, r4, #5, #6 \n\t"
|
||||
#endif
|
||||
+#if SK_ARM_ARCH >= 6
|
||||
"pld [r0, #16] \n\t"
|
||||
+#endif
|
||||
"lsr r4, r4, #11 \n\t"
|
||||
#ifdef SK_ARM_HAS_EDSP
|
||||
"smulbb r6, r6, r7 \n\t"
|
||||
"smulbb r5, r5, r7 \n\t"
|
||||
"smulbb r4, r4, r7 \n\t"
|
||||
#else
|
||||
"mul r6, r6, r7 \n\t"
|
||||
"mul r5, r5, r7 \n\t"
|
||||
"mul r4, r4, r7 \n\t"
|
||||
#endif
|
||||
+#if SK_ARM_ARCH >= 6
|
||||
"uxtb r7, r3, ROR #16 \n\t"
|
||||
"uxtb ip, r3, ROR #8 \n\t"
|
||||
+#else
|
||||
+ "mov ip, #0xff \n\t"
|
||||
+ "and r7, ip, r3, ROR #16 \n\t"
|
||||
+ "and ip, ip, r3, ROR #8 \n\t"
|
||||
+#endif
|
||||
"and r3, r3, #0xff \n\t"
|
||||
"add r6, r6, #16 \n\t"
|
||||
"add r5, r5, #32 \n\t"
|
||||
"add r4, r4, #16 \n\t"
|
||||
"add r6, r6, r6, lsr #5 \n\t"
|
||||
"add r5, r5, r5, lsr #6 \n\t"
|
||||
"add r4, r4, r4, lsr #5 \n\t"
|
||||
"add r6, r7, r6, lsr #5 \n\t"
|
||||
"add r5, ip, r5, lsr #6 \n\t"
|
||||
"add r4, r3, r4, lsr #5 \n\t"
|
||||
"lsr r6, r6, #3 \n\t"
|
||||
"and r5, r5, #0xfc \n\t"
|
||||
"and r4, r4, #0xf8 \n\t"
|
||||
"orr r6, r6, r5, lsl #3 \n\t"
|
||||
"orr r4, r6, r4, lsl #8 \n\t"
|
||||
"strh r4, [%[dst]], #2 \n\t"
|
||||
+#if SK_ARM_ARCH >= 6
|
||||
"pld [r1, #32] \n\t"
|
||||
+#endif
|
||||
"subs %[count], %[count], #1 \n\t"
|
||||
"bne 1b \n\t"
|
||||
"b 4f \n\t"
|
||||
"3: \n\t"
|
||||
"subs %[count], %[count], #1 \n\t"
|
||||
"add %[dst], %[dst], #2 \n\t"
|
||||
"bne 1b \n\t"
|
||||
"4: \n\t"
|
|
@ -1,46 +1,44 @@
|
|||
# $Id: PKGBUILD 169809 2012-10-29 21:12:03Z ibiru $
|
||||
# Maintainer: Jan de Groot <jgc@archlinux.org>
|
||||
# Maintainer: Connor Behan <connor.behan@gmail.com>
|
||||
# Contributor: Jan de Groot <jgc@archlinux.org>
|
||||
# Contributor: Alexander Baldeck <alexander@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich
|
||||
# - added --disable-elf-hack/neon to mozconfig
|
||||
# - set extra CFLAG for v5
|
||||
# - patch to fix build on v5 (https://bugzilla.mozilla.org/show_bug.cgi?id=901208)
|
||||
|
||||
highmem=1
|
||||
|
||||
pkgname=xulrunner
|
||||
pkgver=23.0.1
|
||||
pkgver=25.0
|
||||
pkgrel=1
|
||||
pkgdesc="Mozilla Runtime Environment"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('MPL' 'GPL' 'LGPL')
|
||||
depends=('gtk2' 'mozilla-common' 'nss>=3.14.1' 'libxt' 'libxrender' 'hunspell' 'startup-notification' 'mime-types' 'dbus-glib' 'alsa-lib' 'libevent' 'sqlite>=3.7.4' 'libvpx' 'python2')
|
||||
makedepends=('zip' 'unzip' 'pkg-config' 'diffutils' 'yasm' 'mesa' 'autoconf2.13')
|
||||
depends=('gtk2' 'mozilla-common' 'nss>=3.15' 'libxt' 'hunspell' 'startup-notification' 'mime-types' 'dbus-glib' 'alsa-lib' 'libevent' 'libvpx' 'python2')
|
||||
makedepends=('zip' 'unzip' 'pkg-config' 'diffutils' 'yasm' 'mesa' 'autoconf2.13' 'gstreamer0.10-base>=0.10.25')
|
||||
url="http://wiki.mozilla.org/XUL:Xul_Runner"
|
||||
source=(ftp://ftp.mozilla.org/pub/mozilla.org/xulrunner/releases/$pkgver/source/xulrunner-$pkgver.source.tar.bz2
|
||||
mozconfig
|
||||
mozilla-pkgconfig.patch
|
||||
shared-libs.patch
|
||||
0026-Bug-901208-Fix-ARM-v4t.patch)
|
||||
freetype-headers.patch)
|
||||
options=('!emptydirs' 'staticlibs')
|
||||
replaces=('xulrunner-oss')
|
||||
sha256sums=('50d70813cee1c966a6037957206626bb62dc047b011d2e4fab11c559008f9336'
|
||||
'9823b9c6945b05f6a7bf712dae6349e00598ffa6f79376fe542a5cc1e5a596fb'
|
||||
sha256sums=('796614f7a7a02ae4bceb5d1f2dce2de5096f9e390e91ec09fa5a40bcdff45cb1'
|
||||
'd47f0538966e9dbb12e4390e76e5d79ef5c34c6279d53c56bc810f5e4a6493fb'
|
||||
'23485d937035648add27a7657f6934dc5b295e886cdb0506eebd02a43d07f269'
|
||||
'e2b4a00d14f4ba69c62b3f9ef9908263fbab179ba8004197cbc67edbd916fdf1'
|
||||
'b90076ef2e419bfbf27d9531c3d1202c18fa4b963a9b928da43a3034cf83ddd4')
|
||||
'b62975b25fa3a0dc3e57e32c2b980daf2ee2497eff1d9661595b8e8bafbaa5f8')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/mozilla-release"
|
||||
cp "$srcdir/mozconfig" .mozconfig
|
||||
|
||||
# Fix ARM builds
|
||||
patch -Np1 -i ../0026-Bug-901208-Fix-ARM-v4t.patch
|
||||
|
||||
#fix libdir/sdkdir - fedora
|
||||
patch -Np1 -i ../mozilla-pkgconfig.patch
|
||||
patch -Np1 -i ../shared-libs.patch
|
||||
patch -Np1 -i ../freetype-headers.patch
|
||||
|
||||
# WebRTC build tries to execute "python" and expects Python 2
|
||||
# Workaround taken from chromium PKGBUILD
|
||||
|
@ -68,6 +66,7 @@ package() {
|
|||
cd "$srcdir/mozilla-release"
|
||||
make -j1 -f client.mk DESTDIR="$pkgdir" install
|
||||
|
||||
# Use system-provided dictionaries
|
||||
rm -rf "$pkgdir"/usr/lib/xulrunner-$pkgver/{dictionaries,hyphenation}
|
||||
ln -sf /usr/share/hunspell "$pkgdir/usr/lib/xulrunner-$pkgver/dictionaries"
|
||||
ln -sf /usr/share/hyphen "$pkgdir/usr/lib/xulrunner-$pkgver/hyphenation"
|
||||
|
@ -77,6 +76,8 @@ package() {
|
|||
echo "/usr/lib/xulrunner-$pkgver" > $pkgdir/etc/ld.so.conf.d/xulrunner.conf
|
||||
|
||||
chmod +x "${pkgdir}/usr/lib/xulrunner-devel-$pkgver/sdk/bin/xpt.py"
|
||||
chmod +x "${pkgdir}/usr/lib/xulrunner-devel-$pkgver/sdk/bin/xpcshell"
|
||||
ln -s /usr/lib/xulrunner-devel-$pkgver/sdk/bin/xpcshell "${pkgdir}/usr/lib/xulrunner-$pkgver/xpcshell"
|
||||
sed -i 's|!/usr/bin/env python$|!/usr/bin/env python2|' \
|
||||
"$pkgdir"/usr/lib/xulrunner-devel-$pkgver/sdk/bin/{xpt,header,typelib,xpidl}.py
|
||||
}
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- js/src/ion/shared/IonAssemblerBufferWithConstantPools.h.orig 2013-06-21 16:17:35.029032287 -0500
|
||||
+++ js/src/ion/shared/IonAssemblerBufferWithConstantPools.h 2013-06-21 16:18:05.842731689 -0500
|
||||
@@ -675,7 +675,7 @@
|
||||
JS_ASSERT(perforatedNode != NULL);
|
||||
if (numDumps >= (1<<logBasePoolInfo) && (numDumps & (numDumps-1)) == 0) {
|
||||
// need to resize.
|
||||
- poolInfo = static_cast<PoolInfo*>(realloc_(poolInfo, sizeof(PoolInfo) * numDumps,
|
||||
+ poolInfo = static_cast<PoolInfo*>(this->realloc_(poolInfo, sizeof(PoolInfo) * numDumps,
|
||||
sizeof(PoolInfo) * numDumps * 2));
|
||||
if (poolInfo == NULL) {
|
||||
this->fail_oom();
|
66
community/xulrunner/freetype-headers.patch
Normal file
66
community/xulrunner/freetype-headers.patch
Normal file
|
@ -0,0 +1,66 @@
|
|||
diff -Nur mozilla-release.orig/config/system-headers mozilla-release/config/system-headers
|
||||
--- mozilla-release.orig/config/system-headers
|
||||
+++ mozilla-release/config/system-headers
|
||||
@@ -408,16 +408,29 @@ freetype/ftoutln.h
|
||||
freetype/ttnameid.h
|
||||
freetype/tttables.h
|
||||
freetype/t1tables.h
|
||||
freetype/ftlcdfil.h
|
||||
freetype/ftsizes.h
|
||||
freetype/ftadvanc.h
|
||||
freetype/ftbitmap.h
|
||||
freetype/ftxf86.h
|
||||
+freetype.h
|
||||
+ftcache.h
|
||||
+ftglyph.h
|
||||
+ftsynth.h
|
||||
+ftoutln.h
|
||||
+ttnameid.h
|
||||
+tttables.h
|
||||
+t1tables.h
|
||||
+ftlcdfil.h
|
||||
+ftsizes.h
|
||||
+ftadvanc.h
|
||||
+ftbitmap.h
|
||||
+ftxf86.h
|
||||
fribidi/fribidi.h
|
||||
FSp_fopen.h
|
||||
fstream
|
||||
fstream.h
|
||||
ft2build.h
|
||||
fts.h
|
||||
gconf/gconf-client.h
|
||||
Gdiplus.h
|
||||
diff -Nur mozilla-release.orig/js/src/config/system-headers mozilla-release/js/src/config/system-headers
|
||||
--- mozilla-release.orig/js/src/config/system-headers
|
||||
+++ mozilla-release/js/src/config/system-headers
|
||||
@@ -408,16 +408,29 @@ freetype/ftoutln.h
|
||||
freetype/ttnameid.h
|
||||
freetype/tttables.h
|
||||
freetype/t1tables.h
|
||||
freetype/ftlcdfil.h
|
||||
freetype/ftsizes.h
|
||||
freetype/ftadvanc.h
|
||||
freetype/ftbitmap.h
|
||||
freetype/ftxf86.h
|
||||
+freetype.h
|
||||
+ftcache.h
|
||||
+ftglyph.h
|
||||
+ftsynth.h
|
||||
+ftoutln.h
|
||||
+ttnameid.h
|
||||
+tttables.h
|
||||
+t1tables.h
|
||||
+ftlcdfil.h
|
||||
+ftsizes.h
|
||||
+ftadvanc.h
|
||||
+ftbitmap.h
|
||||
+ftxf86.h
|
||||
fribidi/fribidi.h
|
||||
FSp_fopen.h
|
||||
fstream
|
||||
fstream.h
|
||||
ft2build.h
|
||||
fts.h
|
||||
gconf/gconf-client.h
|
||||
Gdiplus.h
|
|
@ -20,12 +20,13 @@ ac_add_options --with-system-libvpx
|
|||
ac_add_options --enable-system-hunspell
|
||||
ac_add_options --enable-system-sqlite
|
||||
ac_add_options --enable-system-ffi
|
||||
#ac_add_options --enable-system-cairo
|
||||
ac_add_options --enable-system-cairo
|
||||
ac_add_options --enable-system-pixman
|
||||
ac_add_options --with-pthreads
|
||||
|
||||
# Features
|
||||
ac_add_options --enable-startup-notification
|
||||
ac_add_options --enable-gstreamer
|
||||
|
||||
ac_add_options --disable-crashreporter
|
||||
ac_add_options --disable-updater
|
||||
|
|
Loading…
Reference in a new issue