mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/libvpx to 1.8.2-1
This commit is contained in:
parent
2d3d6fd668
commit
865272a93b
2 changed files with 17 additions and 11 deletions
|
@ -1,4 +1,4 @@
|
|||
From e26cf640ca99b84c2536a9b9254777e1110af911 Mon Sep 17 00:00:00 2001
|
||||
From aa08687c9d6a49b22909a88584d593f86e9e1a92 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 15 Jan 2017 12:11:57 -0700
|
||||
Subject: [PATCH] ARM fixes
|
||||
|
@ -9,7 +9,7 @@ Subject: [PATCH] ARM fixes
|
|||
2 files changed, 13 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/build/make/configure.sh b/build/make/configure.sh
|
||||
index 472e7dea7b..3c0831fce1 100644
|
||||
index d05d0fa12a..ba5084b4bf 100644
|
||||
--- a/build/make/configure.sh
|
||||
+++ b/build/make/configure.sh
|
||||
@@ -737,6 +737,14 @@ process_common_toolchain() {
|
||||
|
@ -27,7 +27,7 @@ index 472e7dea7b..3c0831fce1 100644
|
|||
armv7*-hardfloat* | armv7*-gnueabihf | arm-*-gnueabihf)
|
||||
tgt_isa=armv7
|
||||
float_abi=hard
|
||||
@@ -961,7 +969,7 @@ process_common_toolchain() {
|
||||
@@ -937,7 +945,7 @@ process_common_toolchain() {
|
||||
soft_enable neon
|
||||
;;
|
||||
armv7|armv7s)
|
||||
|
@ -36,7 +36,7 @@ index 472e7dea7b..3c0831fce1 100644
|
|||
# Only enable neon_asm when neon is also enabled.
|
||||
enabled neon && soft_enable neon_asm
|
||||
# If someone tries to force it through, die.
|
||||
@@ -981,13 +989,6 @@ process_common_toolchain() {
|
||||
@@ -957,13 +965,6 @@ process_common_toolchain() {
|
||||
arch_int=${arch_int%%te}
|
||||
tune_cflags="-mtune="
|
||||
if [ ${tgt_isa} = "armv7" ] || [ ${tgt_isa} = "armv7s" ]; then
|
||||
|
@ -50,7 +50,7 @@ index 472e7dea7b..3c0831fce1 100644
|
|||
check_add_cflags -march=armv7-a -mfloat-abi=${float_abi}
|
||||
check_add_asflags -march=armv7-a -mfloat-abi=${float_abi}
|
||||
|
||||
@@ -999,8 +1000,8 @@ EOF
|
||||
@@ -975,8 +976,8 @@ EOF
|
||||
check_add_cflags -march=armv8-a
|
||||
check_add_asflags -march=armv8-a
|
||||
else
|
||||
|
@ -62,7 +62,7 @@ index 472e7dea7b..3c0831fce1 100644
|
|||
|
||||
enabled debug && add_asflags -g
|
||||
diff --git a/configure b/configure
|
||||
index d29e00ad86..c44ccee5bd 100755
|
||||
index 181e27b7c0..3ae0e3ba09 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -102,6 +102,8 @@ all_platforms="${all_platforms} arm64-darwin-gcc"
|
||||
|
@ -75,5 +75,5 @@ index d29e00ad86..c44ccee5bd 100755
|
|||
all_platforms="${all_platforms} armv7-darwin-gcc" #neon Cortex-A8
|
||||
all_platforms="${all_platforms} armv7-linux-rvct" #neon Cortex-A8
|
||||
--
|
||||
2.21.0
|
||||
2.23.0
|
||||
|
||||
|
|
|
@ -7,7 +7,7 @@
|
|||
# - disable neon and neon-asm
|
||||
|
||||
pkgname=libvpx
|
||||
pkgver=1.8.1
|
||||
pkgver=1.8.2
|
||||
pkgrel=1
|
||||
pkgdesc='VP8 and VP9 codec'
|
||||
arch=(x86_64)
|
||||
|
@ -18,10 +18,16 @@ makedepends=(
|
|||
nasm
|
||||
)
|
||||
provides=(libvpx.so)
|
||||
source=(git+https://chromium.googlesource.com/webm/libvpx#tag=v${pkgver}
|
||||
source=(git+https://chromium.googlesource.com/webm/libvpx#tag=7ec7a33a081aeeb53fed1a8d87e4cbd189152527
|
||||
0001-ARM-fixes.patch)
|
||||
sha256sums=('SKIP'
|
||||
'91c82653dd9ae1f36d78efd1ae6f9e7a642c6cac68e391ab95460c07988bd885')
|
||||
'fde43bd72223854fe6d7aadd4b8d9947de902124fec01a5578ca12ca9436c810')
|
||||
|
||||
pkgver() {
|
||||
cd libvpx
|
||||
|
||||
git describe --tags | sed 's/^v//'
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd libvpx
|
||||
|
@ -34,7 +40,7 @@ build() {
|
|||
|
||||
[[ $CARCH != "aarch64" ]] && CONFIG="--disable-neon --disable-neon-asm"
|
||||
./configure \
|
||||
--prefix='/usr' \
|
||||
--prefix=/usr \
|
||||
--disable-install-docs \
|
||||
--disable-install-srcs \
|
||||
--enable-pic \
|
||||
|
|
Loading…
Reference in a new issue