mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
community/agave to 0.4.7-10
This commit is contained in:
parent
6aae940efe
commit
86570c79c1
2 changed files with 64 additions and 4 deletions
|
@ -9,22 +9,24 @@
|
|||
|
||||
pkgname=agave
|
||||
pkgver=0.4.7
|
||||
pkgrel=9
|
||||
pkgrel=10
|
||||
pkgdesc="Colorscheme designer tool for GNOME"
|
||||
arch=('x86_64')
|
||||
url="https://web.archive.org/web/20170327063642/http://home.gna.org/colorscheme/"
|
||||
license=('GPL')
|
||||
depends=('libglademm' 'gconfmm')
|
||||
depends=('libglademm')
|
||||
makedepends=('gnome-doc-utils' 'intltool' 'boost')
|
||||
source=(http://ftp.debian.org/debian/pool/main/a/$pkgname/${pkgname}_$pkgver.orig.tar.gz
|
||||
agave-0.4.7-mdv-fix-str-fmt.patch
|
||||
schemebox.patch
|
||||
drop-libgnome.patch
|
||||
fix-build-without-gconf.patch
|
||||
compat-round.patch)
|
||||
sha256sums=('4005361ab1b137029c7d50afbbfbae7d83bdde7cec3e155a85eed59f6ec4e6fc'
|
||||
'132008f0bbe040c59bbc134d9ca3eb244967a66f95bf113d94e976b8ed776c6c'
|
||||
'0471ac9d7057f83d3fc667d7387837a2d85cb0d15a58853dd673a6ea1459623c'
|
||||
'8651250047b5882b00d28ac6d7ff587f53f99bd681c201545b6cf25c5acaaac6'
|
||||
'225f9a5cfebea4f9c1d4120611394eb148ffb9a6c151e79f749df1749e015c91'
|
||||
'1cade4acc25b4da1999d6eb148e2f48ac3d6633fe4e695a6a1fc217d7c477a78')
|
||||
|
||||
prepare() {
|
||||
|
@ -39,6 +41,9 @@ prepare() {
|
|||
# Remove deprecated libgnome dependency
|
||||
patch -Np1 -i ../drop-libgnome.patch
|
||||
|
||||
# Fix build without gconfmm installed
|
||||
patch -Np1 -i ../fix-build-without-gconf.patch
|
||||
|
||||
# Build fix from Debian
|
||||
patch -Np1 -i ../compat-round.patch
|
||||
}
|
||||
|
@ -47,12 +52,12 @@ build() {
|
|||
cd $pkgname-$pkgver
|
||||
CXXFLAGS+=' -std=c++11'
|
||||
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
|
||||
--disable-scrollkeeper --disable-gnome --disable-schemas-install \
|
||||
--with-gconf-schema-file-dir=/usr/share/gconf/schemas
|
||||
--disable-scrollkeeper --disable-gnome --disable-gconf
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname-$pkgver
|
||||
make DESTDIR="$pkgdir" install
|
||||
rm "$pkgdir/agave.schemas"
|
||||
}
|
||||
|
|
55
community/agave/fix-build-without-gconf.patch
Normal file
55
community/agave/fix-build-without-gconf.patch
Normal file
|
@ -0,0 +1,55 @@
|
|||
diff -Naur agave-0.4.7.orig/src/gcs-conf.cc agave-0.4.7/src/gcs-conf.cc
|
||||
--- agave-0.4.7.orig/src/gcs-conf.cc 2008-02-26 04:07:02.000000000 +0100
|
||||
+++ agave-0.4.7/src/gcs-conf.cc 2018-09-05 13:00:23.733940123 +0200
|
||||
@@ -26,6 +26,7 @@
|
||||
#include "config.h"
|
||||
#include "gcs-conf.h"
|
||||
#include "core/gcs-color.h"
|
||||
+#include <glibmm.h>
|
||||
#ifdef HAVE_GCONFMM
|
||||
#include <gconfmm/client.h>
|
||||
#include <gconfmm/value.h>
|
||||
@@ -36,6 +37,7 @@
|
||||
// gconf recommends storing enumerations as strings rather than integers
|
||||
// since it's more robust against changes in enumeration order and is more
|
||||
// human-readable. This is a helper for gconf_string_to_enum and vice versa
|
||||
+#ifdef HAVE_GCONFMM
|
||||
static GConfEnumStringPair schemetype_lookup_table[] =
|
||||
{
|
||||
{ SCHEME_COMPLEMENTS, "COMPLEMENTS" },
|
||||
@@ -59,6 +61,7 @@
|
||||
operator double() { return get_float(); }
|
||||
operator float() { return get_float(); }
|
||||
};
|
||||
+#endif // HAVE_GCONFMM
|
||||
|
||||
const Glib::ustring Conf::APP_DIR = "/apps/agave";
|
||||
|
||||
@@ -128,8 +131,10 @@
|
||||
|
||||
void Conf::set_last_scheme_type(tSchemeType t)
|
||||
{
|
||||
+#ifdef HAVE_GCONFMM
|
||||
Glib::ustring schemetype_string = gconf_enum_to_string(schemetype_lookup_table, t);
|
||||
set_value(KEY_LAST_SCHEME_TYPE, schemetype_string);
|
||||
+#endif // HAVE_GCONFMM
|
||||
}
|
||||
|
||||
|
||||
@@ -137,12 +142,16 @@
|
||||
{
|
||||
Glib::ustring scheme_type;
|
||||
tSchemeType t;
|
||||
+#ifdef HAVE_GCONFMM
|
||||
if (!get_value(KEY_LAST_SCHEME_TYPE, scheme_type) ||
|
||||
!gconf_string_to_enum(schemetype_lookup_table,
|
||||
scheme_type.c_str(), reinterpret_cast<int*>(&t)))
|
||||
{
|
||||
+#endif // HAVE_GCONFMM
|
||||
t = SCHEME_TRIADS;
|
||||
+#ifdef HAVE_GCONFMM
|
||||
}
|
||||
+#endif // HAVE_GCONFMM
|
||||
return t;
|
||||
}
|
||||
|
Loading…
Reference in a new issue